diff options
Diffstat (limited to 'recipes-graphics')
3 files changed, 47 insertions, 6 deletions
diff --git a/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch b/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch index 025b6bc..3da4a48 100644 --- a/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch +++ b/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 8d9299d219a2a4f76f8278973584e1a9f7116c78 Mon Sep 17 00:00:00 2001 | 1 | From 6e8562b45a2e14490da2ca258c9ce3d7bc8375f3 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 10 May 2017 06:39:34 +0000 | 3 | Date: Wed, 10 May 2017 06:39:34 +0000 |
4 | Subject: [PATCH 14/16] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT | 4 | Subject: [PATCH 14/16] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT |
@@ -8,23 +8,28 @@ Upstream-Status: Pending | |||
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | --- | 10 | --- |
11 | interface/khronos/include/GLES2/gl2ext.h | 3 +++ | 11 | interface/khronos/include/GLES2/gl2ext.h | 8 ++++++++ |
12 | 1 file changed, 3 insertions(+) | 12 | 1 file changed, 8 insertions(+) |
13 | 13 | ||
14 | diff --git a/interface/khronos/include/GLES2/gl2ext.h b/interface/khronos/include/GLES2/gl2ext.h | 14 | diff --git a/interface/khronos/include/GLES2/gl2ext.h b/interface/khronos/include/GLES2/gl2ext.h |
15 | index 4eacf7f..283e3e1 100644 | 15 | index 4eacf7f..b1acc9f 100644 |
16 | --- a/interface/khronos/include/GLES2/gl2ext.h | 16 | --- a/interface/khronos/include/GLES2/gl2ext.h |
17 | +++ b/interface/khronos/include/GLES2/gl2ext.h | 17 | +++ b/interface/khronos/include/GLES2/gl2ext.h |
18 | @@ -327,6 +327,9 @@ typedef void* GLeglImageOES; | 18 | @@ -327,6 +327,14 @@ typedef void* GLeglImageOES; |
19 | #define GL_RGBX_BRCM 0x80EE | 19 | #define GL_RGBX_BRCM 0x80EE |
20 | #endif | 20 | #endif |
21 | 21 | ||
22 | +#ifndef GL_EXT_texture_rg | ||
23 | +#define GL_EXT_texture_rg 1 | ||
24 | +#define GL_RED_EXT 0x1903 | ||
25 | +#define GL_RG_EXT 0x8227 | ||
22 | +#define GL_R8_EXT 0x8229 | 26 | +#define GL_R8_EXT 0x8229 |
23 | +#define GL_RG8_EXT 0x822B | 27 | +#define GL_RG8_EXT 0x822B |
28 | +#endif /* GL_EXT_texture_rg */ | ||
24 | + | 29 | + |
25 | /* GL_EXT_texture_type_2_10_10_10_REV */ | 30 | /* GL_EXT_texture_type_2_10_10_10_REV */ |
26 | #ifndef GL_EXT_texture_type_2_10_10_10_REV | 31 | #ifndef GL_EXT_texture_type_2_10_10_10_REV |
27 | #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368 | 32 | #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368 |
28 | -- | 33 | -- |
29 | 2.16.1 | 34 | 2.18.0 |
30 | 35 | ||
diff --git a/recipes-graphics/userland/userland/0018-Add-EGL_IMG_context_priority-related-defines.patch b/recipes-graphics/userland/userland/0018-Add-EGL_IMG_context_priority-related-defines.patch new file mode 100644 index 0000000..330fb3e --- /dev/null +++ b/recipes-graphics/userland/userland/0018-Add-EGL_IMG_context_priority-related-defines.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From ca43aae3e1879d2595cfee80032322f5fdfdea11 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 15 Jul 2018 00:48:38 -0700 | ||
4 | Subject: [PATCH] Add EGL_IMG_context_priority related defines | ||
5 | |||
6 | These defines are needed for compiling weston 4.x | ||
7 | taken from Khronos headers | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | interface/khronos/include/EGL/eglext.h | 8 ++++++++ | ||
12 | 1 file changed, 8 insertions(+) | ||
13 | |||
14 | diff --git a/interface/khronos/include/EGL/eglext.h b/interface/khronos/include/EGL/eglext.h | ||
15 | index dcc90ce..6842bf9 100755 | ||
16 | --- a/interface/khronos/include/EGL/eglext.h | ||
17 | +++ b/interface/khronos/include/EGL/eglext.h | ||
18 | @@ -93,6 +93,14 @@ typedef EGLImageKHR (EGLAPIENTRYP PFNEGLCREATEIMAGEKHRPROC) (EGLDisplay dpy, EGL | ||
19 | typedef EGLBoolean (EGLAPIENTRYP PFNEGLDESTROYIMAGEKHRPROC) (EGLDisplay dpy, EGLImageKHR image); | ||
20 | #endif | ||
21 | |||
22 | +#ifndef EGL_IMG_context_priority | ||
23 | +#define EGL_IMG_context_priority 1 | ||
24 | +#define EGL_CONTEXT_PRIORITY_LEVEL_IMG 0x3102 | ||
25 | +#define EGL_CONTEXT_PRIORITY_HIGH_IMG 0x3101 | ||
26 | +#define EGL_CONTEXT_PRIORITY_MEDIUM_IMG 0x3102 | ||
27 | +#define EGL_CONTEXT_PRIORITY_LOW_IMG 0x3103 | ||
28 | +#endif /* EGL_IMG_context_priority */ | ||
29 | + | ||
30 | #ifndef EGL_KHR_vg_parent_image | ||
31 | #define EGL_KHR_vg_parent_image 1 | ||
32 | #define EGL_VG_PARENT_IMAGE_KHR 0x30BA /* eglCreateImageKHR target */ | ||
33 | -- | ||
34 | 2.18.0 | ||
35 | |||
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb index 2257d15..3903284 100644 --- a/recipes-graphics/userland/userland_git.bb +++ b/recipes-graphics/userland/userland_git.bb | |||
@@ -39,6 +39,7 @@ SRC_URI = "\ | |||
39 | file://0015-EGL-glplatform.h-define-EGL_CAST.patch \ | 39 | file://0015-EGL-glplatform.h-define-EGL_CAST.patch \ |
40 | file://0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch \ | 40 | file://0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch \ |
41 | file://0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch \ | 41 | file://0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch \ |
42 | file://0018-Add-EGL_IMG_context_priority-related-defines.patch \ | ||
42 | " | 43 | " |
43 | S = "${WORKDIR}/git" | 44 | S = "${WORKDIR}/git" |
44 | 45 | ||