summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/userland/userland-nogl.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/userland/userland-nogl.bb')
-rw-r--r--recipes-graphics/userland/userland-nogl.bb87
1 files changed, 87 insertions, 0 deletions
diff --git a/recipes-graphics/userland/userland-nogl.bb b/recipes-graphics/userland/userland-nogl.bb
new file mode 100644
index 0000000..ec5cbdc
--- /dev/null
+++ b/recipes-graphics/userland/userland-nogl.bb
@@ -0,0 +1,87 @@
1DESCRIPTION = "This repository contains the source code for the ARM side \
2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \
3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\
4vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG."
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
7
8COMPATIBLE_MACHINE = "^rpi$"
9
10SRCBRANCH = "master"
11SRCFORK = "raspberrypi"
12SRCREV = "409dfcd90bae0a09b1b8c1f718a532728d26cde2"
13
14# Use the date of the above commit as the package version. Update this when
15# SRCREV is changed.
16PV = "20180702"
17
18SRC_URI = "\
19 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
20 file://0001-Allow-applications-to-set-next-resource-handle.patch \
21 file://0002-wayland-Add-support-for-the-Wayland-winsys.patch \
22 file://0003-wayland-Add-Wayland-example.patch \
23 file://0004-wayland-egl-Add-bcm_host-to-dependencies.patch \
24 file://0005-interface-remove-faulty-assert-to-make-weston-happy-.patch \
25 file://0006-zero-out-wl-buffers-in-egl_surface_free.patch \
26 file://0007-initialize-front-back-wayland-buffers.patch \
27 file://0008-Remove-RPC_FLUSH.patch \
28 file://0009-fix-cmake-dependency-race.patch \
29 file://0010-Fix-for-framerate-with-nested-composition.patch \
30 file://0011-build-shared-library-for-vchostif.patch \
31 file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \
32 file://0013-Implement-triple-buffering-for-wayland.patch \
33 file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch \
34 file://0015-EGL-glplatform.h-define-EGL_CAST.patch \
35 file://0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch \
36 file://0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch \
37 file://0018-Add-EGL_IMG_context_priority-related-defines.patch \
38"
39S = "${WORKDIR}/git"
40
41inherit cmake pkgconfig
42
43ASNEEDED = ""
44
45EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
46 -DVMCS_INSTALL_PREFIX=${exec_prefix} \
47"
48
49EXTRA_OECMAKE_append_aarch64 = " -DARM64=ON "
50
51
52PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
53
54PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland"
55
56CFLAGS_append = " -fPIC"
57
58do_install_append () {
59 for f in `find ${D}${includedir}/interface/vcos/ -name "*.h"`; do
60 sed -i 's/include "vcos_platform.h"/include "pthreads\/vcos_platform.h"/g' ${f}
61 sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f}
62 sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f}
63 done
64 rm -rf ${D}${libdir}/libEGL*
65 rm -rf ${D}${libdir}/libGLES*
66 rm -rf ${D}${libdir}/libwayland-*
67 rm -rf ${D}${libdir}/pkgconfig/egl.pc ${D}${libdir}/pkgconfig/glesv2.pc ${D}${libdir}/pkgconfig/wayland-egl.pc
68 rm -rf ${D}${includedir}/EGL ${D}${includedir}/GLES* ${D}${includedir}/KHR
69}
70
71# Shared libs from userland package build aren't versioned, so we need
72# to force the .so files into the runtime package (and keep them
73# out of -dev package).
74FILES_SOLIBSDEV = ""
75INSANE_SKIP_${PN} += "dev-so"
76
77FILES_${PN} += " \
78 ${libdir}/*.so \
79 ${libdir}/plugins"
80FILES_${PN}-dev += "${includedir} \
81 ${prefix}/src"
82FILES_${PN}-doc += "${datadir}/install"
83FILES_${PN}-dbg += "${libdir}/plugins/.debug"
84
85PACKAGE_ARCH = "${MACHINE_ARCH}"
86
87RDEPENDS_${PN} += "bash libegl"