summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch')
-rw-r--r--recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch b/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
new file mode 100644
index 0000000..55a5be8
--- /dev/null
+++ b/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
@@ -0,0 +1,28 @@
1From fb3002f77a175633af31019c513754d2ef5f3ac0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 2 Apr 2016 10:37:24 -0700
4Subject: [PATCH 11/16] build shared library for vchostif
5
6Fixes #149
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 interface/vmcs_host/CMakeLists.txt | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt
14index c415176..d0cca1a 100755
15--- a/interface/vmcs_host/CMakeLists.txt
16+++ b/interface/vmcs_host/CMakeLists.txt
17@@ -17,7 +17,7 @@ set(VCHOSTIF_SOURCE
18 # ${VMCS_TARGET}/vmcs_main.c
19 # vc_vchi_haud.c
20
21-add_library(vchostif ${VCHOSTIF_SOURCE})
22+add_library(vchostif SHARED ${VCHOSTIF_SOURCE})
23
24 #add_library(bufman vc_vchi_bufman.c )
25
26--
272.16.1
28