summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/rpi-gpio_0.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/rpi-gpio_0.7.0.bb')
-rw-r--r--recipes-devtools/python/rpi-gpio_0.7.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/rpi-gpio_0.7.0.bb b/recipes-devtools/python/rpi-gpio_0.7.0.bb
new file mode 100644
index 0000000..fcce88f
--- /dev/null
+++ b/recipes-devtools/python/rpi-gpio_0.7.0.bb
@@ -0,0 +1,14 @@
1DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
2HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
6
7PYPI_PACKAGE = "RPi.GPIO"
8inherit pypi distutils3
9
10SRC_URI += "file://0001-Remove-nested-functions.patch"
11SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e"
12SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f"
13
14COMPATIBLE_MACHINE = "^rpi$"