summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/bcm2835/bcm2835_1.52.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/bcm2835/bcm2835_1.52.bb')
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.52.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/bcm2835/bcm2835_1.52.bb b/recipes-devtools/bcm2835/bcm2835_1.52.bb
new file mode 100644
index 0000000..c0334fe
--- /dev/null
+++ b/recipes-devtools/bcm2835/bcm2835_1.52.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Package that provides access to GPIO and other IO\
2functions on the Broadcom BCM 2835 chip, allowing access to the\
3GPIO pins on the 26 pin IDE plug on the RPi board"
4SECTION = "base"
5HOMEPAGE = "http://www.open.com.au/mikem/bcm2835"
6AUTHOR = "Mike McCauley (mikem@open.com.au)"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11COMPATIBLE_MACHINE = "raspberrypi"
12
13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "b5dc426b4ff258bb1397442f98e40236"
16SRC_URI[sha256sum] = "b9fd10f7a80aadaed28a77168709b7c519568a63b6e98d0a50e9c5fe31bea6bb"
17
18inherit autotools
19
20do_compile_append() {
21 # Now compiling the examples provided by the package
22 mkdir -p ${B}/examples
23 for file in `ls ${S}/examples`; do
24 ${CC} ${LDFLAGS} ${S}/examples/${file}/${file}.c -o ${B}/examples/${file} -Bstatic -L${B}/src -lbcm2835 -I${S}/src
25 done
26}
27
28do_install_append() {
29 install -d ${D}/${libdir}/${BPN}
30 for file in ${B}/examples/*
31 do
32 install -m 0755 ${file} ${D}/${libdir}/${BPN}
33 done
34}
35
36PACKAGES += "${PN}-tests"
37
38FILES_${PN} = ""
39FILES_${PN}-tests = "${libdir}/${BPN}"
40FILES_${PN}-dbg += "${libdir}/${BPN}/.debug"