summaryrefslogtreecommitdiffstats
path: root/recipes-core/systemd/rpi-zram-service.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd/rpi-zram-service.bb')
-rw-r--r--recipes-core/systemd/rpi-zram-service.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-core/systemd/rpi-zram-service.bb b/recipes-core/systemd/rpi-zram-service.bb
deleted file mode 100644
index f9e1e9c..0000000
--- a/recipes-core/systemd/rpi-zram-service.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "Linux zram compressed in-memory swap systemd service"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4
5inherit allarch systemd
6
7PR = "r0"
8
9SRC_URI = "file://rpi-zram.service \
10 file://rpi-load-zram.sh \
11 "
12
13do_compile() {
14 :
15}
16
17
18do_install () {
19 install -d ${D}/${bindir}
20
21 install -m 0755 ${WORKDIR}/rpi-load-zram.sh ${D}/${bindir}
22
23 install -d ${D}/${base_libdir}/systemd/system
24 install -m 0644 ${WORKDIR}/rpi-zram.service ${D}/${base_libdir}/systemd/system/
25}
26
27SYSTEMD_PACKAGES = "${PN}"
28SYSTEMD_SERVICE_${PN} = "rpi-zram.service"
29
30FILES_${PN} += "${base_libdir}/systemd"