summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index fe18884..f78c6d7 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -30,6 +30,8 @@ GPIO_IR_TX ?= "17"
30 30
31CAN_OSCILLATOR ?= "16000000" 31CAN_OSCILLATOR ?= "16000000"
32 32
33ENABLE_UART ??= ""
34
33WM8960="${@bb.utils.contains("MACHINE_FEATURES", "wm8960", "1", "0", d)}" 35WM8960="${@bb.utils.contains("MACHINE_FEATURES", "wm8960", "1", "0", d)}"
34 36
35inherit deploy nopackages 37inherit deploy nopackages
@@ -177,7 +179,7 @@ do_deploy() {
177 if [ "${ENABLE_UART}" = "1" ] || [ "${ENABLE_UART}" = "0" ] ; then 179 if [ "${ENABLE_UART}" = "1" ] || [ "${ENABLE_UART}" = "0" ] ; then
178 echo "# Enable UART" >>$CONFIG 180 echo "# Enable UART" >>$CONFIG
179 echo "enable_uart=${ENABLE_UART}" >>$CONFIG 181 echo "enable_uart=${ENABLE_UART}" >>$CONFIG
180 else 182 elif [ -n "${ENABLE_UART}" ]; then
181 bbfatal "Invalid value for ENABLE_UART [${ENABLE_UART}]. The value for ENABLE_UART can be 0 or 1." 183 bbfatal "Invalid value for ENABLE_UART [${ENABLE_UART}]. The value for ENABLE_UART can be 0 or 1."
182 fi 184 fi
183 185