summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf12
-rw-r--r--conf/machine/include/rpi-base.inc2
-rw-r--r--conf/machine/include/rpi-default-settings.inc6
-rw-r--r--conf/machine/include/tune-arm1176jzf-s.inc12
-rw-r--r--conf/machine/raspberrypi3-64.conf2
-rw-r--r--conf/machine/raspberrypi4-64.conf2
6 files changed, 18 insertions, 18 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 2518379..944df21 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -6,11 +6,11 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
6 ${LAYERDIR}/recipes*/*/*.bbappend" 6 ${LAYERDIR}/recipes*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "raspberrypi" 8BBFILE_COLLECTIONS += "raspberrypi"
9BBFILE_PATTERN_raspberrypi := "^${LAYERDIR}/" 9BBFILE_PATTERN:raspberrypi := "^${LAYERDIR}/"
10BBFILE_PRIORITY_raspberrypi = "9" 10BBFILE_PRIORITY:raspberrypi = "9"
11 11
12LAYERSERIES_COMPAT_raspberrypi = "hardknott honister" 12LAYERSERIES_COMPAT:raspberrypi = "hardknott honister"
13LAYERDEPENDS_raspberrypi = "core" 13LAYERDEPENDS:raspberrypi = "core"
14 14
15# Additional license directories. 15# Additional license directories.
16LICENSE_PATH += "${LAYERDIR}/files/custom-licenses" 16LICENSE_PATH += "${LAYERDIR}/files/custom-licenses"
@@ -36,5 +36,5 @@ BBFILES_DYNAMIC += " \
36 multimedia-layer:${LAYERDIR}/dynamic-layers/multimedia-layer/*/*/*.bbappend \ 36 multimedia-layer:${LAYERDIR}/dynamic-layers/multimedia-layer/*/*/*.bbappend \
37" 37"
38 38
39DEFAULT_TEST_SUITES_remove_rpi = "parselogs" 39DEFAULT_TEST_SUITES:remove:rpi = "parselogs"
40DEFAULT_TEST_SUITES_append_rpi = " parselogs_rpi" 40DEFAULT_TEST_SUITES:append:rpi = " parselogs:rpi"
diff --git a/conf/machine/include/rpi-base.inc b/conf/machine/include/rpi-base.inc
index 75c3727..a4db938 100644
--- a/conf/machine/include/rpi-base.inc
+++ b/conf/machine/include/rpi-base.inc
@@ -144,4 +144,4 @@ do_image_wic[recrdeps] = "do_build"
144 144
145# The kernel image is installed into the FAT32 boot partition and does not need 145# The kernel image is installed into the FAT32 boot partition and does not need
146# to also be installed into the rootfs. 146# to also be installed into the rootfs.
147RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "" 147RDEPENDS:${KERNEL_PACKAGE_NAME}-base = ""
diff --git a/conf/machine/include/rpi-default-settings.inc b/conf/machine/include/rpi-default-settings.inc
index bb18496..a89ddb1 100644
--- a/conf/machine/include/rpi-default-settings.inc
+++ b/conf/machine/include/rpi-default-settings.inc
@@ -3,7 +3,7 @@
3IMAGE_CLASSES += "sdcard_image-rpi" 3IMAGE_CLASSES += "sdcard_image-rpi"
4 4
5# RPI kernel has errors of its own which should be filtered 5# RPI kernel has errors of its own which should be filtered
6# therefore use parselogs_rpi test instead of parselogs from oe-core 6# therefore use parselogs:rpi test instead of parselogs from oe-core
7# 7#
8DEFAULT_TEST_SUITES_append_rpi = " parselogs_rpi" 8DEFAULT_TEST_SUITES:append:rpi = " parselogs:rpi"
9DEFAULT_TEST_SUITES_remove_rpi = " parselogs" 9DEFAULT_TEST_SUITES:remove:rpi = " parselogs"
diff --git a/conf/machine/include/tune-arm1176jzf-s.inc b/conf/machine/include/tune-arm1176jzf-s.inc
index b9e0377..ce5f08e 100644
--- a/conf/machine/include/tune-arm1176jzf-s.inc
+++ b/conf/machine/include/tune-arm1176jzf-s.inc
@@ -7,11 +7,11 @@ TUNE_CCARGS .= "${@bb.utils.contains('TUNE_FEATURES', 'arm1176jzfs', ' -mcpu=arm
7MACHINEOVERRIDES =. "${@bb.utils.contains('TUNE_FEATURES', 'arm1176jzfs', 'armv6:', '', d)}" 7MACHINEOVERRIDES =. "${@bb.utils.contains('TUNE_FEATURES', 'arm1176jzfs', 'armv6:', '', d)}"
8 8
9AVAILTUNES += "arm1176jzfs" 9AVAILTUNES += "arm1176jzfs"
10ARMPKGARCH_tune-arm1176jzfs = "arm1176jzfs" 10ARMPKGARCH:tune-arm1176jzfs = "arm1176jzfs"
11TUNE_FEATURES_tune-arm1176jzfs = "arm thumb vfp arm1176jzfs" 11TUNE_FEATURES:tune-arm1176jzfs = "arm thumb vfp arm1176jzfs"
12PACKAGE_EXTRA_ARCHS_tune-arm1176jzfs = "${PACKAGE_EXTRA_ARCHS_tune-armv6} arm1176jzfs" 12PACKAGE_EXTRA_ARCHS:tune-arm1176jzfs = "${PACKAGE_EXTRA_ARCHS:tune-armv6} arm1176jzfs"
13 13
14AVAILTUNES += "arm1176jzfshf" 14AVAILTUNES += "arm1176jzfshf"
15ARMPKGARCH_tune-arm1176jzfshf = "${ARMPKGARCH_tune-arm1176jzfs}" 15ARMPKGARCH:tune-arm1176jzfshf = "${ARMPKGARCH:tune-arm1176jzfs}"
16TUNE_FEATURES_tune-arm1176jzfshf = "${TUNE_FEATURES_tune-arm1176jzfs} callconvention-hard" 16TUNE_FEATURES:tune-arm1176jzfshf = "${TUNE_FEATURES:tune-arm1176jzfs} callconvention-hard"
17PACKAGE_EXTRA_ARCHS_tune-arm1176jzfshf = "${PACKAGE_EXTRA_ARCHS_tune-armv6thf} arm1176jzfshf-vfp" 17PACKAGE_EXTRA_ARCHS:tune-arm1176jzfshf = "${PACKAGE_EXTRA_ARCHS:tune-armv6thf} arm1176jzfshf-vfp"
diff --git a/conf/machine/raspberrypi3-64.conf b/conf/machine/raspberrypi3-64.conf
index 5394132..4ed2d2a 100644
--- a/conf/machine/raspberrypi3-64.conf
+++ b/conf/machine/raspberrypi3-64.conf
@@ -23,7 +23,7 @@ RPI_KERNEL_DEVICETREE = " \
23 23
24SERIAL_CONSOLES ?= "115200;ttyS0" 24SERIAL_CONSOLES ?= "115200;ttyS0"
25 25
26UBOOT_MACHINE = "rpi_arm64_config" 26UBOOT_MACHINE = "rpi:arm64_config"
27 27
28# When u-boot is enabled we need to use the "Image" format and the "booti" 28# When u-boot is enabled we need to use the "Image" format and the "booti"
29# command to load the kernel 29# command to load the kernel
diff --git a/conf/machine/raspberrypi4-64.conf b/conf/machine/raspberrypi4-64.conf
index 12c8954..99a2a7c 100644
--- a/conf/machine/raspberrypi4-64.conf
+++ b/conf/machine/raspberrypi4-64.conf
@@ -22,7 +22,7 @@ RPI_KERNEL_DEVICETREE = " \
22SDIMG_KERNELIMAGE ?= "kernel8.img" 22SDIMG_KERNELIMAGE ?= "kernel8.img"
23SERIAL_CONSOLES ?= "115200;ttyS0" 23SERIAL_CONSOLES ?= "115200;ttyS0"
24 24
25UBOOT_MACHINE = "rpi_arm64_config" 25UBOOT_MACHINE = "rpi:arm64_config"
26 26
27VC4DTBO ?= "vc4-fkms-v3d" 27VC4DTBO ?= "vc4-fkms-v3d"
28 28