summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-11-20 23:40:21 -0800
committerAndrei Gherzan <andrei@gherzan.ro>2018-11-21 17:56:52 +0200
commitb38a77938a40a340ab77aafc0fbde12fcded7e4c (patch)
tree5834b171a33a8cb5af742bb1ec0f4f664ec205d9 /recipes-multimedia
parente1ba4484c0135e12fbbd4b7bab00d9a15d5137f2 (diff)
downloadmeta-raspberrypi-b38a77938a40a340ab77aafc0fbde12fcded7e4c.tar.gz
userland: Merge userland-nogl into userland itself
Control the installs via MACHINE_FEATURES and avoid almost duplicate recipe Adjust other recipes to depend on userland now Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend4
-rw-r--r--recipes-multimedia/omxplayer/omxplayer_git.bb6
2 files changed, 4 insertions, 6 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
index 19cd259..f892c66 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
@@ -1,4 +1,4 @@
1DEPENDS_append_rpi = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " userland-nogl", "", d)}" 1DEPENDS_append_rpi = " userland"
2GSTREAMER_1_0_OMX_TARGET_rpi = "rpi" 2GSTREAMER_1_0_OMX_TARGET_rpi = "rpi"
3GSTREAMER_1_0_OMX_CORE_NAME_rpi = "${libdir}/libopenmaxil.so" 3GSTREAMER_1_0_OMX_CORE_NAME_rpi = "${libdir}/libopenmaxil.so"
4# How to make this RPI specific? 4# How to make this RPI specific?
@@ -6,4 +6,4 @@ EXTRA_OECONF_append_rpi = " CFLAGS="$CFLAGS -I${STAGING_DIR_TARGET}/usr/include
6#examples only build with GL but not GLES, so disable it for RPI 6#examples only build with GL but not GLES, so disable it for RPI
7EXTRA_OECONF_append_rpi = " --disable-examples" 7EXTRA_OECONF_append_rpi = " --disable-examples"
8 8
9RDEPENDS_${PN}_append_rpi = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " userland-nogl", "", d)}" 9RDEPENDS_${PN}_append_rpi = " userland"
diff --git a/recipes-multimedia/omxplayer/omxplayer_git.bb b/recipes-multimedia/omxplayer/omxplayer_git.bb
index 4ec0b24..f557207 100644
--- a/recipes-multimedia/omxplayer/omxplayer_git.bb
+++ b/recipes-multimedia/omxplayer/omxplayer_git.bb
@@ -7,8 +7,7 @@ SECTION = "console/utils"
7LICENSE = "GPLv2" 7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9 9
10DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl libssh libomxil coreutils-native curl-native" 10DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl libssh libomxil coreutils-native curl-native userland"
11DEPENDS += "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " userland-nogl", "", d)}"
12 11
13PR = "r4" 12PR = "r4"
14 13
@@ -105,5 +104,4 @@ FILES_${PN} = "${bindir}/omxplayer* \
105 104
106FILES_${PN}-dev += "${libdir}/omxplayer/*.so" 105FILES_${PN}-dev += "${libdir}/omxplayer/*.so"
107 106
108RDEPENDS_${PN} += "bash procps" 107RDEPENDS_${PN} += "bash procps userland"
109RDEPENDS_${PN} += "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " userland-nogl", "", d)}"