summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 19:58:04 +0200
committerAndrei Gherzan <andrei@gherzan.com>2021-08-04 12:30:12 +0300
commit9ea7aa2cd2cdc775425797b689e782718896ea50 (patch)
tree3831e2403262e27cd178a213b82c2ed8ad91e9a6 /recipes-multimedia
parent8dc3a310883ea87cd9900442f46f20bb08e57583 (diff)
downloadmeta-raspberrypi-9ea7aa2cd2cdc775425797b689e782718896ea50.tar.gz
Convert to new override syntax
This is the result of automated script conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend10
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend6
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.%.bbappend2
-rw-r--r--recipes-multimedia/omxplayer/omxplayer_git.bb10
-rw-r--r--recipes-multimedia/x264/x264_%.bbappend4
6 files changed, 17 insertions, 17 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
index a971236..5e0b457 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
@@ -1,12 +1,12 @@
1FILESEXTRAPATHS_prepend_rpi := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend:rpi := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_rpi = " \ 3SRC_URI:append:rpi = " \
4 file://0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch \ 4 file://0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch \
5 file://0003-no-timeout-on-get-state.patch \ 5 file://0003-no-timeout-on-get-state.patch \
6 file://0004-Properly-handle-drain-requests-while-flushing.patch \ 6 file://0004-Properly-handle-drain-requests-while-flushing.patch \
7 file://0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch \ 7 file://0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch \
8" 8"
9 9
10GSTREAMER_1_0_OMX_TARGET_rpi = "rpi" 10GSTREAMER_1_0_OMX_TARGET:rpi = "rpi"
11GSTREAMER_1_0_OMX_CORE_NAME_rpi = "${libdir}/libopenmaxil.so" 11GSTREAMER_1_0_OMX_CORE_NAME:rpi = "${libdir}/libopenmaxil.so"
12EXTRA_OEMESON_append_rpi = " -Dheader_path=${STAGING_DIR_TARGET}/usr/include/IL" 12EXTRA_OEMESON:append:rpi = " -Dheader_path=${STAGING_DIR_TARGET}/usr/include/IL"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index 8ab1510..4a815ab 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -1,2 +1,2 @@
1PACKAGECONFIG_append_rpi = " hls libmms \ 1PACKAGECONFIG:append:rpi = " hls libmms \
2 ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'faad', '', d)}" 2 ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'faad', '', d)}"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
index 6bed42a..834ccfb 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
@@ -1,6 +1,6 @@
1# if using bcm driver enable dispmanx not when using VC4 driver 1# if using bcm driver enable dispmanx not when using VC4 driver
2PACKAGECONFIG_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' dispmanx', d)}" 2PACKAGECONFIG:append:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' dispmanx', d)}"
3DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" 3DEPENDS:append:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
4 4
5PACKAGECONFIG_GL_VC4GRAPHICS = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}" 5PACKAGECONFIG_GL_VC4GRAPHICS = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
6PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '${PACKAGECONFIG_GL_VC4GRAPHICS}', 'egl gles2', d)}" 6PACKAGECONFIG_GL:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '${PACKAGECONFIG_GL_VC4GRAPHICS}', 'egl gles2', d)}"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.%.bbappend
index 80a324f..f3fb144 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.%.bbappend
@@ -1 +1 @@
PACKAGECONFIG_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' rpi', d)}" PACKAGECONFIG:append:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' rpi', d)}"
diff --git a/recipes-multimedia/omxplayer/omxplayer_git.bb b/recipes-multimedia/omxplayer/omxplayer_git.bb
index 55e5a1c..d294399 100644
--- a/recipes-multimedia/omxplayer/omxplayer_git.bb
+++ b/recipes-multimedia/omxplayer/omxplayer_git.bb
@@ -36,12 +36,12 @@ SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master
36 file://0007-Remove-Makefile-hardcoded-arch-tune.patch \ 36 file://0007-Remove-Makefile-hardcoded-arch-tune.patch \
37 " 37 "
38 38
39SRC_URI_append = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " file://0001-Fix-build-with-vc4-driver.patch ", "", d)}" 39SRC_URI:append = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " file://0001-Fix-build-with-vc4-driver.patch ", "", d)}"
40 40
41S = "${WORKDIR}/git" 41S = "${WORKDIR}/git"
42 42
43COMPATIBLE_MACHINE = "^rpi$" 43COMPATIBLE_MACHINE = "^rpi$"
44COMPATIBLE_HOST_aarch64 = "null" 44COMPATIBLE_HOST:aarch64 = "null"
45 45
46def cpu(d): 46def cpu(d):
47 for arg in (d.getVar('TUNE_CCARGS') or '').split(): 47 for arg in (d.getVar('TUNE_CCARGS') or '').split():
@@ -99,10 +99,10 @@ do_install() {
99 install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/ 99 install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/
100} 100}
101 101
102FILES_${PN} = "${bindir}/omxplayer* \ 102FILES:${PN} = "${bindir}/omxplayer* \
103 ${libdir}/omxplayer/lib*${SOLIBS} \ 103 ${libdir}/omxplayer/lib*${SOLIBS} \
104 ${datadir}/fonts" 104 ${datadir}/fonts"
105 105
106FILES_${PN}-dev += "${libdir}/omxplayer/*.so" 106FILES:${PN}-dev += "${libdir}/omxplayer/*.so"
107 107
108RDEPENDS_${PN} += "bash procps userland" 108RDEPENDS:${PN} += "bash procps userland"
diff --git a/recipes-multimedia/x264/x264_%.bbappend b/recipes-multimedia/x264/x264_%.bbappend
index 505719e..e0cfaf8 100644
--- a/recipes-multimedia/x264/x264_%.bbappend
+++ b/recipes-multimedia/x264/x264_%.bbappend
@@ -1,2 +1,2 @@
1EXTRA_OECONF_append_raspberrypi = " --disable-asm" 1EXTRA_OECONF:append:raspberrypi = " --disable-asm"
2EXTRA_OECONF_append_raspberrypi0-wifi = " --disable-asm" 2EXTRA_OECONF:append:raspberrypi0-wifi = " --disable-asm"