summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2016-06-08 00:57:13 +1000
committerAndrei Gherzan <andrei@gherzan.ro>2016-06-14 16:27:18 +0100
commit0dbf569173178810c17c6fe1a2e1b29b716ce90f (patch)
tree4913c678974fb540ca86880ce8bd5f47109462a4 /recipes-multimedia
parentffddbad97c67ae20b09284096276d85e7a6a66e1 (diff)
downloadmeta-raspberrypi-0dbf569173178810c17c6fe1a2e1b29b716ce90f.tar.gz
omxplayer: fix compilation with GCC 6
Specifying -isystem${STAGING_DIR_HOST}/usr/include in INCLUDES gives: In file included from utils/PCMRemap.cpp:26:0: .../build/tmp/sysroots/raspberrypi2/usr/include/c++/6.1.1/cstdlib:75:25: fatal error: stdlib.h: No such file or directory #include_next <stdlib.h> ^ compilation terminated. Makefile:44: recipe for target 'utils/PCMRemap.o' failed To resolve this, /usr/include shouldn't be specified as it is already a default include path relative to the sysroot. See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129. Signed-off-by: Jonathan Liu <net147@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/omxplayer/omxplayer_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/recipes-multimedia/omxplayer/omxplayer_git.bb b/recipes-multimedia/omxplayer/omxplayer_git.bb
index 7d3b464..d9460de 100644
--- a/recipes-multimedia/omxplayer/omxplayer_git.bb
+++ b/recipes-multimedia/omxplayer/omxplayer_git.bb
@@ -40,8 +40,7 @@ export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
40 -L${STAGING_DIR_HOST}/lib \ 40 -L${STAGING_DIR_HOST}/lib \
41 -L${STAGING_DIR_HOST}/usr/lib \ 41 -L${STAGING_DIR_HOST}/usr/lib \
42 " 42 "
43export INCLUDES = "-isystem${STAGING_DIR_HOST}/usr/include \ 43export INCLUDES = "-isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
44 -isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
45 -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \ 44 -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \
46 -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \ 45 -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \
47 -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \ 46 -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \