summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-30 10:44:19 -0700
committerAndrei Gherzan <andrei@gherzan.com>2018-05-04 22:08:38 +0100
commitcf9971fa8bc218f9818412781e4e1bc57133779e (patch)
tree3acd49a2fdb62fbbbc82d192e37056841473c282 /recipes-graphics
parent4d689a792cbcd928f1f0026955920870c37d14ee (diff)
downloadmeta-raspberrypi-cf9971fa8bc218f9818412781e4e1bc57133779e.tar.gz
xserver-xf86-config: Disable glamor for vc4 in general
We need this fix across 32bit and 64bit with vc4/mesa Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend11
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
index 7902f20..919e95e 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -3,20 +3,19 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3SRC_URI_append_rpi = " \ 3SRC_URI_append_rpi = " \
4 file://xorg.conf.d/98-pitft.conf \ 4 file://xorg.conf.d/98-pitft.conf \
5 file://xorg.conf.d/99-calibration.conf \ 5 file://xorg.conf.d/99-calibration.conf \
6"
7SRC_URI_append_libc-musl_raspberrypi3-64 = " \
8 file://xorg.conf.d/10-noglamor.conf \ 6 file://xorg.conf.d/10-noglamor.conf \
9" 7"
10do_install_append_rpi () { 8do_install_append_rpi () {
11 PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" 9 PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
10 VC4="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
12 if [ "${PITFT}" = "1" ]; then 11 if [ "${PITFT}" = "1" ]; then
13 install -d ${D}/${sysconfdir}/X11/xorg.conf.d/ 12 install -d ${D}/${sysconfdir}/X11/xorg.conf.d/
14 install -m 0644 ${WORKDIR}/xorg.conf.d/98-pitft.conf ${D}/${sysconfdir}/X11/xorg.conf.d/ 13 install -m 0644 ${WORKDIR}/xorg.conf.d/98-pitft.conf ${D}/${sysconfdir}/X11/xorg.conf.d/
15 install -m 0644 ${WORKDIR}/xorg.conf.d/99-calibration.conf ${D}/${sysconfdir}/X11/xorg.conf.d/ 14 install -m 0644 ${WORKDIR}/xorg.conf.d/99-calibration.conf ${D}/${sysconfdir}/X11/xorg.conf.d/
16 fi 15 fi
16 if [ "${VC4}" = "1" ]; then
17 install -Dm 0644 ${WORKDIR}/xorg.conf.d/10-noglamor.conf ${D}/${sysconfdir}/X11/xorg.conf.d/10-noglamor.conf
18 fi
17} 19}
18do_install_append_libc-musl_raspberrypi3-64 () { 20
19 install -d ${D}/${sysconfdir}/X11/xorg.conf.d/
20 install -m 0644 ${WORKDIR}/xorg.conf.d/10-noglamor.conf ${D}/${sysconfdir}/X11/xorg.conf.d/
21}
22FILES_${PN}_rpi += "${sysconfdir}/X11/xorg.conf ${sysconfdir}/X11/xorg.conf.d/*" 21FILES_${PN}_rpi += "${sysconfdir}/X11/xorg.conf ${sysconfdir}/X11/xorg.conf.d/*"