summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-21 22:24:28 -0800
committerAndrei Gherzan <andrei@gherzan.ro>2019-02-24 11:04:38 +0000
commit2c8b2f6c6bdc9e3ac89873d8066708095c639744 (patch)
tree8a059f7a24e2788eefcb06ddc2b136e5c57e8e1c /recipes-graphics
parent09c00164d6ad978d444749a89e0a0a3d77a1735e (diff)
downloadmeta-raspberrypi-2c8b2f6c6bdc9e3ac89873d8066708095c639744.tar.gz
mesa-gl: Let userland provide libEGL and GLESv2 when vc4 graphics is not used
When vc4graphics is not used then useland graphics provides these libraries Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa-gl_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa-gl_%.bbappend b/recipes-graphics/mesa/mesa-gl_%.bbappend
index 7897125..107f6b5 100644
--- a/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ b/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -1 +1,12 @@
1PACKAGECONFIG_append_rpi = " gbm" 1PACKAGECONFIG_append_rpi = " gbm"
2
3do_install_append_rpi() {
4 if [ "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" = "0" ]; then
5 rm -rf ${D}${libdir}/libEGL*
6 rm -rf ${D}${libdir}/libGLES*
7 rm -rf ${D}${libdir}/libwayland-*
8 rm -rf ${D}${libdir}/pkgconfig/egl.pc ${D}${libdir}/pkgconfig/glesv2.pc \
9 ${D}${libdir}/pkgconfig/wayland-egl.pc
10 rm -rf ${D}${includedir}/EGL ${D}${includedir}/GLES* ${D}${includedir}/KHR
11 fi
12}