diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-10-01 20:41:16 -0700 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.com> | 2018-10-02 14:14:54 +0100 |
commit | 16a8bb9da04aee6a4bc9cfa24962999408cbf22a (patch) | |
tree | bf862e98eac61cbc7188912ac541198d05b916ed /recipes-graphics | |
parent | 0b10f248d0f3b9f1acbf07551f24ac99e9b489a7 (diff) | |
download | meta-raspberrypi-16a8bb9da04aee6a4bc9cfa24962999408cbf22a.tar.gz |
xorg-server: Do not install 10-noglamor.conf
This causes glamor APIs to be disabled and glxgears run very slow
like 1FPS, without this it speeds up to 55.5fps
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xf86-config/rpi/xorg.conf.d/10-noglamor.conf | 6 | ||||
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend | 5 |
2 files changed, 0 insertions, 11 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/rpi/xorg.conf.d/10-noglamor.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/rpi/xorg.conf.d/10-noglamor.conf deleted file mode 100644 index 1a562ea..0000000 --- a/recipes-graphics/xorg-xserver/xserver-xf86-config/rpi/xorg.conf.d/10-noglamor.conf +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | # | ||
2 | Section "Device" | ||
3 | Identifier "modeset" | ||
4 | Driver "modesetting" | ||
5 | Option "AccelMethod" "None" | ||
6 | EndSection | ||
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend index 919e95e..71e0adc 100644 --- a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend +++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend | |||
@@ -3,19 +3,14 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
3 | SRC_URI_append_rpi = " \ | 3 | SRC_URI_append_rpi = " \ |
4 | file://xorg.conf.d/98-pitft.conf \ | 4 | file://xorg.conf.d/98-pitft.conf \ |
5 | file://xorg.conf.d/99-calibration.conf \ | 5 | file://xorg.conf.d/99-calibration.conf \ |
6 | file://xorg.conf.d/10-noglamor.conf \ | ||
7 | " | 6 | " |
8 | do_install_append_rpi () { | 7 | do_install_append_rpi () { |
9 | PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" | 8 | PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" |
10 | VC4="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" | ||
11 | if [ "${PITFT}" = "1" ]; then | 9 | if [ "${PITFT}" = "1" ]; then |
12 | install -d ${D}/${sysconfdir}/X11/xorg.conf.d/ | 10 | install -d ${D}/${sysconfdir}/X11/xorg.conf.d/ |
13 | install -m 0644 ${WORKDIR}/xorg.conf.d/98-pitft.conf ${D}/${sysconfdir}/X11/xorg.conf.d/ | 11 | install -m 0644 ${WORKDIR}/xorg.conf.d/98-pitft.conf ${D}/${sysconfdir}/X11/xorg.conf.d/ |
14 | install -m 0644 ${WORKDIR}/xorg.conf.d/99-calibration.conf ${D}/${sysconfdir}/X11/xorg.conf.d/ | 12 | install -m 0644 ${WORKDIR}/xorg.conf.d/99-calibration.conf ${D}/${sysconfdir}/X11/xorg.conf.d/ |
15 | fi | 13 | fi |
16 | if [ "${VC4}" = "1" ]; then | ||
17 | install -Dm 0644 ${WORKDIR}/xorg.conf.d/10-noglamor.conf ${D}/${sysconfdir}/X11/xorg.conf.d/10-noglamor.conf | ||
18 | fi | ||
19 | } | 14 | } |
20 | 15 | ||
21 | FILES_${PN}_rpi += "${sysconfdir}/X11/xorg.conf ${sysconfdir}/X11/xorg.conf.d/*" | 16 | FILES_${PN}_rpi += "${sysconfdir}/X11/xorg.conf ${sysconfdir}/X11/xorg.conf.d/*" |