summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/pi-blaster
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2017-06-07 22:50:06 +0200
committerPetter Mabäcker <petter@technux.se>2017-06-08 16:28:23 +0200
commitdf901c29159846458b2a25477fa5d8265b63ffe7 (patch)
tree0baa56372983f3963478bd82c20e4d47a9747f46 /recipes-devtools/pi-blaster
parent081405feaa544b5b5c55a3ac72e629f3f3869a26 (diff)
downloadmeta-raspberrypi-df901c29159846458b2a25477fa5d8265b63ffe7.tar.gz
pi-blaster: update to include proper rpi3 support
Update to latest available revision, in order to include proper rpi3 support as well as latest fixes. LIC_FILES_CHKSUM for the license text in README.md is changed to handle fixes of whitespace and newlines in the license text, introduced by the pi-blaster commit: '0e1a1df Cleaning up the README'. Signed-off-by: Petter Mabäcker <petter@technux.se>
Diffstat (limited to 'recipes-devtools/pi-blaster')
-rw-r--r--recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch37
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster.inc2
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster_git.bb2
3 files changed, 30 insertions, 11 deletions
diff --git a/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch b/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch
index 7ea9a3b..c8afe60 100644
--- a/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch
+++ b/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch
@@ -1,13 +1,28 @@
1Remove dependencies on LSB functions 1From 1338f98a279616f4e5e9ea30a25d1dfa0c7df5d6 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Petter=20Mab=C3=A4cker?= <petter@technux.se>
3Date: Sun, 4 Jun 2017 12:22:40 +0200
4Subject: [PATCH] Remove dependencies on LSB functions
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9See this as a rebase of the previous 'Remove dependencies on LSB
10functions patch' with only minor modifications from the original version,
11based on the work done by Alex Lennon <ajlennon@dynamicdevices.co.uk> in
12'25fd817 pi-blaster: Added recipe'.
2 13
3Upstream-Status: Inappropriate [configuration] 14Upstream-Status: Inappropriate [configuration]
4 15
5Signed-off-by: Alex Lennon <ajlennon@dynamicdevices.co.uk> 16Signed-off-by: Petter Mabäcker <petter@technux.se>
17---
18 debian/pi-blaster.init | 38 +++++++-------------------------------
19 1 file changed, 7 insertions(+), 31 deletions(-)
6 20
7diff -ur git.org/pi-blaster.boot.sh git/pi-blaster.boot.sh 21diff --git a/debian/pi-blaster.init b/debian/pi-blaster.init
8--- git.org/pi-blaster.boot.sh 2014-05-20 14:49:44.378582168 +0100 22index b142d70..01a686c 100644
9+++ git/pi-blaster.boot.sh 2014-05-20 14:51:08.330582386 +0100 23--- a/debian/pi-blaster.init
10@@ -28,12 +28,12 @@ 24+++ b/debian/pi-blaster.init
25@@ -28,12 +28,12 @@ SCRIPTNAME=/etc/init.d/$NAME
11 [ -r /etc/default/$NAME ] && . /etc/default/$NAME 26 [ -r /etc/default/$NAME ] && . /etc/default/$NAME
12 27
13 # Load the VERBOSE setting and other rcS variables 28 # Load the VERBOSE setting and other rcS variables
@@ -22,7 +37,7 @@ diff -ur git.org/pi-blaster.boot.sh git/pi-blaster.boot.sh
22 37
23 # 38 #
24 # Function that starts the daemon/service 39 # Function that starts the daemon/service
25@@ -77,48 +77,23 @@ 40@@ -77,48 +77,24 @@ do_stop()
26 41
27 case "$1" in 42 case "$1" in
28 start) 43 start)
@@ -52,6 +67,7 @@ diff -ur git.org/pi-blaster.boot.sh git/pi-blaster.boot.sh
52 # 'force-reload' alias 67 # 'force-reload' alias
53 # 68 #
54- log_daemon_msg "Restarting $DESC" "$NAME" 69- log_daemon_msg "Restarting $DESC" "$NAME"
70+ echo "Restarting $DESC" "$NAME"
55 do_stop 71 do_stop
56- case "$?" in 72- case "$?" in
57- 0|1) 73- 0|1)
@@ -67,11 +83,14 @@ diff -ur git.org/pi-blaster.boot.sh git/pi-blaster.boot.sh
67- log_end_msg 1 83- log_end_msg 1
68- ;; 84- ;;
69- esac 85- esac
70+ do_start 86+ do_start
71 ;; 87 ;;
72 *) 88 *)
73- echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2 89- echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
74+ echo "Usage: $SCRIPTNAME {start|stop|restart}" >&2 90+ echo "Usage: $SCRIPTNAME {start|stop|restart|force-reload}" >&2
75 exit 3 91 exit 3
76 ;; 92 ;;
77 esac 93 esac
94--
951.9.1
96
diff --git a/recipes-devtools/pi-blaster/pi-blaster.inc b/recipes-devtools/pi-blaster/pi-blaster.inc
index a3beccc..a548957 100644
--- a/recipes-devtools/pi-blaster/pi-blaster.inc
+++ b/recipes-devtools/pi-blaster/pi-blaster.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspbe
2HOMEPAGE = "https://github.com/sarfata/pi-blaster/" 2HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
3SECTION = "devel/libs" 3SECTION = "devel/libs"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.md;beginline=157;endline=170;md5=f20832f31126609af5a7bf2340014540" 5LIC_FILES_CHKSUM = "file://README.md;beginline=212;endline=239;md5=a012868ef5f83b9f257af253d7cb07a3"
6 6
7SRC_URI = "git://github.com/sarfata/pi-blaster \ 7SRC_URI = "git://github.com/sarfata/pi-blaster \
8 file://remove-initscript-lsb-dependency.patch \ 8 file://remove-initscript-lsb-dependency.patch \
diff --git a/recipes-devtools/pi-blaster/pi-blaster_git.bb b/recipes-devtools/pi-blaster/pi-blaster_git.bb
index 263852b..ac812ab 100644
--- a/recipes-devtools/pi-blaster/pi-blaster_git.bb
+++ b/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -1,3 +1,3 @@
1require pi-blaster.inc 1require pi-blaster.inc
2 2
3SRCREV = "ec5e1b4c6191d8f9a538497dbbb86f9cf0de7016" 3SRCREV = "9f45eb23a8a3b2d1c08d08a6d68f206fe91ecf4c"