summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/pi-blaster
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.com>2017-11-02 15:18:38 +0000
committerAndrei Gherzan <andrei@gherzan.com>2017-11-08 10:20:08 +0000
commitc07d7055e51a80e6d4698380199151b6e3ebdfdf (patch)
tree91136e846c5712311bd68724ac6deac086832825 /recipes-devtools/pi-blaster
parentabe5e31a891541b76fb48f4694474b39290f3222 (diff)
downloadmeta-raspberrypi-c07d7055e51a80e6d4698380199151b6e3ebdfdf.tar.gz
pi-blaster: An .inc file looks too much for this small recipe
Signed-off-by: Andrei Gherzan <andrei@gherzan.com>
Diffstat (limited to 'recipes-devtools/pi-blaster')
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster.inc21
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster_git.bb22
2 files changed, 21 insertions, 22 deletions
diff --git a/recipes-devtools/pi-blaster/pi-blaster.inc b/recipes-devtools/pi-blaster/pi-blaster.inc
deleted file mode 100644
index 3cb79cc..0000000
--- a/recipes-devtools/pi-blaster/pi-blaster.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi."
2HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
3SECTION = "devel/libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.md;beginline=225;endline=252;md5=a012868ef5f83b9f257af253d7cb07a3"
6
7SRC_URI = "git://github.com/sarfata/pi-blaster \
8 file://remove-initscript-lsb-dependency.patch \
9"
10
11S = "${WORKDIR}/git"
12
13inherit update-rc.d autotools
14
15INITSCRIPT_PACKAGES = "${PN}"
16INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
17INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
18
19COMPATIBLE_MACHINE = "^rpi$"
20
21PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-devtools/pi-blaster/pi-blaster_git.bb b/recipes-devtools/pi-blaster/pi-blaster_git.bb
index 730f9d3..2748459 100644
--- a/recipes-devtools/pi-blaster/pi-blaster_git.bb
+++ b/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -1,3 +1,23 @@
1require pi-blaster.inc 1DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi."
2HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
3SECTION = "devel/libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.md;beginline=225;endline=252;md5=a012868ef5f83b9f257af253d7cb07a3"
6
7SRC_URI = "git://github.com/sarfata/pi-blaster \
8 file://remove-initscript-lsb-dependency.patch \
9"
10
11S = "${WORKDIR}/git"
2 12
3SRCREV = "1035ad7dffb270c40eec1bb3a654171a755fba98" 13SRCREV = "1035ad7dffb270c40eec1bb3a654171a755fba98"
14
15inherit update-rc.d autotools
16
17INITSCRIPT_PACKAGES = "${PN}"
18INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
19INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
20
21COMPATIBLE_MACHINE = "^rpi$"
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"