summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/pi-blaster
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-11 10:30:31 -0700
committerAndrei Gherzan <andrei@gherzan.com>2018-08-16 11:34:33 +0100
commit40a9a11794ead811c2687798c5a0e6530d00251c (patch)
tree3c5f8bf9e6d8351dc754392c824be231cca8c8b6 /recipes-devtools/pi-blaster
parent2f7e6e9b0e8a7ffbad4c56367faf9df5826bc066 (diff)
downloadmeta-raspberrypi-40a9a11794ead811c2687798c5a0e6530d00251c.tar.gz
pi-blaster: Fix build with glibc 2.28
Licesnse-Update: Limit the check to license text alone and not until end of file and point to correct lines otherwise license is unchanged Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/pi-blaster')
-rw-r--r--recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch32
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster_git.bb7
2 files changed, 36 insertions, 3 deletions
diff --git a/recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch b/recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch
new file mode 100644
index 0000000..b4bc4b2
--- /dev/null
+++ b/recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch
@@ -0,0 +1,32 @@
1From 6a6b705ff5cba960c54bdb4d4bcdaa3b00a854a2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 Aug 2018 10:24:24 -0700
4Subject: [PATCH] pi-blaster: Include sys/sysmacros.h for makedev()
5
6In glibc 2.28+ this header is not included indirectly anymore
7
8fixes
9
10ld: pi-blaster.o: in function `mbox_open':
11pi-blaster.c:(.text+0x28): undefined reference to `makedev'
12collect2: error: ld returned 1 exit status
13
14Upstream-Status: Submitted [https://github.com/sarfata/pi-blaster/pull/100]
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 pi-blaster.c | 1 +
19 1 file changed, 1 insertion(+)
20
21diff --git a/pi-blaster.c b/pi-blaster.c
22index 6cfd010..fc4e686 100644
23--- a/pi-blaster.c
24+++ b/pi-blaster.c
25@@ -41,6 +41,7 @@ static char VERSION[] = "SNAPSHOT";
26 #include <sys/time.h>
27 #include <sys/types.h>
28 #include <sys/stat.h>
29+#include <sys/sysmacros.h>
30 #include <fcntl.h>
31 #include <sys/mman.h>
32 #include "mailbox.h"
diff --git a/recipes-devtools/pi-blaster/pi-blaster_git.bb b/recipes-devtools/pi-blaster/pi-blaster_git.bb
index 2748459..9cedf5e 100644
--- a/recipes-devtools/pi-blaster/pi-blaster_git.bb
+++ b/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -2,15 +2,16 @@ DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspbe
2HOMEPAGE = "https://github.com/sarfata/pi-blaster/" 2HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
3SECTION = "devel/libs" 3SECTION = "devel/libs"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.md;beginline=225;endline=252;md5=a012868ef5f83b9f257af253d7cb07a3" 5LIC_FILES_CHKSUM = "file://README.md;beginline=244;endline=268;md5=86d10e4bcf4b4014d306dde7c1d2a80d"
6 6
7SRC_URI = "git://github.com/sarfata/pi-blaster \ 7SRC_URI = "git://github.com/sarfata/pi-blaster \
8 file://remove-initscript-lsb-dependency.patch \ 8 file://remove-initscript-lsb-dependency.patch \
9" 9 file://0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch \
10 "
10 11
11S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
12 13
13SRCREV = "1035ad7dffb270c40eec1bb3a654171a755fba98" 14SRCREV = "e981aa5d7624c75a4d4afcddcbd235f25e32ffe4"
14 15
15inherit update-rc.d autotools 16inherit update-rc.d autotools
16 17