summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Botö <erik.boto@gmail.com>2020-01-13 09:35:30 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2020-01-14 16:17:04 +0000
commite7c856ee7bcfd7878853b55310957f0b9a990fd2 (patch)
tree3764b04bba7a38ff217254f95db4c94b3fc8a9d2
parent09f35259a2aa9e0542e802077b325189c7ae8ef4 (diff)
downloadmeta-raspberrypi-e7c856ee7bcfd7878853b55310957f0b9a990fd2.tar.gz
Add support for PiTFT 2.8" with capacitive touch
Add support for the Adafruit PiTFT Plus 320x240 2.8" TFT with Capacitive Touchscreen, using the same patterns used for the other versions of the PiTFT screens. Signed-off-by: Erik Botö <erik.boto@gmail.com>
-rw-r--r--conf/machine/include/rpi-base.inc1
-rw-r--r--docs/extra-build-config.md1
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb6
3 files changed, 8 insertions, 0 deletions
diff --git a/conf/machine/include/rpi-base.inc b/conf/machine/include/rpi-base.inc
index 36a8daf..9772fd9 100644
--- a/conf/machine/include/rpi-base.inc
+++ b/conf/machine/include/rpi-base.inc
@@ -30,6 +30,7 @@ RPI_KERNEL_DEVICETREE_OVERLAYS ?= " \
30 overlays/pi3-miniuart-bt.dtbo \ 30 overlays/pi3-miniuart-bt.dtbo \
31 overlays/pitft22.dtbo \ 31 overlays/pitft22.dtbo \
32 overlays/pitft28-resistive.dtbo \ 32 overlays/pitft28-resistive.dtbo \
33 overlays/pitft28-capacitive.dtbo \
33 overlays/pitft35-resistive.dtbo \ 34 overlays/pitft35-resistive.dtbo \
34 overlays/pps-gpio.dtbo \ 35 overlays/pps-gpio.dtbo \
35 overlays/rpi-ft5406.dtbo \ 36 overlays/rpi-ft5406.dtbo \
diff --git a/docs/extra-build-config.md b/docs/extra-build-config.md
index 1f7ef68..a2b68d8 100644
--- a/docs/extra-build-config.md
+++ b/docs/extra-build-config.md
@@ -204,6 +204,7 @@ modelname should be added as a MACHINE_FEATURES in local.conf like below:
204List of currently supported models: 204List of currently supported models:
205* pitft22 205* pitft22
206* pitft28r 206* pitft28r
207* pitft28c
207* pitft35r 208* pitft35r
208 209
209## Misc. display 210## Misc. display
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 160bc16..5315676 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -20,6 +20,7 @@ INHIBIT_DEFAULT_DEPS = "1"
20PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" 20PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
21PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}" 21PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}"
22PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}" 22PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}"
23PITFT28c="${@bb.utils.contains("MACHINE_FEATURES", "pitft28c", "1", "0", d)}"
23PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}" 24PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
24 25
25VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" 26VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
@@ -144,6 +145,11 @@ do_deploy() {
144 echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 145 echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
145 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 146 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
146 fi 147 fi
148 if [ "${PITFT28c}" = "1" ]; then
149 echo "# Enable PITFT28c display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
150 echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
151 echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
152 fi
147 if [ "${PITFT35r}" = "1" ]; then 153 if [ "${PITFT35r}" = "1" ]; then
148 echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 154 echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
149 echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 155 echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt