summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZygmunt Krynicki <me@zygoon.pl>2021-10-08 00:49:36 +0200
committerAndrei Gherzan <andrei@gherzan.com>2021-10-14 23:09:47 +0100
commit90b3ac6fb3037118bc711a14adcb31d2bcd7dfa4 (patch)
tree10f46ef5e8ee5d3199970dc23ff22bcd84efacd1
parent9eb4879cf4a289607ec7493577adb0ba97367821 (diff)
downloadmeta-raspberrypi-90b3ac6fb3037118bc711a14adcb31d2bcd7dfa4.tar.gz
rpi-config: warn on config.txt lines exceeding 80 bytes
The Raspberry Pi firmware does not support lines exceeding 80 bytes. This is documented at https://www.raspberrypi.com/documentation/computers/config_txt.html#file-format It seems that comments can be longer but it's still best to avoid this problem instead of debug it. Detect the situation in do_deploy_append and bbwarn if the limit is exceeded. Connected to #917 Signed-off-by: Zygmunt Krynicki <me@zygoon.pl>
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 657123f..96453ef 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -278,6 +278,12 @@ do_deploy:append:raspberrypi3-64() {
278 echo "dtparam=audio=on" >> $CONFIG 278 echo "dtparam=audio=on" >> $CONFIG
279} 279}
280 280
281do_deploy:append() {
282 if grep -q -E '^.{80}.$' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt; then
283 bbwarn "config.txt contains lines longer than 80 characters, this is not supported"
284 fi
285}
286
281addtask deploy before do_build after do_install 287addtask deploy before do_build after do_install
282do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}" 288do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
283 289