summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus Comstedt <marcus@mc.pp.se>2021-07-30 15:46:16 +0200
committerAndrei Gherzan <andrei@gherzan.com>2021-08-19 11:03:16 +0300
commit596907b3bae9dc8fa7f1cea4cf87fe44be9a2417 (patch)
tree3b26154b3fe6d3b2f4e714ea63ab33532159918c
parentfcd7b67d9c00eb77787d470b6a7ea972736f1446 (diff)
downloadmeta-raspberrypi-596907b3bae9dc8fa7f1cea4cf87fe44be9a2417.tar.gz
pi-bluetooth: Add compatibility with non-systemd builds
Signed-off-by: Marcus Comstedt <marcus@mc.pp.se>
-rw-r--r--recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb b/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
index c91e3c5..75b581d 100644
--- a/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
+++ b/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
@@ -14,12 +14,14 @@ SRCREV = "fd4775bf90e037551532fc214a958074830bb80d"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'update-rc.d', d)}
17# hciuart.service replaces what was brcm43438.service 18# hciuart.service replaces what was brcm43438.service
18inherit systemd
19SYSTEMD_SERVICE:${PN} = "\ 19SYSTEMD_SERVICE:${PN} = "\
20 hciuart.service \ 20 hciuart.service \
21 bthelper@.service \ 21 bthelper@.service \
22" 22"
23INITSCRIPT_NAME = "btuart"
24INITSCRIPT_PARAMS = "start 18 2 3 4 5 ."
23 25
24do_install() { 26do_install() {
25 install -d ${D}${sysconfdir}/udev/rules.d 27 install -d ${D}${sysconfdir}/udev/rules.d
@@ -33,6 +35,14 @@ do_install() {
33 install -d ${D}${systemd_system_unitdir} 35 install -d ${D}${systemd_system_unitdir}
34 install -m 0644 ${S}/debian/pi-bluetooth.bthelper@.service ${D}${systemd_system_unitdir}/bthelper@.service 36 install -m 0644 ${S}/debian/pi-bluetooth.bthelper@.service ${D}${systemd_system_unitdir}/bthelper@.service
35 install -m 0644 ${S}/debian/pi-bluetooth.hciuart.service ${D}${systemd_system_unitdir}/hciuart.service 37 install -m 0644 ${S}/debian/pi-bluetooth.hciuart.service ${D}${systemd_system_unitdir}/hciuart.service
38 else
39 install -d ${D}${sysconfdir}/init.d/
40 cat > ${WORKDIR}/btuart.init << EOF
41#!/bin/sh
42/usr/bin/btuart
43EOF
44 install -m 0755 ${WORKDIR}/btuart.init ${D}${sysconfdir}/init.d/btuart
45 sed -i -e 's:TAG+="systemd".*$:RUN+="/usr/bin/bthelper %k":' ${D}${sysconfdir}/udev/rules.d/90-pi-bluetooth.rules
36 fi 46 fi
37} 47}
38 48