summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 20:00:20 +0200
committerAndrei Gherzan <andrei@gherzan.com>2021-08-04 12:30:12 +0300
commit3f703e1b1d8c523ef244e24f316079c80e02b1ab (patch)
tree39d8380a646953388d13dd3aa9d7454088e1a6ca
parent9ea7aa2cd2cdc775425797b689e782718896ea50 (diff)
downloadmeta-raspberrypi-3f703e1b1d8c523ef244e24f316079c80e02b1ab.tar.gz
Manually fix conversion
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--classes/sdcard_image-rpi.bbclass6
-rw-r--r--conf/layer.conf10
-rw-r--r--conf/machine/include/rpi-default-settings.inc4
-rw-r--r--conf/machine/raspberrypi3-64.conf2
-rw-r--r--conf/machine/raspberrypi4-64.conf2
-rw-r--r--docs/conf.py4
-rw-r--r--recipes-graphics/userland/userland_git.bb2
7 files changed, 15 insertions, 15 deletions
diff --git a/classes/sdcard_image-rpi.bbclass b/classes/sdcard_image-rpi.bbclass
index 7b06936..639cc41 100644
--- a/classes/sdcard_image-rpi.bbclass
+++ b/classes/sdcard_image-rpi.bbclass
@@ -23,7 +23,7 @@ inherit image_types
23# 0 4MiB 4MiB + 48MiB 4MiB + 48Mib + SDIMG_ROOTFS 23# 0 4MiB 4MiB + 48MiB 4MiB + 48Mib + SDIMG_ROOTFS
24 24
25# This image depends on the rootfs image 25# This image depends on the rootfs image
26IMAGE_TYPEDEP:rpi-sdimg = "${SDIMG_ROOTFS_TYPE}" 26IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}"
27 27
28# Kernel image name 28# Kernel image name
29SDIMG_KERNELIMAGE:raspberrypi ?= "kernel.img" 29SDIMG_KERNELIMAGE:raspberrypi ?= "kernel.img"
@@ -50,7 +50,7 @@ inherit kernel-artifact-names
50 50
51RPI_SDIMG_EXTRA_DEPENDS ?= "" 51RPI_SDIMG_EXTRA_DEPENDS ?= ""
52 52
53do_image:rpi_sdimg[depends] = " \ 53do_image_rpi_sdimg[depends] = " \
54 parted-native:do_populate_sysroot \ 54 parted-native:do_populate_sysroot \
55 mtools-native:do_populate_sysroot \ 55 mtools-native:do_populate_sysroot \
56 dosfstools-native:do_populate_sysroot \ 56 dosfstools-native:do_populate_sysroot \
@@ -62,7 +62,7 @@ do_image:rpi_sdimg[depends] = " \
62 ${RPI_SDIMG_EXTRA_DEPENDS} \ 62 ${RPI_SDIMG_EXTRA_DEPENDS} \
63" 63"
64 64
65do_image:rpi_sdimg[recrdeps] = "do_build" 65do_image_rpi_sdimg[recrdeps] = "do_build"
66 66
67# SD card image name 67# SD card image name
68SDIMG = "${IMGDEPLOYDIR}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.rpi-sdimg" 68SDIMG = "${IMGDEPLOYDIR}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.rpi-sdimg"
diff --git a/conf/layer.conf b/conf/layer.conf
index 944df21..c36c7e3 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -6,11 +6,11 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
6 ${LAYERDIR}/recipes*/*/*.bbappend" 6 ${LAYERDIR}/recipes*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "raspberrypi" 8BBFILE_COLLECTIONS += "raspberrypi"
9BBFILE_PATTERN:raspberrypi := "^${LAYERDIR}/" 9BBFILE_PATTERN_raspberrypi := "^${LAYERDIR}/"
10BBFILE_PRIORITY:raspberrypi = "9" 10BBFILE_PRIORITY_raspberrypi = "9"
11 11
12LAYERSERIES_COMPAT:raspberrypi = "hardknott honister" 12LAYERSERIES_COMPAT_raspberrypi = "hardknott honister"
13LAYERDEPENDS:raspberrypi = "core" 13LAYERDEPENDS_raspberrypi = "core"
14 14
15# Additional license directories. 15# Additional license directories.
16LICENSE_PATH += "${LAYERDIR}/files/custom-licenses" 16LICENSE_PATH += "${LAYERDIR}/files/custom-licenses"
@@ -37,4 +37,4 @@ BBFILES_DYNAMIC += " \
37" 37"
38 38
39DEFAULT_TEST_SUITES:remove:rpi = "parselogs" 39DEFAULT_TEST_SUITES:remove:rpi = "parselogs"
40DEFAULT_TEST_SUITES:append:rpi = " parselogs:rpi" 40DEFAULT_TEST_SUITES:append:rpi = " parselogs_rpi"
diff --git a/conf/machine/include/rpi-default-settings.inc b/conf/machine/include/rpi-default-settings.inc
index a89ddb1..b788f14 100644
--- a/conf/machine/include/rpi-default-settings.inc
+++ b/conf/machine/include/rpi-default-settings.inc
@@ -3,7 +3,7 @@
3IMAGE_CLASSES += "sdcard_image-rpi" 3IMAGE_CLASSES += "sdcard_image-rpi"
4 4
5# RPI kernel has errors of its own which should be filtered 5# RPI kernel has errors of its own which should be filtered
6# therefore use parselogs:rpi test instead of parselogs from oe-core 6# therefore use parselogs_rpi test instead of parselogs from oe-core
7# 7#
8DEFAULT_TEST_SUITES:append:rpi = " parselogs:rpi" 8DEFAULT_TEST_SUITES:append:rpi = " parselogs_rpi"
9DEFAULT_TEST_SUITES:remove:rpi = " parselogs" 9DEFAULT_TEST_SUITES:remove:rpi = " parselogs"
diff --git a/conf/machine/raspberrypi3-64.conf b/conf/machine/raspberrypi3-64.conf
index 4ed2d2a..5394132 100644
--- a/conf/machine/raspberrypi3-64.conf
+++ b/conf/machine/raspberrypi3-64.conf
@@ -23,7 +23,7 @@ RPI_KERNEL_DEVICETREE = " \
23 23
24SERIAL_CONSOLES ?= "115200;ttyS0" 24SERIAL_CONSOLES ?= "115200;ttyS0"
25 25
26UBOOT_MACHINE = "rpi:arm64_config" 26UBOOT_MACHINE = "rpi_arm64_config"
27 27
28# When u-boot is enabled we need to use the "Image" format and the "booti" 28# When u-boot is enabled we need to use the "Image" format and the "booti"
29# command to load the kernel 29# command to load the kernel
diff --git a/conf/machine/raspberrypi4-64.conf b/conf/machine/raspberrypi4-64.conf
index 99a2a7c..12c8954 100644
--- a/conf/machine/raspberrypi4-64.conf
+++ b/conf/machine/raspberrypi4-64.conf
@@ -22,7 +22,7 @@ RPI_KERNEL_DEVICETREE = " \
22SDIMG_KERNELIMAGE ?= "kernel8.img" 22SDIMG_KERNELIMAGE ?= "kernel8.img"
23SERIAL_CONSOLES ?= "115200;ttyS0" 23SERIAL_CONSOLES ?= "115200;ttyS0"
24 24
25UBOOT_MACHINE = "rpi:arm64_config" 25UBOOT_MACHINE = "rpi_arm64_config"
26 26
27VC4DTBO ?= "vc4-fkms-v3d" 27VC4DTBO ?= "vc4-fkms-v3d"
28 28
diff --git a/docs/conf.py b/docs/conf.py
index e96f951..fcebbf1 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -284,7 +284,7 @@ latex_documents = [
284 284
285# Documents to append as an appendix to all manuals. 285# Documents to append as an appendix to all manuals.
286# 286#
287# latex:appendices = [] 287# latex_appendices = []
288 288
289# It false, will not define \strong, \code, itleref, \crossref ... but only 289# It false, will not define \strong, \code, itleref, \crossref ... but only
290# \sphinxstrong, ..., \sphinxtitleref, ... To help avoid clash with user added 290# \sphinxstrong, ..., \sphinxtitleref, ... To help avoid clash with user added
@@ -324,7 +324,7 @@ texinfo_documents = [
324 324
325# Documents to append as an appendix to all manuals. 325# Documents to append as an appendix to all manuals.
326# 326#
327# texinfo:appendices = [] 327# texinfo_appendices = []
328 328
329# If false, no module index is generated. 329# If false, no module index is generated.
330# 330#
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 4b01535..5676e30 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "This repository contains the source code for the ARM side \ 1DESCRIPTION = "This repository contains the source code for the ARM side \
2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \ 2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \
3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\ 3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\
4vcos, openmaxil, vchiq:arm, bcm_host, WFC, OpenVG." 4vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG."
5LICENSE = "BSD-3-Clause" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196" 6LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
7 7