diff options
Diffstat (limited to 'recipes-qt')
-rw-r--r-- | recipes-qt/qt5/nativesdk-qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qt3d_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5.inc | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtconnectivity_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtdeclarative_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtgamepad_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtlocation_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquickcontrols2_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquickcontrols_git.bb | 13 | ||||
-rw-r--r-- | recipes-qt/qt5/qtserialbus_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtxmlpatterns_git.bb | 2 |
15 files changed, 27 insertions, 14 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb index 424ccf75..714b367e 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bb +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb | |||
@@ -191,4 +191,4 @@ fakeroot do_generate_qt_environment_file() { | |||
191 | 191 | ||
192 | addtask generate_qt_environment_file after do_install before do_package | 192 | addtask generate_qt_environment_file after do_install before do_package |
193 | 193 | ||
194 | SRCREV = "43a5fe258b7f48baad69ac040f395cb597022fa9" | 194 | SRCREV = "e1c8451ffeeaa82f29aa2519addfa377f678ed9e" |
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb index 67fbe04b..882ab12a 100644 --- a/recipes-qt/qt5/qt3d_git.bb +++ b/recipes-qt/qt5/qt3d_git.bb | |||
@@ -34,6 +34,6 @@ do_configure_prepend() { | |||
34 | ${S}/src/quick3d/imports/input/importsinput.pro | 34 | ${S}/src/quick3d/imports/input/importsinput.pro |
35 | } | 35 | } |
36 | 36 | ||
37 | SRCREV = "7cbbf942972b9619af9442218ff2e16857536fb8" | 37 | SRCREV = "4fb03dc1d50c9638b6045e1d99fbeff863662c2d" |
38 | 38 | ||
39 | BBCLASSEXTEND += "native nativesdk" | 39 | BBCLASSEXTEND += "native nativesdk" |
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc index 6630665f..6f925244 100644 --- a/recipes-qt/qt5/qt5.inc +++ b/recipes-qt/qt5/qt5.inc | |||
@@ -119,6 +119,7 @@ FILES_${PN}-qmlplugins = " \ | |||
119 | ${OE_QMAKE_PATH_QML}/*/*/*/images \ | 119 | ${OE_QMAKE_PATH_QML}/*/*/*/images \ |
120 | ${OE_QMAKE_PATH_QML}/*/*/*/*.qmltypes \ | 120 | ${OE_QMAKE_PATH_QML}/*/*/*/*.qmltypes \ |
121 | ${OE_QMAKE_PATH_QML}/*/*/*/*.qml \ | 121 | ${OE_QMAKE_PATH_QML}/*/*/*/*.qml \ |
122 | ${OE_QMAKE_PATH_QML}/*/*/*/*.qmlc \ | ||
122 | ${OE_QMAKE_PATH_QML}/*/*/*/*.js \ | 123 | ${OE_QMAKE_PATH_QML}/*/*/*/*.js \ |
123 | ${OE_QMAKE_PATH_QML}/*/*/*/*.png \ | 124 | ${OE_QMAKE_PATH_QML}/*/*/*/*.png \ |
124 | ${OE_QMAKE_PATH_QML}/*/*/*/*.metainfo \ | 125 | ${OE_QMAKE_PATH_QML}/*/*/*/*.metainfo \ |
@@ -126,6 +127,7 @@ FILES_${PN}-qmlplugins = " \ | |||
126 | ${OE_QMAKE_PATH_QML}/*/*/*/*/qmldir \ | 127 | ${OE_QMAKE_PATH_QML}/*/*/*/*/qmldir \ |
127 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.qmltypes \ | 128 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.qmltypes \ |
128 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.qml \ | 129 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.qml \ |
130 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.qmlc \ | ||
129 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.js \ | 131 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.js \ |
130 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*/*.png \ | 132 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*/*.png \ |
131 | ${OE_QMAKE_PATH_IMPORTS}/*.qmltypes \ | 133 | ${OE_QMAKE_PATH_IMPORTS}/*.qmltypes \ |
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb index ef217488..7226c904 100644 --- a/recipes-qt/qt5/qtbase-native_git.bb +++ b/recipes-qt/qt5/qtbase-native_git.bb | |||
@@ -109,4 +109,4 @@ do_install() { | |||
109 | install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS} | 109 | install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS} |
110 | } | 110 | } |
111 | 111 | ||
112 | SRCREV = "43a5fe258b7f48baad69ac040f395cb597022fa9" | 112 | SRCREV = "e1c8451ffeeaa82f29aa2519addfa377f678ed9e" |
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index 89439781..8a90b4eb 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -182,4 +182,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps" | |||
182 | 182 | ||
183 | RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" | 183 | RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" |
184 | 184 | ||
185 | SRCREV = "43a5fe258b7f48baad69ac040f395cb597022fa9" | 185 | SRCREV = "e1c8451ffeeaa82f29aa2519addfa377f678ed9e" |
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb index c9ea7e61..a1ac8b9c 100644 --- a/recipes-qt/qt5/qtconnectivity_git.bb +++ b/recipes-qt/qt5/qtconnectivity_git.bb | |||
@@ -23,4 +23,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}" | |||
23 | 23 | ||
24 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" | 24 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" |
25 | 25 | ||
26 | SRCREV = "8f09b31d98d50e9041d294e96eb0726cdf58f4b5" | 26 | SRCREV = "60d27ebd2977eee384461469053755c6ba36f102" |
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb index 7b8a7328..1ff6aa82 100644 --- a/recipes-qt/qt5/qtdeclarative_git.bb +++ b/recipes-qt/qt5/qtdeclarative_git.bb | |||
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() { | |||
32 | 32 | ||
33 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" | 33 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" |
34 | 34 | ||
35 | SRCREV = "452a78d0ac4a1579733a8ab641be24c9b7c0dd96" | 35 | SRCREV = "1bee1eb0f80ca099945e60c113d24f7fa1e0ef29" |
36 | 36 | ||
37 | BBCLASSEXTEND =+ "native nativesdk" | 37 | BBCLASSEXTEND =+ "native nativesdk" |
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb index 083ee91f..2174f802 100644 --- a/recipes-qt/qt5/qtgamepad_git.bb +++ b/recipes-qt/qt5/qtgamepad_git.bb | |||
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2" | |||
14 | 14 | ||
15 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" | 15 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" |
16 | 16 | ||
17 | SRCREV = "582bb5d97668877e1e2b4a45bf78ad7542771f21" | 17 | SRCREV = "c7f84dfc27f3afc9a8f4a8bacb8d036d090bb49c" |
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb index 83af0b69..4c058286 100644 --- a/recipes-qt/qt5/qtlocation_git.bb +++ b/recipes-qt/qt5/qtlocation_git.bb | |||
@@ -24,7 +24,7 @@ SRC_URI += " \ | |||
24 | ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \ | 24 | ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \ |
25 | " | 25 | " |
26 | 26 | ||
27 | SRCREV_qtlocation = "8714cb31102026f96a3fbf10b8d715319d400536" | 27 | SRCREV_qtlocation = "453fab84c606328811bafd4de9cde5564620fdc6" |
28 | SRCREV_qtlocation-mapboxgl = "fa9e435795a958b44d50a5cd9cfb4a83363c1923" | 28 | SRCREV_qtlocation-mapboxgl = "fa9e435795a958b44d50a5cd9cfb4a83363c1923" |
29 | 29 | ||
30 | SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl" | 30 | SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl" |
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb index 1174b430..5b841f79 100644 --- a/recipes-qt/qt5/qtquickcontrols2_git.bb +++ b/recipes-qt/qt5/qtquickcontrols2_git.bb | |||
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \ | |||
10 | 10 | ||
11 | DEPENDS += "qtdeclarative" | 11 | DEPENDS += "qtdeclarative" |
12 | 12 | ||
13 | SRCREV = "dcb0dd861bec6eb61b6bca6dad9399f59a5a1c2c" | 13 | SRCREV = "2e8922b144e7308d6895528977b9e94b13b5e902" |
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb index bcfe61c7..f566e156 100644 --- a/recipes-qt/qt5/qtquickcontrols_git.bb +++ b/recipes-qt/qt5/qtquickcontrols_git.bb | |||
@@ -17,8 +17,19 @@ DEPENDS += "qtdeclarative" | |||
17 | 17 | ||
18 | RDEPENDS_${PN}-dev = "" | 18 | RDEPENDS_${PN}-dev = "" |
19 | 19 | ||
20 | FILES_${PN}-qmlplugins += " \ | ||
21 | ${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders \ | ||
22 | ${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders/* \ | ||
23 | ${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders/+hlsl \ | ||
24 | ${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders/+hlsl/* \ | ||
25 | ${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders/+glslcore \ | ||
26 | ${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders/+glslcore/* \ | ||
27 | ${OE_QMAKE_PATH_QML}/QtQuick/Controls/Private/*.jsc \ | ||
28 | ${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \ | ||
29 | " | ||
30 | |||
20 | SRC_URI += " \ | 31 | SRC_URI += " \ |
21 | file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \ | 32 | file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \ |
22 | " | 33 | " |
23 | 34 | ||
24 | SRCREV = "da9183da38513d5531af3753d14d040991e04132" | 35 | SRCREV = "751f08cf46f505980b8ebe9a228a6c229b470152" |
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb index 0cf6432e..2d94982e 100644 --- a/recipes-qt/qt5/qtserialbus_git.bb +++ b/recipes-qt/qt5/qtserialbus_git.bb | |||
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \ | |||
11 | 11 | ||
12 | DEPENDS += "qtbase qtserialport" | 12 | DEPENDS += "qtbase qtserialport" |
13 | 13 | ||
14 | SRCREV = "e6a10bc0b5c7be73c5a58f8e565c1d571723bc4a" | 14 | SRCREV = "0ac7bc6e57be2a7c2ee14bfaf7489e20daf3edc0" |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 1e7f268f..e4802ec3 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -111,7 +111,7 @@ SRC_URI += " \ | |||
111 | file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ | 111 | file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ |
112 | " | 112 | " |
113 | 113 | ||
114 | SRCREV_qtwebengine = "2d235e2112b71e0011c3c31f8d496680091dac66" | 114 | SRCREV_qtwebengine = "fa94cb09e095a6d6c5634ae8543fc70145594c05" |
115 | SRCREV_chromium = "853d4069e45b06106f33611c458f5480f71e7c57" | 115 | SRCREV_chromium = "853d4069e45b06106f33611c458f5480f71e7c57" |
116 | SRCREV = "${SRCREV_qtwebengine}" | 116 | SRCREV = "${SRCREV_qtwebengine}" |
117 | 117 | ||
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb index 9fd44148..8de7d117 100644 --- a/recipes-qt/qt5/qtwebkit_git.bb +++ b/recipes-qt/qt5/qtwebkit_git.bb | |||
@@ -85,4 +85,4 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db | |||
85 | RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }" | 85 | RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }" |
86 | export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}" | 86 | export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}" |
87 | 87 | ||
88 | SRCREV = "54110a075ed5eba337e3463d33ad45b538d9365a" | 88 | SRCREV = "ce29c5f019ffe0ceec6eb9be3d82e1c061d0d530" |
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb index 72d1f9a6..7f51e06d 100644 --- a/recipes-qt/qt5/qtxmlpatterns_git.bb +++ b/recipes-qt/qt5/qtxmlpatterns_git.bb | |||
@@ -16,6 +16,6 @@ LIC_FILES_CHKSUM = " \ | |||
16 | 16 | ||
17 | DEPENDS += "qtbase" | 17 | DEPENDS += "qtbase" |
18 | 18 | ||
19 | SRCREV = "7c92929b7611d873df34434151fe28ae88daed4f" | 19 | SRCREV = "3a44e86cdceba7acc6b830274968b0dfa482f5a8" |
20 | 20 | ||
21 | BBCLASSEXTEND =+ "native nativesdk" | 21 | BBCLASSEXTEND =+ "native nativesdk" |