summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch26
-rw-r--r--recipes-qt/qt5/qt3d_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
20 files changed, 20 insertions, 47 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 0788794b..ee6c1730 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -191,4 +191,4 @@ fakeroot do_generate_qt_environment_file() {
191 191
192addtask generate_qt_environment_file after do_install before do_package 192addtask generate_qt_environment_file after do_install before do_package
193 193
194SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a" 194SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b"
diff --git a/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch b/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch
deleted file mode 100644
index 0d8d0837..00000000
--- a/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 6a1c600bcb6288c021eafdef516b8313c60505a3 Mon Sep 17 00:00:00 2001
2From: Mikko Gronoff <mikko.gronoff@qt.io>
3Date: Fri, 17 Mar 2017 14:42:12 +0200
4Subject: [PATCH] qt3d: include qcoreapplication.h header in
5 qtquickscene2dplugin.cpp
6
7Fix build break in qt3d:
8Add #include <QtCore/qcoreapplication.h> to qtquickscene2dplugin.cpp
9to prevent build break due unknown Q_COREAPP_STARTUP_FUNCTION macro.
10---
11 src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp | 2 ++
12 1 file changed, 2 insertions(+)
13
14diff --git a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
15index c67271a..224b24f 100644
16--- a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
17+++ b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
18@@ -40,6 +40,8 @@
19 #include <private/qrenderaspect_p.h>
20 #include <Qt3DQuickScene2D/private/qt3dquick3dscene2d_p.h>
21
22+#include <QtCore/qcoreapplication.h>
23+
24 QT_BEGIN_NAMESPACE
25
26 static void initScene2dPlugin()
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 10ffd9c9..ee757437 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -13,7 +13,6 @@ DEPENDS_class-target += "qtdeclarative qt3d-native"
13 13
14SRC_URI += " \ 14SRC_URI += " \
15 file://0001-Allow-a-tools-only-build.patch \ 15 file://0001-Allow-a-tools-only-build.patch \
16 file://0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch \
17" 16"
18 17
19PACKAGECONFIG ??= "" 18PACKAGECONFIG ??= ""
@@ -35,6 +34,6 @@ do_configure_prepend() {
35 ${S}/src/quick3d/imports/input/importsinput.pro 34 ${S}/src/quick3d/imports/input/importsinput.pro
36} 35}
37 36
38SRCREV = "fd39bbaca2fe8e29bb9b603340ed94c7480b6da5" 37SRCREV = "873e8ac06c606e71aafb9be9baa21143e6757df5"
39 38
40BBCLASSEXTEND += "native nativesdk" 39BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 32c59498..88ff4231 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -106,4 +106,4 @@ do_install() {
106 install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS} 106 install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
107} 107}
108 108
109SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a" 109SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index a6375a6c..36a9f3cb 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -182,4 +182,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
182 182
183RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" 183RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
184 184
185SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a" 185SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 29c0a985..f0d80524 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
8 8
9DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns" 9DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
10 10
11SRCREV = "fb9e66188e0582a6b80ad3b8b3ac80024180a9df" 11SRCREV = "1a4d36afc821d745fe304f222e73d6c2fa249afa"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 6ef0f60e..6fd2866c 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
32 32
33EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" 33EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
34 34
35SRCREV = "7a125135e1ef592aa20a29f7aac1a6117a6b1770" 35SRCREV = "73f365f9f2d04131ae27a5dba26255feda18baa2"
36 36
37BBCLASSEXTEND =+ "native nativesdk" 37BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 93a9a7c2..24e14225 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -24,7 +24,7 @@ SRC_URI += " \
24 ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \ 24 ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
25 " 25 "
26 26
27SRCREV_qtlocation = "51052caaa27c639c10f7618a853d0b374720c6ea" 27SRCREV_qtlocation = "a7cadd6f5f5278220847dcb2c4897a3c40896ea3"
28SRCREV_qtlocation-mapboxgl = "60320d74ba577185d1d90a7f234e182ca06d7d76" 28SRCREV_qtlocation-mapboxgl = "60320d74ba577185d1d90a7f234e182ca06d7d76"
29 29
30SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl" 30SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 6f156f22..e07faea4 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -33,4 +33,4 @@ SRC_URI += "\
33 file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \ 33 file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \
34" 34"
35 35
36SRCREV = "03560060a1702af5190b60fec74f9e71b3c2e104" 36SRCREV = "6c3b0fdb5ceb9079241cb7136d756e9dba114cfe"
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index 89ee7818..2f16a36f 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -23,4 +23,4 @@ do_configure_prepend() {
23} 23}
24 24
25QT_MODULE_BRANCH = "dev" 25QT_MODULE_BRANCH = "dev"
26SRCREV = "a0783470449a911fce09d6328abfcff17973d421" 26SRCREV = "695460401d9a89d2f156016d51601b2e59b64105"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 7158bdc3..a67fb368 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
10 10
11DEPENDS += "qtdeclarative" 11DEPENDS += "qtdeclarative"
12 12
13SRCREV = "9df0f8cb35ee1c134f772f432272e6e020bf9c52" 13SRCREV = "40f454dbfe0e3c73e9d8a77d58938736000a70f4"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index eca7e818..329b4b66 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -21,4 +21,4 @@ SRC_URI += " \
21 file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \ 21 file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
22" 22"
23 23
24SRCREV = "b7ce67c2774197026885e500e9ef495460eb0d33" 24SRCREV = "b84d25b20ed316529ae2fa091c5d9e2fbf45e023"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 089ee4f8..ae5e0da4 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -25,4 +25,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
25 25
26DEPENDS += "qtbase" 26DEPENDS += "qtbase"
27 27
28SRCREV = "5cde7e8668c0d8729674e4fdd96ee6de52e6c2c3" 28SRCREV = "e00ca9b6bec2adf78fd14e02376ecf1b55a93b0c"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 368a1e9d..8c55526a 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
10 10
11DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native" 11DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
12 12
13SRCREV = "34e9418cd669a706dd407f0032c5de564212369e" 13SRCREV = "06ee5829c54e1aafeb03d387a8f5d6377a7ed115"
14 14
15SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch" 15SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
16 16
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index c9ced273..20468e18 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
11 11
12DEPENDS += "qtbase qtserialport" 12DEPENDS += "qtbase qtserialport"
13 13
14SRCREV = "71a31bf19bb0cce506638bc79ba96bc5e5da92fe" 14SRCREV = "dc124162efeabe90b9025789391d1f0e15cef0f1"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 4b79b0bc..76e6dd6f 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
15 15
16DEPENDS += "qtbase" 16DEPENDS += "qtbase"
17 17
18SRCREV = "5c6a433d6a6a4176082036ae94931467101a199a" 18SRCREV = "d320f01018f0273e4fea2e0a7aa8f30ee8129587"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 0667ac00..81c14d79 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -29,6 +29,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
29 29
30EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}" 30EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
31 31
32SRCREV = "c5e54d58e8763898db81e1f3b5b5460d6e4b9455" 32SRCREV = "224a4bdc0380b15e6a8f07dc0d4bf9ae4dae1996"
33 33
34BBCLASSEXTEND = "native nativesdk" 34BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 741ff86a..0a42d7a6 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
49 49
50DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns" 50DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
51 51
52SRCREV = "956a6a04a7a98be7c05320b504674260b4322851" 52SRCREV = "1efffb8fea600c77925422cdf85f6c024ab3d8b2"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 80278935..5c10bb41 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -41,7 +41,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
41 41
42EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" 42EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
43 43
44SRCREV = "dfcda81c5b13ad15517a37bcc45f3bf5f550466c" 44SRCREV = "50fea6ae0e9ee863f02d0343baa06ccdf06b7238"
45 45
46# From https://bugreports.qt.io/browse/QTBUG-57767 46# From https://bugreports.qt.io/browse/QTBUG-57767
47SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch" 47SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 60815e7f..f1bdedbd 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -111,8 +111,8 @@ SRC_URI += " \
111 file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ 111 file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
112" 112"
113 113
114SRCREV_qtwebengine = "140d12802c9ebc54f5816fbf1a410c5bdc730ec6" 114SRCREV_qtwebengine = "57fee86eb2756a2f102e2bbeb16a443b84a17e01"
115SRCREV_chromium = "8d882ead843178d1ba30f0d80d722e147788e6d1" 115SRCREV_chromium = "bba44efa6bb5707bf6fb4e92627e3326be3f3a3b"
116SRCREV = "${SRCREV_qtwebengine}" 116SRCREV = "${SRCREV_qtwebengine}"
117 117
118SRCREV_FORMAT = "qtwebengine_chromium" 118SRCREV_FORMAT = "qtwebengine_chromium"