summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb50
1 files changed, 26 insertions, 24 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 3a6a37e2..dcb81747 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -123,38 +123,40 @@ RDEPENDS_${PN}-examples += " \
123 123
124QT_MODULE_BRANCH_CHROMIUM = "61-based" 124QT_MODULE_BRANCH_CHROMIUM = "61-based"
125 125
126# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.9 126# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.10
127# 5.9.meta-qt5.3 127# 5.10.meta-qt5.1
128SRC_URI += " \ 128SRC_URI += " \
129 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 129 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
130 file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \ 130 file://0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
131 file://0003-Include-dependency-to-QCoreApplication-translate.patch \ 131 file://0002-Include-dependency-to-QCoreApplication-translate.patch \
132 file://0004-Force-host-toolchain-configuration.patch \ 132 file://0003-Force-host-toolchain-configuration.patch \
133"
134SRC_URI_append_libc-musl = "\
135 file://0004-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
136 file://0005-musl-link-against-libexecinfo.patch \
133" 137"
134 138
135# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based 139# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/61-based
136# 56-based.meta-qt5.2 140# 61-based.meta-qt5.1
137SRC_URI += " \ 141SRC_URI += " \
138 file://0002-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \ 142 file://0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
139 file://0003-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \ 143 file://0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
140" 144"
141 145
142SRC_URI_append_libc-musl = "\ 146SRC_URI_append_libc-musl = "\
143 file://0005-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \ 147 file://0003-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
144 file://0006-musl-link-against-libexecinfo.patch \ 148 file://0004-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
145 file://0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 149 file://0005-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
146 file://0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 150 file://0006-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
147 file://0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 151 file://0007-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
148 file://0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \ 152 file://0008-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
149 file://0008-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \ 153 file://0009-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
150 file://0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \ 154 file://0010-chromium-musl-Match-syscalls-to-match-musl.patch;patchdir=src/3rdparty \
151 file://0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \ 155 file://0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
152 file://0011-chromium-musl-Match-syscalls-to-match-musl.patch;patchdir=src/3rdparty \ 156 file://0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
153 file://0012-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \ 157 file://0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
154 file://0013-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \ 158 file://0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
155 file://0014-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \ 159 file://0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
156 file://0015-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
157 file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
158" 160"
159 161
160SRCREV_qtwebengine = "efa6d3f0d3a01753dd40823ce119e7d4f9765c8e" 162SRCREV_qtwebengine = "efa6d3f0d3a01753dd40823ce119e7d4f9765c8e"