summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
new file mode 100644
index 00000000..f4964bf7
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -0,0 +1,24 @@
1require qt5-git.inc
2require ${PN}.inc
3
4# QtWebEngine has it's own version format currently and doesn't follow the major Qt
5# versions (but it's release are at the same time as of major Qt releases). We're tracking
6# the master branch which will lead to 1.0 when Qt 5.4 is released here.
7PV = "0.9.99+git${SRCPV}"
8
9QT_MODULE_BRANCH = "master"
10
11# For now we have to define SRC_URI here again as qt5-git.inc points to
12# qt.gitorious.org/qt/ but qtwebengine is still on qt.gitorious.org/qt-labs/ which will
13# switch soon.
14SRC_URI = " \
15 git://gitorious.org/qt-labs/qtwebengine.git;name=qtwebengine;protocol=git;branch=${QT_MODULE_BRANCH} \
16 git://gitorious.org/qt-labs/chromium.git;name=chromium;protocol=git;branch=${QT_MODULE_BRANCH};destsuffix=git/src/3rdparty \
17 file://0001-Drop-build-time-only-dependency-on-x11-libraries.patch \
18 file://0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch \
19 file://0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch \
20"
21SRCREV_qtwebengine = "21f6ce84ecca9a4ff2aa980b21d2e5174c78d14b"
22SRCREV_chromium = "1f3cc8c2618979b557d60ef1ad984a49dca83bff"
23
24SRCREV_FORMAT = "qtwebengine"