summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative_git.bb')
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb11
1 files changed, 1 insertions, 10 deletions
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index b09e96e7..56a98eaa 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -14,25 +14,16 @@ LIC_FILES_CHKSUM = " \
14 14
15DEPENDS += "qtbase" 15DEPENDS += "qtbase"
16 16
17PACKAGECONFIG ??= "qtxmlpatterns qml-debug qml-network ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)}" 17PACKAGECONFIG ??= "qml-debug qml-network ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)}"
18PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns"
19PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug" 18PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug"
20PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network" 19PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network"
21PACKAGECONFIG[static] = ",,qtdeclarative-native" 20PACKAGECONFIG[static] = ",,qtdeclarative-native"
22 21
23do_configure_prepend() {
24 # disable qtxmlpatterns test if it isn't enabled by PACKAGECONFIG
25 sed -e 's/^\(qtHaveModule(xmlpatterns)\)/OE_QTXMLPATTERNS_ENABLED:\1/' -i ${S}/src/imports/imports.pro
26 sed -e 's/^\(!qtHaveModule(xmlpatterns)\)/!OE_QTXMLPATTERNS_ENABLED|\1/' -i ${S}/tests/auto/quick/quick.pro
27}
28
29do_install_append_class-nativesdk() { 22do_install_append_class-nativesdk() {
30 # qml files not needed in nativesdk 23 # qml files not needed in nativesdk
31 rm -rf ${D}${OE_QMAKE_PATH_QML} 24 rm -rf ${D}${OE_QMAKE_PATH_QML}
32} 25}
33 26
34EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
35
36SRCREV = "c401ae278b4bb91c70c6d7df974a241d7c68855b" 27SRCREV = "c401ae278b4bb91c70c6d7df974a241d7c68855b"
37 28
38BBCLASSEXTEND =+ "native nativesdk" 29BBCLASSEXTEND =+ "native nativesdk"