summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch37
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch b/recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch
new file mode 100644
index 00000000..8b82010c
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch
@@ -0,0 +1,37 @@
1From 006f08373cbaa8485311f491ab8e67433c0e9ad6 Mon Sep 17 00:00:00 2001
2From: Daniel Mack <daniel@zonque.org>
3Date: Tue, 24 Oct 2017 15:46:19 +0200
4Subject: [PATCH] tests: make accessibility tests conditional
5
6Only test the accessibility functions if accessibility was enabled in the Qt
7config.
8---
9 tests/auto/widgets/widgets.pro | 5 ++++-
10 1 file changed, 4 insertions(+), 1 deletion(-)
11
12diff --git a/tests/auto/widgets/widgets.pro b/tests/auto/widgets/widgets.pro
13index 441eea0f..7bab18f0 100644
14--- a/tests/auto/widgets/widgets.pro
15+++ b/tests/auto/widgets/widgets.pro
16@@ -1,7 +1,6 @@
17 TEMPLATE = subdirs
18
19 SUBDIRS += \
20- qwebengineaccessibility \
21 qwebenginedefaultsurfaceformat \
22 qwebenginedownloads \
23 qwebenginefaviconmanager \
24@@ -14,6 +13,10 @@ SUBDIRS += \
25 qwebenginesettings \
26 qwebengineview
27
28+qtConfig(accessibility) {
29+ SUBDIRS += qwebengineaccessibility
30+}
31+
32 contains(WEBENGINE_CONFIG, use_spellchecker):!cross_compile {
33 !contains(WEBENGINE_CONFIG, use_native_spellchecker) {
34 SUBDIRS += qwebenginespellcheck
35--
362.13.6
37
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 4ced7925..50a98b66 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -137,6 +137,7 @@ SRC_URI += " \
137 file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \ 137 file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
138 file://0003-Include-dependency-to-QCoreApplication-translate.patch \ 138 file://0003-Include-dependency-to-QCoreApplication-translate.patch \
139 file://0004-Force-host-toolchain-configuration.patch \ 139 file://0004-Force-host-toolchain-configuration.patch \
140 file://0005-tests-make-accessibility-tests-conditional.patch \
140" 141"
141 142
142# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based 143# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based