summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-06-08 09:56:37 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-02 12:23:26 +0200
commiteedb3e64137cdcab347aefe6ef3f9e781cce83e8 (patch)
treef960918adc36ea57879bcaf13be90cc55c32275b /recipes-qt
parent5509fa944cb9ec640e380ab733ab93ca516189f3 (diff)
downloadmeta-qt5-eedb3e64137cdcab347aefe6ef3f9e781cce83e8.tar.gz
qtwebkit: Fix build with musl
Make backtrace() API conditional to glibc Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtwebkit/0003-Exclude-backtrace-API-for-non-glibc-libraries.patch38
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0003-Exclude-backtrace-API-for-non-glibc-libraries.patch b/recipes-qt/qt5/qtwebkit/0003-Exclude-backtrace-API-for-non-glibc-libraries.patch
new file mode 100644
index 00000000..6a9d1f41
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0003-Exclude-backtrace-API-for-non-glibc-libraries.patch
@@ -0,0 +1,38 @@
1From b345a3414a7d09b47586aac437d79e2bbfa52fb8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 5 Jun 2015 19:55:05 -0700
4Subject: [PATCH] Exclude backtrace() API for non-glibc libraries
5
6It was excluding musl with current checks, so lets make it such that it
7considers only glibc when using backtrace API
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Source/WTF/wtf/Assertions.cpp | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/Source/WTF/wtf/Assertions.cpp b/Source/WTF/wtf/Assertions.cpp
15index 1b2091f..ba03a28 100644
16--- a/Source/WTF/wtf/Assertions.cpp
17+++ b/Source/WTF/wtf/Assertions.cpp
18@@ -61,7 +61,7 @@
19 #include <windows.h>
20 #endif
21
22-#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
23+#if (OS(DARWIN) || (OS(LINUX) && defined (__GLIBC__) && !defined(__UCLIBC__))) && !OS(ANDROID)
24 #include <cxxabi.h>
25 #include <dlfcn.h>
26 #include <execinfo.h>
27@@ -245,7 +245,7 @@ void WTFReportArgumentAssertionFailure(const char* file, int line, const char* f
28
29 void WTFGetBacktrace(void** stack, int* size)
30 {
31-#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
32+#if (OS(DARWIN) || (OS(LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__))) && !OS(ANDROID)
33 *size = backtrace(stack, *size);
34 #elif OS(WINDOWS) && !OS(WINCE)
35 // The CaptureStackBackTrace function is available in XP, but it is not defined
36--
372.1.4
38
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 77568af7..bad44efd 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -20,6 +20,7 @@ ARM_INSTRUCTION_SET = "arm"
20SRC_URI += "\ 20SRC_URI += "\
21 file://0001-qtwebkit-fix-QA-issue-bad-RPATH.patch \ 21 file://0001-qtwebkit-fix-QA-issue-bad-RPATH.patch \
22 file://0002-Remove-TEXTREL-tag-in-x86.patch \ 22 file://0002-Remove-TEXTREL-tag-in-x86.patch \
23 file://0003-Exclude-backtrace-API-for-non-glibc-libraries.patch \
23" 24"
24 25
25PACKAGECONFIG ??= "gstreamer qtlocation qtmultimedia qtsensors qtwebchannel" 26PACKAGECONFIG ??= "gstreamer qtlocation qtmultimedia qtsensors qtwebchannel"