diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-12-27 09:31:24 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-01-09 10:02:34 +0000 |
commit | 88fa1db0a6fde5a557a8fe2a15698fcde84ff822 (patch) | |
tree | a953ee33cbc9665bd71c7569b618311cbe0dee7b /recipes-qt | |
parent | da14e9464b2751a77ed73f678e6d676bbb8bcb95 (diff) | |
download | meta-qt5-88fa1db0a6fde5a557a8fe2a15698fcde84ff822.tar.gz |
Add QtNetworkAuth and QtSCXML modules
Change-Id: I94a2a24eb7395c78c6b02642ccdd15b935093406
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r-- | recipes-qt/qt5/qtnetworkauth_git.bb | 13 | ||||
-rw-r--r-- | recipes-qt/qt5/qtscxml_git.bb | 20 |
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb new file mode 100644 index 00000000..5657c869 --- /dev/null +++ b/recipes-qt/qt5/qtnetworkauth_git.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | LICENSE = "BSD & GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial" | ||
2 | LIC_FILES_CHKSUM = " \ | ||
3 | file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \ | ||
4 | file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \ | ||
5 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | ||
6 | " | ||
7 | |||
8 | require qt5.inc | ||
9 | require qt5-git.inc | ||
10 | |||
11 | DEPENDS += "qtbase" | ||
12 | |||
13 | SRCREV = "ec7663382bc6382323f3261ab199ec2edbeb5e37" | ||
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb new file mode 100644 index 00000000..8b6d575b --- /dev/null +++ b/recipes-qt/qt5/qtscxml_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | LICENSE = "LGPL-3.0 & BSD & GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial" | ||
2 | LIC_FILES_CHKSUM = " \ | ||
3 | file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | ||
4 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ | ||
5 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | ||
6 | " | ||
7 | |||
8 | require qt5.inc | ||
9 | require qt5-git.inc | ||
10 | |||
11 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native" | ||
12 | |||
13 | SRCREV = "4704292500b98143eee9b0fb0b6a34a858ed1253" | ||
14 | |||
15 | do_install_append_class-nativesdk() { | ||
16 | # qml files not needed in nativesdk | ||
17 | rm -rf ${D}${OE_QMAKE_PATH_QML} | ||
18 | } | ||
19 | |||
20 | BBCLASSEXTEND =+ "native nativesdk" | ||