summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-05-09 10:11:02 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-09 16:54:03 +0200
commit48138bfb2735e0e07065397d3c93516d202c3104 (patch)
tree09bc3634c4c657c4c5e1bf45c86c94e164684ca5 /recipes-qt
parent94b2064593e565ceaefdd7ef32506a99b0e6792b (diff)
downloadmeta-qt5-48138bfb2735e0e07065397d3c93516d202c3104.tar.gz
qtbase: use EXTRA_OEMAKE also in config.tests executed in do_configure
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase-5.0.2/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch35
-rw-r--r--recipes-qt/qt5/qtbase-git/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch35
-rw-r--r--recipes-qt/qt5/qtbase-native.inc1
-rw-r--r--recipes-qt/qt5/qtbase.inc1
-rw-r--r--recipes-qt/qt5/qtbase/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch35
5 files changed, 107 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase-5.0.2/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch b/recipes-qt/qt5/qtbase-5.0.2/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch
new file mode 100644
index 00000000..e432b979
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-5.0.2/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch
@@ -0,0 +1,35 @@
1From 68c459603bcf545637e852e08613c6fca4da9ef9 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 9 May 2013 10:06:50 +0200
4Subject: [PATCH 14/14] configure.prf: Allow to add extra arguments to make
5
6* sometimes we would like to add -e or define some variable and respect it from both
7 Makefiles used in configure tests and also Maakefiles to build the application
8
9Change-Id: Ib29beb89cc9b179dddd40d3b212b7c200d29a469
10---
11 mkspecs/features/configure.prf | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
15index 39144e7..1864ba8 100644
16--- a/mkspecs/features/configure.prf
17+++ b/mkspecs/features/configure.prf
18@@ -54,12 +54,12 @@ defineTest(qtCompileTest) {
19 qmake_configs = "\"CONFIG -= qt debug_and_release app_bundle lib_bundle\""
20
21 # Clean up after previous run
22- exists($$test_out_dir/Makefile):qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE distclean")
23+ exists($$test_out_dir/Makefile):qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE $$(QMAKE_MAKE_ARGS) distclean")
24
25 mkpath($$test_out_dir)|error("Aborting.")
26
27 qtRunLoggedCommand("$$test_cmd_base $$system_quote($$system_path($$QMAKE_QMAKE)) $$qmake_configs $$shell_quote($$test_dir)") {
28- qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE") {
29+ qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE $$(QMAKE_MAKE_ARGS)") {
30 log("yes$$escape_expand(\\n)")
31 msg = "test $$1 succeeded"
32 write_file($$QMAKE_CONFIG_LOG, msg, append)
33--
341.8.2.1
35
diff --git a/recipes-qt/qt5/qtbase-git/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch b/recipes-qt/qt5/qtbase-git/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch
new file mode 100644
index 00000000..7d4b32bf
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-git/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch
@@ -0,0 +1,35 @@
1From c57cec0fdcbc89671ef297c68554e27fbe99c09d Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 9 May 2013 10:06:50 +0200
4Subject: [PATCH 14/14] configure.prf: Allow to add extra arguments to make
5
6* sometimes we would like to add -e or define some variable and respect it from both
7 Makefiles used in configure tests and also Maakefiles to build the application
8
9Change-Id: Ib29beb89cc9b179dddd40d3b212b7c200d29a469
10---
11 mkspecs/features/configure.prf | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
15index b4569df..50ca562 100644
16--- a/mkspecs/features/configure.prf
17+++ b/mkspecs/features/configure.prf
18@@ -57,12 +57,12 @@ defineTest(qtCompileTest) {
19 qmake_configs = "\"CONFIG -= qt debug_and_release app_bundle lib_bundle\""
20
21 # Clean up after previous run
22- exists($$test_out_dir/Makefile):qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE distclean")
23+ exists($$test_out_dir/Makefile):qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE $$(QMAKE_MAKE_ARGS) distclean")
24
25 mkpath($$test_out_dir)|error("Aborting.")
26
27 qtRunLoggedCommand("$$test_cmd_base $$system_quote($$system_path($$QMAKE_QMAKE)) $$qmake_configs $$shell_quote($$test_dir)") {
28- qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE") {
29+ qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE $$(QMAKE_MAKE_ARGS)") {
30 log("yes$$escape_expand(\\n)")
31 msg = "test $$1 succeeded"
32 write_file($$QMAKE_CONFIG_LOG, msg, append)
33--
341.8.2.1
35
diff --git a/recipes-qt/qt5/qtbase-native.inc b/recipes-qt/qt5/qtbase-native.inc
index 1de1e1da..87698227 100644
--- a/recipes-qt/qt5/qtbase-native.inc
+++ b/recipes-qt/qt5/qtbase-native.inc
@@ -21,6 +21,7 @@ SRC_URI += " \
21 file://0011-qt_module-Fix-paths-in-.prl-files.patch \ 21 file://0011-qt_module-Fix-paths-in-.prl-files.patch \
22 file://0012-wayland-scanner-disable-silent-rules.patch \ 22 file://0012-wayland-scanner-disable-silent-rules.patch \
23 file://0013-configure-don-t-export-SYSTEM_VARIABLES-to-.qmake.va.patch \ 23 file://0013-configure-don-t-export-SYSTEM_VARIABLES-to-.qmake.va.patch \
24 file://0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch \
24" 25"
25 26
26# specific for native version 27# specific for native version
diff --git a/recipes-qt/qt5/qtbase.inc b/recipes-qt/qt5/qtbase.inc
index 3e471517..9624f1de 100644
--- a/recipes-qt/qt5/qtbase.inc
+++ b/recipes-qt/qt5/qtbase.inc
@@ -13,6 +13,7 @@ SRC_URI += " \
13 file://0011-qt_module-Fix-paths-in-.prl-files.patch \ 13 file://0011-qt_module-Fix-paths-in-.prl-files.patch \
14 file://0012-wayland-scanner-disable-silent-rules.patch \ 14 file://0012-wayland-scanner-disable-silent-rules.patch \
15 file://0013-configure-don-t-export-SYSTEM_VARIABLES-to-.qmake.va.patch \ 15 file://0013-configure-don-t-export-SYSTEM_VARIABLES-to-.qmake.va.patch \
16 file://0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch \
16" 17"
17 18
18DEPENDS += "qtbase-native freetype jpeg libpng zlib openssl glib-2.0 ${ICU} udev ${XCB_DEPENDS} ${GL_DEPENDS}" 19DEPENDS += "qtbase-native freetype jpeg libpng zlib openssl glib-2.0 ${ICU} udev ${XCB_DEPENDS} ${GL_DEPENDS}"
diff --git a/recipes-qt/qt5/qtbase/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch b/recipes-qt/qt5/qtbase/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch
new file mode 100644
index 00000000..79d314c5
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0014-configure.prf-Allow-to-add-extra-arguments-to-make.patch
@@ -0,0 +1,35 @@
1From 01653e270c4a9169a32c0002a87a6644727d0b11 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 9 May 2013 10:06:50 +0200
4Subject: [PATCH 14/14] configure.prf: Allow to add extra arguments to make
5
6* sometimes we would like to add -e or define some variable and respect it from both
7 Makefiles used in configure tests and also Maakefiles to build the application
8
9Change-Id: Ib29beb89cc9b179dddd40d3b212b7c200d29a469
10---
11 mkspecs/features/configure.prf | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
15index 39144e7..1864ba8 100644
16--- a/mkspecs/features/configure.prf
17+++ b/mkspecs/features/configure.prf
18@@ -54,12 +54,12 @@ defineTest(qtCompileTest) {
19 qmake_configs = "\"CONFIG -= qt debug_and_release app_bundle lib_bundle\""
20
21 # Clean up after previous run
22- exists($$test_out_dir/Makefile):qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE distclean")
23+ exists($$test_out_dir/Makefile):qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE $$(QMAKE_MAKE_ARGS) distclean")
24
25 mkpath($$test_out_dir)|error("Aborting.")
26
27 qtRunLoggedCommand("$$test_cmd_base $$system_quote($$system_path($$QMAKE_QMAKE)) $$qmake_configs $$shell_quote($$test_dir)") {
28- qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE") {
29+ qtRunLoggedCommand("$$test_cmd_base $$QMAKE_MAKE $$(QMAKE_MAKE_ARGS)") {
30 log("yes$$escape_expand(\\n)")
31 msg = "test $$1 succeeded"
32 write_file($$QMAKE_CONFIG_LOG, msg, append)
33--
341.8.2.1
35