diff options
author | Khem Raj <raj.khem@gmail.com> | 2015-05-17 21:55:13 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-05-21 14:12:35 +0200 |
commit | 5ebbfedbc72452d2de18ce1557a36f3ba8b1175f (patch) | |
tree | bb796a172a1b67b9f83b9ee32a7e7ac850efb8f6 /recipes-qt/qt5 | |
parent | 8525f31981cb387709619129459eb82aec11f4b0 (diff) | |
download | meta-qt5-5ebbfedbc72452d2de18ce1557a36f3ba8b1175f.tar.gz |
qtwebkit: Backport fix to build with gcc5
This is already committed upstream to 5.4 branch
may be next minor upgrade will get it but until then
we need it
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r-- | recipes-qt/qt5/qtwebkit/0004-gcc5-qtbug-44829.patch | 36 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit_5.4.1.bb | 1 |
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0004-gcc5-qtbug-44829.patch b/recipes-qt/qt5/qtwebkit/0004-gcc5-qtbug-44829.patch new file mode 100644 index 00000000..81295d1c --- /dev/null +++ b/recipes-qt/qt5/qtwebkit/0004-gcc5-qtbug-44829.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 650c6ee8e76bb574d3a1bea09e2494992d8f070e Mon Sep 17 00:00:00 2001 | ||
2 | From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com> | ||
3 | Date: Fri, 6 Mar 2015 11:20:13 +0100 | ||
4 | Subject: Fix g++ 5.0 build | ||
5 | |||
6 | A non-inline template needs to be explicitly instantiated if used | ||
7 | outside the object where it is declared. | ||
8 | |||
9 | Patch suggested by Khem Raj. | ||
10 | |||
11 | Task-number: QTBUG-44829 | ||
12 | Change-Id: Ib0adbd9273bd1cef01e5863bc8aaa9c373022792 | ||
13 | Reviewed-by: Andras Becsi <andras.becsi@theqtcompany.com> | ||
14 | --- | ||
15 | Source/JavaScriptCore/runtime/JSObject.cpp | 5 +++++ | ||
16 | 1 file changed, 5 insertions(+) | ||
17 | |||
18 | diff --git a/Source/JavaScriptCore/runtime/JSObject.cpp b/Source/JavaScriptCore/runtime/JSObject.cpp | ||
19 | index 5637e20..bd55919 100644 | ||
20 | --- a/Source/JavaScriptCore/runtime/JSObject.cpp | ||
21 | +++ b/Source/JavaScriptCore/runtime/JSObject.cpp | ||
22 | @@ -1909,6 +1909,11 @@ void JSObject::putByIndexBeyondVectorLengthWithoutAttributes(ExecState* exec, un | ||
23 | } | ||
24 | } | ||
25 | |||
26 | +// Used in JSArray.cpp so we must instantiate explicit | ||
27 | +template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<Int32Shape>(ExecState* exec, unsigned i, JSValue value); | ||
28 | +template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<DoubleShape>(ExecState* exec, unsigned i, JSValue value); | ||
29 | +template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<ContiguousShape>(ExecState* exec, unsigned i, JSValue value); | ||
30 | + | ||
31 | void JSObject::putByIndexBeyondVectorLengthWithArrayStorage(ExecState* exec, unsigned i, JSValue value, bool shouldThrow, ArrayStorage* storage) | ||
32 | { | ||
33 | VM& vm = exec->vm(); | ||
34 | -- | ||
35 | cgit v0.11.0 | ||
36 | |||
diff --git a/recipes-qt/qt5/qtwebkit_5.4.1.bb b/recipes-qt/qt5/qtwebkit_5.4.1.bb index 909696b2..454e4708 100644 --- a/recipes-qt/qt5/qtwebkit_5.4.1.bb +++ b/recipes-qt/qt5/qtwebkit_5.4.1.bb | |||
@@ -3,6 +3,7 @@ require ${PN}.inc | |||
3 | 3 | ||
4 | SRC_URI += "\ | 4 | SRC_URI += "\ |
5 | file://0003-Fix-building-with-glib-2.43.patch \ | 5 | file://0003-Fix-building-with-glib-2.43.patch \ |
6 | file://0004-gcc5-qtbug-44829.patch \ | ||
6 | " | 7 | " |
7 | 8 | ||
8 | SRC_URI[md5sum] = "186627b1ea5b614811fbd0cfa9b4d073" | 9 | SRC_URI[md5sum] = "186627b1ea5b614811fbd0cfa9b4d073" |