summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-10-08 12:10:10 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-08 15:50:10 +0200
commit040dd25bedf46da3399f40c17ea2473a30fa2963 (patch)
treebd9c2184f1daa711acd7d30b2ce6b742dfb7b4d9 /recipes-qt/qt5
parent2ecccc2ca2eb017b32db3697f2750b9e7aec78e8 (diff)
downloadmeta-qt5-040dd25bedf46da3399f40c17ea2473a30fa2963.tar.gz
qtjsondb: Remove unsupported module
* https://bugreports.qt-project.org/browse/QTBUG-31741 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtbase-native_5.1.1.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtjsondb.inc10
-rw-r--r--recipes-qt/qt5/qtjsondb_git.bb22
4 files changed, 2 insertions, 34 deletions
diff --git a/recipes-qt/qt5/qtbase-native_5.1.1.bb b/recipes-qt/qt5/qtbase-native_5.1.1.bb
index 2ee644c0..612553c6 100644
--- a/recipes-qt/qt5/qtbase-native_5.1.1.bb
+++ b/recipes-qt/qt5/qtbase-native_5.1.1.bb
@@ -3,7 +3,7 @@ require ${PN}.inc
3 3
4do_install_append() { 4do_install_append() {
5 # for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt) 5 # for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt)
6 # e.g. qt3d, qtjsondb, qtwayland 6 # e.g. qt3d, qtwayland
7 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt 7 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
8} 8}
9 9
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 0db74da8..96e7c298 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -3,7 +3,7 @@ require ${PN}.inc
3 3
4do_install_append() { 4do_install_append() {
5 # for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt) 5 # for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt)
6 # e.g. qt3d, qtjsondb, qtwayland 6 # e.g. qt3d, qtwayland
7 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt 7 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
8} 8}
9 9
diff --git a/recipes-qt/qt5/qtjsondb.inc b/recipes-qt/qt5/qtjsondb.inc
deleted file mode 100644
index 33816de3..00000000
--- a/recipes-qt/qt5/qtjsondb.inc
+++ /dev/null
@@ -1,10 +0,0 @@
1require qt5.inc
2
3DEPENDS += "qtdeclarative ${ICU}"
4
5LICENSE = "BSD & LGPL-2.1 & GFDL-1.3"
6# this is for latest SRCREV:
7LIC_FILES_CHKSUM = "file://${S}/doc/src/qtjsondb.qdoc;endline=26;md5=757f4eda130ceff3ca0985dde715af07 \
8 file://${S}/examples/jsondb-client/example.qml;endline=39;md5=5213e8171c07d54db7107f29ac2f7b5e \
9 file://${S}/src/client/qjsondbglobal.h;endline=40;md5=34f5660524f0d70941d0416511ef49a0 \
10"
diff --git a/recipes-qt/qt5/qtjsondb_git.bb b/recipes-qt/qt5/qtjsondb_git.bb
deleted file mode 100644
index 012bf9a3..00000000
--- a/recipes-qt/qt5/qtjsondb_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1require qt5-git.inc
2require ${PN}.inc
3
4# qtjsondb wasn't released yet, last tag before this SRCREV isn't even 5.0.0-beta1, but lets use it for now
5PV = "4.999+5.0.0-beta1+git${SRCPV}"
6
7QT_MODULE_BRANCH = "master"
8
9SRCREV = "27a2b5d9a0f081f71c26a1716721411606f8dedf"
10
11do_configure_prepend() {
12 # Temporary hack to get qtjsondb build for Qt 5.1.0
13 if ! grep -q MODULE_VERSION ${S}/.qmake.conf; then
14 echo "MODULE_VERSION = 5.1.0" >> ${S}/.qmake.conf
15 fi
16}
17
18do_configure_append() {
19 # work around for this issue:
20 # http://www.mail-archive.com/ci-reports@qt-project.org/msg09692.html
21 sed -i '/^INCPATH/s#-I\.$#-I. -I../../include/QtJsonDbPartition#g' ${B}/src/client/Makefile
22}