diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-12-01 16:46:14 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-12-09 12:22:36 +0000 |
commit | c4a0a450b4275cc3869cf389c92e86b62f09fcea (patch) | |
tree | 6705cbb48ae3d433639bad3e78e239d210e13dee /recipes-qt/qt5/qtwebengine_git.bb | |
parent | 4e113c7b8e0a7512d2f0ad306decc8b4885ef807 (diff) | |
download | meta-qt5-c4a0a450b4275cc3869cf389c92e86b62f09fcea.tar.gz |
qt5: update submodules
New configuration system is now used for more modules, so add new
EXTRA_QMAKEVARS_CONFIGURE variable that can be used for configure
modules with -[no-]feature flags.
SHA1s are now from the release 5.8.0 branches, so need to add "nobranch=1"
option so that there is no build break when release branches are removed.
Add recipe for QtGamepad module, it's already used by Qt3D.
Change-Id: I152b3b66b68c802d07445f4a7f1e81802308418e
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 20 |
1 files changed, 5 insertions, 15 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 4152ef0a..7dc37a92 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -20,14 +20,9 @@ DEPENDS += " \ | |||
20 | libdrm fontconfig pixman openssl pango cairo icu pciutils \ | 20 | libdrm fontconfig pixman openssl pango cairo icu pciutils \ |
21 | libcap \ | 21 | libcap \ |
22 | gperf-native \ | 22 | gperf-native \ |
23 | ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa-lib', '', d)} \ | ||
23 | " | 24 | " |
24 | 25 | ||
25 | # when qtbase is built with xcb enabled (default with x11 in DISTRO_FEATURES), | ||
26 | # qtwebengine will have additional dependencies: | ||
27 | # contains(QT_CONFIG, xcb): REQUIRED_PACKAGES += libdrm xcomposite xcursor xi xrandr xscrnsaver xtst | ||
28 | # xscreensaver isn't covered in qtbase DEPENDS | ||
29 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxscrnsaver', '', d)}" | ||
30 | |||
31 | DEPENDS += "yasm-native" | 26 | DEPENDS += "yasm-native" |
32 | EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm" | 27 | EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm" |
33 | 28 | ||
@@ -52,6 +47,7 @@ COMPATIBLE_MACHINE_x86-64 = "(.*)" | |||
52 | COMPATIBLE_MACHINE_armv6 = "(.*)" | 47 | COMPATIBLE_MACHINE_armv6 = "(.*)" |
53 | COMPATIBLE_MACHINE_armv7a = "(.*)" | 48 | COMPATIBLE_MACHINE_armv7a = "(.*)" |
54 | COMPATIBLE_MACHINE_armv7ve = "(.*)" | 49 | COMPATIBLE_MACHINE_armv7ve = "(.*)" |
50 | COMPATIBLE_MACHINE_aarch64 = "(.*)" | ||
55 | 51 | ||
56 | inherit qmake5 | 52 | inherit qmake5 |
57 | inherit gettext | 53 | inherit gettext |
@@ -65,10 +61,6 @@ def gettext_oeconf(d): | |||
65 | require qt5.inc | 61 | require qt5.inc |
66 | require qt5-git.inc | 62 | require qt5-git.inc |
67 | 63 | ||
68 | # To avoid trouble start with not separated build directory | ||
69 | SEPB = "${S}" | ||
70 | B = "${SEPB}" | ||
71 | |||
72 | export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja" | 64 | export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja" |
73 | 65 | ||
74 | do_configure() { | 66 | do_configure() { |
@@ -86,7 +78,7 @@ do_configure() { | |||
86 | 78 | ||
87 | # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as | 79 | # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as |
88 | # arguments here | 80 | # arguments here |
89 | ${OE_QMAKE_QMAKE} ${OE_QMAKE_QTCONF} -r ${EXTRA_QMAKEVARS_PRE} QTWEBENGINE_ROOT="${S}" \ | 81 | ${OE_QMAKE_QMAKE} ${OE_QMAKE_QTCONF} -r ${EXTRA_QMAKEVARS_PRE} ${S} \ |
90 | QMAKE_CXX="${OE_QMAKE_CXX}" QMAKE_CC="${OE_QMAKE_CC}" \ | 82 | QMAKE_CXX="${OE_QMAKE_CXX}" QMAKE_CC="${OE_QMAKE_CC}" \ |
91 | QMAKE_LINK="${OE_QMAKE_LINK}" \ | 83 | QMAKE_LINK="${OE_QMAKE_LINK}" \ |
92 | QMAKE_CFLAGS="${OE_QMAKE_CFLAGS}" \ | 84 | QMAKE_CFLAGS="${OE_QMAKE_CFLAGS}" \ |
@@ -123,13 +115,11 @@ SRC_URI += " \ | |||
123 | file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ | 115 | file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ |
124 | " | 116 | " |
125 | 117 | ||
126 | SRCREV_qtwebengine = "ac3d8780a0293793dbc3cd47b96aab4613dec5d9" | 118 | SRCREV_qtwebengine = "a79fd91391c489ea1cd7baf717778b75e4847b92" |
127 | SRCREV_chromium = "f3ce802c71aeaeb7dd218180a3bc5c6ac63b445d" | 119 | SRCREV_chromium = "93b3786290ac16c95f15c95e2c2f3d8254171ab6" |
128 | SRCREV = "${SRCREV_qtwebengine}" | 120 | SRCREV = "${SRCREV_qtwebengine}" |
129 | 121 | ||
130 | SRCREV_FORMAT = "qtwebengine_chromium" | 122 | SRCREV_FORMAT = "qtwebengine_chromium" |
131 | 123 | ||
132 | S = "${WORKDIR}/git" | ||
133 | |||
134 | # WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel] | 124 | # WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel] |
135 | INSANE_SKIP_${PN} += "textrel" | 125 | INSANE_SKIP_${PN} += "textrel" |