summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-05-09 14:14:09 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-05-10 10:26:57 +0000
commitc0cc57124d953f209fc5f8a28291e40612e45d7e (patch)
treeb98831e1b78117a8254e6722acf56a48995ac15d /recipes-qt/qt5/qtwebengine_git.bb
parentbc1327c8aab6ec63d104971dbbaa38ce9714412f (diff)
downloadmeta-qt5-c0cc57124d953f209fc5f8a28291e40612e45d7e.tar.gz
qtwebengine: use system NSS instead of BoringSSL
Using system NSS for the certificate handling. Task-number: QTBUG-60603 Change-Id: I0ad0a9ffa6c84c708e1d340f49cf03af742085b7 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 64ff9182..6b395a72 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -29,7 +29,7 @@ EXTRA_QMAKEVARS_CONFIGURE += "-feature-system-ninja -no-feature-system-gn"
29 29
30# To use system ffmpeg you need to enable also libwebp, opus, vpx 30# To use system ffmpeg you need to enable also libwebp, opus, vpx
31# Only depenedencies available in oe-core are enabled by default 31# Only depenedencies available in oe-core are enabled by default
32PACKAGECONFIG ??= "libwebp flac libevent libxslt speex" 32PACKAGECONFIG ??= "libwebp flac libevent libxslt speex nss"
33PACKAGECONFIG[opus] = "WEBENGINE_CONFIG+=use_system_opus,,libopus" 33PACKAGECONFIG[opus] = "WEBENGINE_CONFIG+=use_system_opus,,libopus"
34PACKAGECONFIG[icu] = "WEBENGINE_CONFIG+=use_system_icu,,icu" 34PACKAGECONFIG[icu] = "WEBENGINE_CONFIG+=use_system_icu,,icu"
35PACKAGECONFIG[ffmpeg] = "WEBENGINE_CONFIG+=use_system_ffmpeg,,libav" 35PACKAGECONFIG[ffmpeg] = "WEBENGINE_CONFIG+=use_system_ffmpeg,,libav"
@@ -39,6 +39,7 @@ PACKAGECONFIG[libevent] = "WEBENGINE_CONFIG+=use_system_libevent,,libevent"
39PACKAGECONFIG[libxslt] = "WEBENGINE_CONFIG+=use_system_libxslt,,libxslt" 39PACKAGECONFIG[libxslt] = "WEBENGINE_CONFIG+=use_system_libxslt,,libxslt"
40PACKAGECONFIG[speex] = "WEBENGINE_CONFIG+=use_system_speex,,speex" 40PACKAGECONFIG[speex] = "WEBENGINE_CONFIG+=use_system_speex,,speex"
41PACKAGECONFIG[vpx] = "WEBENGINE_CONFIG+=use_system_vpx,,libvpx" 41PACKAGECONFIG[vpx] = "WEBENGINE_CONFIG+=use_system_vpx,,libvpx"
42PACKAGECONFIG[nss] = "WEBENGINE_CONFIG+=use_nss,,nss"
42 43
43EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" 44EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
44 45