diff options
author | Mikko Levonmaa <mikko.levonmaa@palm.com> | 2013-03-06 12:31:29 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-06 12:21:28 +0200 |
commit | fc0b7ec73ce6aa470b6666ad115f3d0e8b83a340 (patch) | |
tree | d8eca663f908d6a2c0f6e726589703136a4c282a /recipes-qt/qt5/qtwayland.inc | |
parent | db7467e72a8330b0b73546ff3f68e424aeea4b1c (diff) | |
download | meta-qt5-fc0b7ec73ce6aa470b6666ad115f3d0e8b83a340.tar.gz |
qtwayland: Add recipe
* Fix shader precision definition
* MJ: Fix license information
* MJ: Fix PV
* MJ: add wayland-native to depends for wayland-scaner
* MJ: add libxkbcommon to depends, but make it easy to remove it
Signed-off-by: Mikko Levonmaa <mikko.levonmaa@palm.com>
Signed-off-by: Martin Jansa <martin.jansa@lge.com>
Diffstat (limited to 'recipes-qt/qt5/qtwayland.inc')
-rw-r--r-- | recipes-qt/qt5/qtwayland.inc | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland.inc b/recipes-qt/qt5/qtwayland.inc new file mode 100644 index 00000000..32fb08e9 --- /dev/null +++ b/recipes-qt/qt5/qtwayland.inc | |||
@@ -0,0 +1,29 @@ | |||
1 | require qt5module.inc | ||
2 | |||
3 | LICENSE = "BSD & LGPL-2.1 | GPL-3.0" | ||
4 | LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenode.cpp;endline=40;md5=e38eccd7e9a6a149c9e31b6fb47daac1 \ | ||
5 | file://${S}/src/compositor/compositor_api/qwaylandcompositor.cpp;endline=39;md5=8897abe415f27031e4237f09db7b9a36 \ | ||
6 | " | ||
7 | |||
8 | # wayland-native is already in wayland DEPENDS, but add it here | ||
9 | # explicitly, because it's native wayland-scanner we're looking for | ||
10 | # libxkbcommon isn't mandatory with 0001-xcbcommon-should-not-be-a-mandatory-dependency.patch | ||
11 | # make it easier to remove by .bbappend (e.g. for building qtwayland with danny which doesn't | ||
12 | # have libxkbcommon in oe-core). | ||
13 | XKB_DEPENDS = "libxkbcommon" | ||
14 | DEPENDS += "qtdeclarative wayland wayland-native ${XKB_DEPENDS}" | ||
15 | |||
16 | INC_PR = "r1" | ||
17 | |||
18 | SRC_URI += " \ | ||
19 | file://0001-xcbcommon-should-not-be-a-mandatory-dependency.patch \ | ||
20 | file://0002-Temporarily-patching-this-out-as-Qt5.0.0-does-not-ha.patch \ | ||
21 | file://0003-eglCreateImageKHR-requires-the-context-to-be-NULL.patch \ | ||
22 | file://0004-EGL-Specify-vec2d-precision-qualifier-in-fragment-sh.patch \ | ||
23 | " | ||
24 | |||
25 | QT_WAYLAND_CONFIG ?= "wayland-compositor" | ||
26 | QT_WAYLAND_DEFINES ?= "" | ||
27 | |||
28 | EXTRA_QMAKEVARS_PRE += "CONFIG+=${QT_WAYLAND_CONFIG}" | ||
29 | EXTRA_QMAKEVARS_PRE += "DEFINES+=${QT_WAYLAND_DEFINES}" | ||