summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-10-23 15:50:41 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2012-10-23 15:50:41 -0200
commitec0ac6e5b1682b7a448eb50666cb8330928c9d74 (patch)
tree66845bd9e63af6660c81be3013e1e95e38932a08 /conf
downloadmeta-qt5-ec0ac6e5b1682b7a448eb50666cb8330928c9d74.tar.gz
Add layer basic structure
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf24
1 files changed, 24 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 00000000..7730dc27
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,24 @@
1# It really depends on order of the layers appearing in BBLAYERS
2# variable in toplevel bblayers.conf file, where bitbake will search
3# for .inc files and others where bitbake uses BBPATH since it will
4# search the directories from first to last as specified in BBPATH
5# Therefore if you want a given layer to be considered high priority
6# for the .inc and .conf etc. then consider it adding at the beginning
7# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
8# the recipe contention so the order of directories in BBFILES does
9# not matter.
10
11# We have a conf and classes directory, append to BBPATH
12BBPATH .= ":${LAYERDIR}"
13
14# We have a recipes directory, add to BBFILES
15BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/*/recipes-*/*/*.bbappend"
16
17BBFILE_COLLECTIONS += "qt5-layer"
18BBFILE_PATTERN_qt5-layer := "^${LAYERDIR}/"
19
20# Define the priority for recipes (.bb files) from this layer,
21# choosing carefully how this layer interacts with all of the
22# other layers.
23
24BBFILE_PRIORITY_systemd-layer = "7"