summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-10-08 16:11:02 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-01 19:07:47 +0100
commitdf324ebd497db3ab935a79ddc5a378b14a6ea91f (patch)
tree75cef82f0005246558133fd8d776521290cb75cc
parent6255c3bc0ccf1b4329d9a460fa853be0d7827224 (diff)
downloadmeta-qt5-df324ebd497db3ab935a79ddc5a378b14a6ea91f.tar.gz
qt5: Use existing variables for paths of host tools
Makes it possible to install qmake into ${bindir} without setting QT_DIR_NAME = "". Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--classes/qmake5_base.bbclass2
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-creator_3.5.1.bb6
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb4
5 files changed, 9 insertions, 9 deletions
diff --git a/classes/qmake5_base.bbclass b/classes/qmake5_base.bbclass
index a4b7d1bf..70faccaa 100644
--- a/classes/qmake5_base.bbclass
+++ b/classes/qmake5_base.bbclass
@@ -32,7 +32,7 @@ EXTRA_OEMAKE = " \
32 32
33OE_QMAKESPEC = "${QMAKE_MKSPEC_PATH_NATIVE}/mkspecs/${OE_QMAKE_PLATFORM_NATIVE}" 33OE_QMAKESPEC = "${QMAKE_MKSPEC_PATH_NATIVE}/mkspecs/${OE_QMAKE_PLATFORM_NATIVE}"
34OE_XQMAKESPEC = "${QMAKE_MKSPEC_PATH}/mkspecs/${OE_QMAKE_PLATFORM}" 34OE_XQMAKESPEC = "${QMAKE_MKSPEC_PATH}/mkspecs/${OE_QMAKE_PLATFORM}"
35OE_QMAKE_QMAKE = "${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/qmake" 35OE_QMAKE_QMAKE = "${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qmake"
36OE_QMAKE_COMPILER = "${CC}" 36OE_QMAKE_COMPILER = "${CC}"
37OE_QMAKE_CC = "${CC}" 37OE_QMAKE_CC = "${CC}"
38OE_QMAKE_CFLAGS = "${CFLAGS}" 38OE_QMAKE_CFLAGS = "${CFLAGS}"
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 74526484..dce78fce 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -146,7 +146,7 @@ export OE_QMAKE_AR
146export OE_QMAKE_STRIP 146export OE_QMAKE_STRIP
147 147
148# another exception is that we need to run bin/qmake, because EffectivePaths are relative to qmake location 148# another exception is that we need to run bin/qmake, because EffectivePaths are relative to qmake location
149OE_QMAKE_QMAKE_ORIG = "${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/qmake" 149OE_QMAKE_QMAKE_ORIG := "${OE_QMAKE_QMAKE}"
150OE_QMAKE_QMAKE = "bin/qmake" 150OE_QMAKE_QMAKE = "bin/qmake"
151 151
152do_configure() { 152do_configure() {
diff --git a/recipes-qt/qt5/qt5-creator_3.5.1.bb b/recipes-qt/qt5/qt5-creator_3.5.1.bb
index 2d8cee9d..f4ba8580 100644
--- a/recipes-qt/qt5/qt5-creator_3.5.1.bb
+++ b/recipes-qt/qt5/qt5-creator_3.5.1.bb
@@ -32,8 +32,8 @@ EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}"
32 32
33do_configure_append() { 33do_configure_append() {
34 # Find native tools 34 # Find native tools
35 sed -i 's:${STAGING_BINDIR}.*/lrelease:${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/lrelease:g' ${B}/share/qtcreator/translations/Makefile 35 sed -i 's:${STAGING_BINDIR}.*/lrelease:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/lrelease:g' ${B}/share/qtcreator/translations/Makefile
36 sed -i 's:${STAGING_BINDIR}.*/qdoc:${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/qdoc:g' ${B}/Makefile 36 sed -i 's:${STAGING_BINDIR}.*/qdoc:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qdoc:g' ${B}/Makefile
37 37
38 # see qtbase-native.inc 38 # see qtbase-native.inc
39 # sed -i 's:QT_INSTALL_DOCS=${docdir}:QT_INSTALL_DOCS=${STAGING_DATADIR_NATIVE}${QT_DIR_NAME}/doc:g' ${B}/Makefile 39 # sed -i 's:QT_INSTALL_DOCS=${docdir}:QT_INSTALL_DOCS=${STAGING_DATADIR_NATIVE}${QT_DIR_NAME}/doc:g' ${B}/Makefile
@@ -50,7 +50,7 @@ do_install() {
50 # install desktop and ensure that qt-creator finds qmake 50 # install desktop and ensure that qt-creator finds qmake
51 install -d ${D}${datadir}/applications 51 install -d ${D}${datadir}/applications
52 install -m 0644 ${WORKDIR}/qtcreator.desktop.in ${D}${datadir}/applications/qtcreator.desktop 52 install -m 0644 ${WORKDIR}/qtcreator.desktop.in ${D}${datadir}/applications/qtcreator.desktop
53 sed -i 's:@QT5_QMAKE@:${bindir}${QT_DIR_NAME}:g' ${D}${datadir}/applications/qtcreator.desktop 53 sed -i 's:@QT5_QMAKE@:${OE_QMAKE_PATH_QT_BINS}:g' ${D}${datadir}/applications/qtcreator.desktop
54} 54}
55 55
56FILES_${PN} += " \ 56FILES_${PN} += " \
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index eda57aca..223383dd 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -156,7 +156,7 @@ EOF
156QMAKE_MKSPEC_PATH = "${B}" 156QMAKE_MKSPEC_PATH = "${B}"
157 157
158# another exception is that we need to run bin/qmake, because EffectivePaths are relative to qmake location 158# another exception is that we need to run bin/qmake, because EffectivePaths are relative to qmake location
159OE_QMAKE_QMAKE_ORIG = "${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/qmake" 159OE_QMAKE_QMAKE_ORIG := "${OE_QMAKE_QMAKE}"
160OE_QMAKE_QMAKE = "bin/qmake" 160OE_QMAKE_QMAKE = "bin/qmake"
161 161
162# qtbase is exception, configure script is using our get(X)QEvalMakeConf and setBootstrapEvalVariable functions to read it from shell 162# qtbase is exception, configure script is using our get(X)QEvalMakeConf and setBootstrapEvalVariable functions to read it from shell
@@ -211,7 +211,7 @@ do_install_append() {
211 # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory" 211 # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"
212 touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri 212 touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri
213 213
214 install -m 0755 ${B}/bin/qmake-target ${D}/${bindir}${QT_DIR_NAME}/qmake 214 install -m 0755 ${B}/bin/qmake-target ${D}${OE_QMAKE_PATH_QT_BINS}/qmake
215 215
216 # Remove example.pro file as it is useless 216 # Remove example.pro file as it is useless
217 rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro 217 rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 5cc4caa1..2633be7e 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -22,7 +22,7 @@ SRC_URI += " \
22 file://0003-Workaround-crashes-in-QtQml-code-related-to-dead-sto.patch \ 22 file://0003-Workaround-crashes-in-QtQml-code-related-to-dead-sto.patch \
23" 23"
24 24
25EXTRA_OEMAKE += "QMAKE_SYNCQT=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/syncqt" 25EXTRA_OEMAKE += "QMAKE_SYNCQT=${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/syncqt"
26 26
27PACKAGECONFIG ??= "qtxmlpatterns" 27PACKAGECONFIG ??= "qtxmlpatterns"
28PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns" 28PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns"
@@ -33,7 +33,7 @@ do_configure_prepend() {
33 sed -e 's/^\(!qtHaveModule(xmlpatterns)\)/!OE_QTXMLPATTERNS_ENABLED|\1/' -i ${S}/tests/auto/quick/quick.pro 33 sed -e 's/^\(!qtHaveModule(xmlpatterns)\)/!OE_QTXMLPATTERNS_ENABLED|\1/' -i ${S}/tests/auto/quick/quick.pro
34 34
35 #set the path for syncqt properly 35 #set the path for syncqt properly
36 echo "QT_TOOL.syncqt.binary = \"${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/syncqt\"" > ${B}/.qmake.cache 36 echo "QT_TOOL.syncqt.binary = \"${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/syncqt\"" > ${B}/.qmake.cache
37} 37}
38 38
39EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" 39EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"