summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-18 10:34:36 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-20 00:55:36 +0000
commitc483f15ee654f2b9d6eab0e34461299acadbdc49 (patch)
treed7b1de80124a3c17c00889eda2c123f9e06a49a4
parentb725e6de4549221b191174bcbfc78fd57c4638e8 (diff)
downloadmeta-qt5-c483f15ee654f2b9d6eab0e34461299acadbdc49.tar.gz
qtbase: Fix build with gcc9
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch34
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 760eb7ca..34f27f1e 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -44,6 +44,7 @@ SRC_URI += "\
44 file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \ 44 file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
45 file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \ 45 file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
46 file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \ 46 file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
47 file://0022-Fix-compile-issue-with-gcc-9.patch \
47" 48"
48 49
49# common for qtbase-native and nativesdk-qtbase 50# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 31c10ff6..04deec67 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -39,6 +39,7 @@ SRC_URI += "\
39 file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \ 39 file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
40 file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \ 40 file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
41 file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \ 41 file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
42 file://0022-Fix-compile-issue-with-gcc-9.patch \
42" 43"
43 44
44# common for qtbase-native and nativesdk-qtbase 45# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch b/recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch
new file mode 100644
index 00000000..6c72061d
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch
@@ -0,0 +1,34 @@
1From 0d89dead4396126606fb7954c0bb0a2734d2347b Mon Sep 17 00:00:00 2001
2From: Allan Sandfeld Jensen <allan.jensen@qt.io>
3Date: Tue, 13 Nov 2018 16:00:23 +0100
4Subject: [PATCH] Fix compile issue with gcc 9
5
6It appears messenne_twisters in the latest libstdc++ has one more
7requirement before it is willing to construct with our
8SystemGenerator struct as an sseq provider.
9
10Upstream-Status: Backport
11
12Change-Id: If38151d1fa6f40a80274acc26d9ed6b4ac6049fe
13Reviewed-by: Giuseppe D'Angelo <giuseppe.dangelo@kdab.com>
14Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
15---
16
17 src/corelib/global/qrandom.cpp | 1 +
18 1 file changed, 1 insertion(+)
19
20diff --git a/src/corelib/global/qrandom.cpp b/src/corelib/global/qrandom.cpp
21index ebf9864b15..577736a867 100644
22--- a/src/corelib/global/qrandom.cpp
23+++ b/src/corelib/global/qrandom.cpp
24@@ -218,6 +218,7 @@ struct QRandomGenerator::SystemGenerator
25 #endif // Q_OS_WINRT
26
27 static SystemGenerator &self();
28+ typedef quint32 result_type;
29 void generate(quint32 *begin, quint32 *end) Q_DECL_NOEXCEPT_EXPR(FillBufferNoexcept);
30
31 // For std::mersenne_twister_engine implementations that use something
32--
332.20.1
34
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index e50c90f5..6d4fd0c2 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -35,6 +35,7 @@ SRC_URI += "\
35 file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \ 35 file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
36 file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \ 36 file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
37 file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \ 37 file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
38 file://0022-Fix-compile-issue-with-gcc-9.patch \
38" 39"
39 40
40 41