diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-03-30 08:43:15 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-03-31 05:28:04 +0000 |
commit | 9b12e74031f12c6ced4d69ee0a0780113501ee18 (patch) | |
tree | 55c506ef9ae52ceb9c7d5df5054a3a958b855e6e | |
parent | 7d49e81ca5fcd639aea6f5e2e24677dbc90f4c17 (diff) | |
download | meta-qt5-9b12e74031f12c6ced4d69ee0a0780113501ee18.tar.gz |
qt5: update submodules
* Update submodules to 5.9.0 Beta RC1
* Removed obsolete temporary build fix patch from qt3d
Change-Id: Iee1e0c64792ee17fce947d9e68a143b09e77c31a
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r-- | recipes-qt/qt5/nativesdk-qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch | 26 | ||||
-rw-r--r-- | recipes-qt/qt5/qt3d_git.bb | 3 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtdatavis3d_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtdeclarative_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtlocation_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtmultimedia_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquick1_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquickcontrols2_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquickcontrols_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtscript_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtscxml_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtserialbus_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtserialport_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qttools_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtvirtualkeyboard_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwayland_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 4 |
20 files changed, 20 insertions, 47 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb index 0788794b..ee6c1730 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bb +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb | |||
@@ -191,4 +191,4 @@ fakeroot do_generate_qt_environment_file() { | |||
191 | 191 | ||
192 | addtask generate_qt_environment_file after do_install before do_package | 192 | addtask generate_qt_environment_file after do_install before do_package |
193 | 193 | ||
194 | SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a" | 194 | SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b" |
diff --git a/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch b/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch deleted file mode 100644 index 0d8d0837..00000000 --- a/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 6a1c600bcb6288c021eafdef516b8313c60505a3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mikko Gronoff <mikko.gronoff@qt.io> | ||
3 | Date: Fri, 17 Mar 2017 14:42:12 +0200 | ||
4 | Subject: [PATCH] qt3d: include qcoreapplication.h header in | ||
5 | qtquickscene2dplugin.cpp | ||
6 | |||
7 | Fix build break in qt3d: | ||
8 | Add #include <QtCore/qcoreapplication.h> to qtquickscene2dplugin.cpp | ||
9 | to prevent build break due unknown Q_COREAPP_STARTUP_FUNCTION macro. | ||
10 | --- | ||
11 | src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp | 2 ++ | ||
12 | 1 file changed, 2 insertions(+) | ||
13 | |||
14 | diff --git a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp | ||
15 | index c67271a..224b24f 100644 | ||
16 | --- a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp | ||
17 | +++ b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp | ||
18 | @@ -40,6 +40,8 @@ | ||
19 | #include <private/qrenderaspect_p.h> | ||
20 | #include <Qt3DQuickScene2D/private/qt3dquick3dscene2d_p.h> | ||
21 | |||
22 | +#include <QtCore/qcoreapplication.h> | ||
23 | + | ||
24 | QT_BEGIN_NAMESPACE | ||
25 | |||
26 | static void initScene2dPlugin() | ||
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb index 10ffd9c9..ee757437 100644 --- a/recipes-qt/qt5/qt3d_git.bb +++ b/recipes-qt/qt5/qt3d_git.bb | |||
@@ -13,7 +13,6 @@ DEPENDS_class-target += "qtdeclarative qt3d-native" | |||
13 | 13 | ||
14 | SRC_URI += " \ | 14 | SRC_URI += " \ |
15 | file://0001-Allow-a-tools-only-build.patch \ | 15 | file://0001-Allow-a-tools-only-build.patch \ |
16 | file://0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch \ | ||
17 | " | 16 | " |
18 | 17 | ||
19 | PACKAGECONFIG ??= "" | 18 | PACKAGECONFIG ??= "" |
@@ -35,6 +34,6 @@ do_configure_prepend() { | |||
35 | ${S}/src/quick3d/imports/input/importsinput.pro | 34 | ${S}/src/quick3d/imports/input/importsinput.pro |
36 | } | 35 | } |
37 | 36 | ||
38 | SRCREV = "fd39bbaca2fe8e29bb9b603340ed94c7480b6da5" | 37 | SRCREV = "873e8ac06c606e71aafb9be9baa21143e6757df5" |
39 | 38 | ||
40 | BBCLASSEXTEND += "native nativesdk" | 39 | BBCLASSEXTEND += "native nativesdk" |
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb index 32c59498..88ff4231 100644 --- a/recipes-qt/qt5/qtbase-native_git.bb +++ b/recipes-qt/qt5/qtbase-native_git.bb | |||
@@ -106,4 +106,4 @@ do_install() { | |||
106 | install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS} | 106 | install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS} |
107 | } | 107 | } |
108 | 108 | ||
109 | SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a" | 109 | SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b" |
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index a6375a6c..36a9f3cb 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -182,4 +182,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps" | |||
182 | 182 | ||
183 | RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" | 183 | RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" |
184 | 184 | ||
185 | SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a" | 185 | SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b" |
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb index 29c0a985..f0d80524 100644 --- a/recipes-qt/qt5/qtdatavis3d_git.bb +++ b/recipes-qt/qt5/qtdatavis3d_git.bb | |||
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \ | |||
8 | 8 | ||
9 | DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns" | 9 | DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns" |
10 | 10 | ||
11 | SRCREV = "fb9e66188e0582a6b80ad3b8b3ac80024180a9df" | 11 | SRCREV = "1a4d36afc821d745fe304f222e73d6c2fa249afa" |
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb index 6ef0f60e..6fd2866c 100644 --- a/recipes-qt/qt5/qtdeclarative_git.bb +++ b/recipes-qt/qt5/qtdeclarative_git.bb | |||
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() { | |||
32 | 32 | ||
33 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" | 33 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" |
34 | 34 | ||
35 | SRCREV = "7a125135e1ef592aa20a29f7aac1a6117a6b1770" | 35 | SRCREV = "73f365f9f2d04131ae27a5dba26255feda18baa2" |
36 | 36 | ||
37 | BBCLASSEXTEND =+ "native nativesdk" | 37 | BBCLASSEXTEND =+ "native nativesdk" |
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb index 93a9a7c2..24e14225 100644 --- a/recipes-qt/qt5/qtlocation_git.bb +++ b/recipes-qt/qt5/qtlocation_git.bb | |||
@@ -24,7 +24,7 @@ SRC_URI += " \ | |||
24 | ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \ | 24 | ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \ |
25 | " | 25 | " |
26 | 26 | ||
27 | SRCREV_qtlocation = "51052caaa27c639c10f7618a853d0b374720c6ea" | 27 | SRCREV_qtlocation = "a7cadd6f5f5278220847dcb2c4897a3c40896ea3" |
28 | SRCREV_qtlocation-mapboxgl = "60320d74ba577185d1d90a7f234e182ca06d7d76" | 28 | SRCREV_qtlocation-mapboxgl = "60320d74ba577185d1d90a7f234e182ca06d7d76" |
29 | 29 | ||
30 | SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl" | 30 | SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl" |
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb index 6f156f22..e07faea4 100644 --- a/recipes-qt/qt5/qtmultimedia_git.bb +++ b/recipes-qt/qt5/qtmultimedia_git.bb | |||
@@ -33,4 +33,4 @@ SRC_URI += "\ | |||
33 | file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \ | 33 | file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \ |
34 | " | 34 | " |
35 | 35 | ||
36 | SRCREV = "03560060a1702af5190b60fec74f9e71b3c2e104" | 36 | SRCREV = "6c3b0fdb5ceb9079241cb7136d756e9dba114cfe" |
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb index 89ee7818..2f16a36f 100644 --- a/recipes-qt/qt5/qtquick1_git.bb +++ b/recipes-qt/qt5/qtquick1_git.bb | |||
@@ -23,4 +23,4 @@ do_configure_prepend() { | |||
23 | } | 23 | } |
24 | 24 | ||
25 | QT_MODULE_BRANCH = "dev" | 25 | QT_MODULE_BRANCH = "dev" |
26 | SRCREV = "a0783470449a911fce09d6328abfcff17973d421" | 26 | SRCREV = "695460401d9a89d2f156016d51601b2e59b64105" |
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb index 7158bdc3..a67fb368 100644 --- a/recipes-qt/qt5/qtquickcontrols2_git.bb +++ b/recipes-qt/qt5/qtquickcontrols2_git.bb | |||
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \ | |||
10 | 10 | ||
11 | DEPENDS += "qtdeclarative" | 11 | DEPENDS += "qtdeclarative" |
12 | 12 | ||
13 | SRCREV = "9df0f8cb35ee1c134f772f432272e6e020bf9c52" | 13 | SRCREV = "40f454dbfe0e3c73e9d8a77d58938736000a70f4" |
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb index eca7e818..329b4b66 100644 --- a/recipes-qt/qt5/qtquickcontrols_git.bb +++ b/recipes-qt/qt5/qtquickcontrols_git.bb | |||
@@ -21,4 +21,4 @@ SRC_URI += " \ | |||
21 | file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \ | 21 | file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \ |
22 | " | 22 | " |
23 | 23 | ||
24 | SRCREV = "b7ce67c2774197026885e500e9ef495460eb0d33" | 24 | SRCREV = "b84d25b20ed316529ae2fa091c5d9e2fbf45e023" |
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb index 089ee4f8..ae5e0da4 100644 --- a/recipes-qt/qt5/qtscript_git.bb +++ b/recipes-qt/qt5/qtscript_git.bb | |||
@@ -25,4 +25,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm" | |||
25 | 25 | ||
26 | DEPENDS += "qtbase" | 26 | DEPENDS += "qtbase" |
27 | 27 | ||
28 | SRCREV = "5cde7e8668c0d8729674e4fdd96ee6de52e6c2c3" | 28 | SRCREV = "e00ca9b6bec2adf78fd14e02376ecf1b55a93b0c" |
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb index 368a1e9d..8c55526a 100644 --- a/recipes-qt/qt5/qtscxml_git.bb +++ b/recipes-qt/qt5/qtscxml_git.bb | |||
@@ -10,7 +10,7 @@ require qt5-git.inc | |||
10 | 10 | ||
11 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native" | 11 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native" |
12 | 12 | ||
13 | SRCREV = "34e9418cd669a706dd407f0032c5de564212369e" | 13 | SRCREV = "06ee5829c54e1aafeb03d387a8f5d6377a7ed115" |
14 | 14 | ||
15 | SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch" | 15 | SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch" |
16 | 16 | ||
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb index c9ced273..20468e18 100644 --- a/recipes-qt/qt5/qtserialbus_git.bb +++ b/recipes-qt/qt5/qtserialbus_git.bb | |||
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \ | |||
11 | 11 | ||
12 | DEPENDS += "qtbase qtserialport" | 12 | DEPENDS += "qtbase qtserialport" |
13 | 13 | ||
14 | SRCREV = "71a31bf19bb0cce506638bc79ba96bc5e5da92fe" | 14 | SRCREV = "dc124162efeabe90b9025789391d1f0e15cef0f1" |
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb index 4b79b0bc..76e6dd6f 100644 --- a/recipes-qt/qt5/qtserialport_git.bb +++ b/recipes-qt/qt5/qtserialport_git.bb | |||
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \ | |||
15 | 15 | ||
16 | DEPENDS += "qtbase" | 16 | DEPENDS += "qtbase" |
17 | 17 | ||
18 | SRCREV = "5c6a433d6a6a4176082036ae94931467101a199a" | 18 | SRCREV = "d320f01018f0273e4fea2e0a7aa8f30ee8129587" |
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb index 0667ac00..81c14d79 100644 --- a/recipes-qt/qt5/qttools_git.bb +++ b/recipes-qt/qt5/qttools_git.bb | |||
@@ -29,6 +29,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit" | |||
29 | 29 | ||
30 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}" | 30 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}" |
31 | 31 | ||
32 | SRCREV = "c5e54d58e8763898db81e1f3b5b5460d6e4b9455" | 32 | SRCREV = "224a4bdc0380b15e6a8f07dc0d4bf9ae4dae1996" |
33 | 33 | ||
34 | BBCLASSEXTEND = "native nativesdk" | 34 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb index 741ff86a..0a42d7a6 100644 --- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb +++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb | |||
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit" | |||
49 | 49 | ||
50 | DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns" | 50 | DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns" |
51 | 51 | ||
52 | SRCREV = "956a6a04a7a98be7c05320b504674260b4322851" | 52 | SRCREV = "1efffb8fea600c77925422cdf85f6c024ab3d8b2" |
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb index 80278935..5c10bb41 100644 --- a/recipes-qt/qt5/qtwayland_git.bb +++ b/recipes-qt/qt5/qtwayland_git.bb | |||
@@ -41,7 +41,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature | |||
41 | 41 | ||
42 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" | 42 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" |
43 | 43 | ||
44 | SRCREV = "dfcda81c5b13ad15517a37bcc45f3bf5f550466c" | 44 | SRCREV = "50fea6ae0e9ee863f02d0343baa06ccdf06b7238" |
45 | 45 | ||
46 | # From https://bugreports.qt.io/browse/QTBUG-57767 | 46 | # From https://bugreports.qt.io/browse/QTBUG-57767 |
47 | SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch" | 47 | SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch" |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 60815e7f..f1bdedbd 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -111,8 +111,8 @@ SRC_URI += " \ | |||
111 | file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ | 111 | file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ |
112 | " | 112 | " |
113 | 113 | ||
114 | SRCREV_qtwebengine = "140d12802c9ebc54f5816fbf1a410c5bdc730ec6" | 114 | SRCREV_qtwebengine = "57fee86eb2756a2f102e2bbeb16a443b84a17e01" |
115 | SRCREV_chromium = "8d882ead843178d1ba30f0d80d722e147788e6d1" | 115 | SRCREV_chromium = "bba44efa6bb5707bf6fb4e92627e3326be3f3a3b" |
116 | SRCREV = "${SRCREV_qtwebengine}" | 116 | SRCREV = "${SRCREV_qtwebengine}" |
117 | 117 | ||
118 | SRCREV_FORMAT = "qtwebengine_chromium" | 118 | SRCREV_FORMAT = "qtwebengine_chromium" |