diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-12-11 18:23:52 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-12-17 14:18:37 +0100 |
commit | 8d9a1b8b61630bc14862d4862d1340059d6f9c16 (patch) | |
tree | ffa4c808ecc351881814579d25498afa5fc983c9 | |
parent | d5d2aa57010a6d9488c60464b622051b3e72e705 (diff) | |
download | meta-qt5-8d9a1b8b61630bc14862d4862d1340059d6f9c16.tar.gz |
qtbwebengine: fix build for qemux86-64
* it was applied only for qtwebengine_5.3.2+git.bb, then removed
completely with 5.4.0 upgrade, but it's still needed for both
versions
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0001-chromium-base.gypi-include-atomicops_internals_x86_gcc.cc-whe.patch b/recipes-qt/qt5/qtwebengine/0001-chromium-base.gypi-include-atomicops_internals_x86_gcc.cc-whe.patch new file mode 100644 index 00000000..032fe4de --- /dev/null +++ b/recipes-qt/qt5/qtwebengine/0001-chromium-base.gypi-include-atomicops_internals_x86_gcc.cc-whe.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 41b142ec46c61d075b5cd95a88b57f0db74cbf31 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Fri, 3 Oct 2014 03:52:11 +0200 | ||
4 | Subject: [PATCH] base.gypi: include atomicops_internals_x86_gcc.cc when | ||
5 | building for x64 arch | ||
6 | |||
7 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
8 | --- | ||
9 | chromium/base/base.gypi | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/3rdparty/chromium/base/base.gypi b/src/3rdparty/chromium/base/base.gypi | ||
13 | index a5a990a..af30cfa 100644 | ||
14 | --- a/src/3rdparty/chromium/base/base.gypi | ||
15 | +++ b/src/3rdparty/chromium/base/base.gypi | ||
16 | @@ -745,7 +745,7 @@ | ||
17 | ['include', '^nix/'], | ||
18 | ], | ||
19 | }], | ||
20 | - ['use_qt==1 and target_arch=="ia32"', { | ||
21 | + ['use_qt==1 and target_arch=="ia32" or target_arch=="x64"', { | ||
22 | 'sources/': [ | ||
23 | ['include', 'atomicops_internals_x86_gcc.cc'], | ||
24 | ], | ||
25 | -- | ||
26 | 2.1.3 | ||
27 | |||
diff --git a/recipes-qt/qt5/qtwebengine_5.4.0.bb b/recipes-qt/qt5/qtwebengine_5.4.0.bb index 85ac3979..e74a7397 100644 --- a/recipes-qt/qt5/qtwebengine_5.4.0.bb +++ b/recipes-qt/qt5/qtwebengine_5.4.0.bb | |||
@@ -8,4 +8,5 @@ SRC_URI += " \ | |||
8 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ | 8 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ |
9 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ | 9 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ |
10 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ | 10 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ |
11 | file://0001-chromium-base.gypi-include-atomicops_internals_x86_gcc.cc-whe.patch \ | ||
11 | " | 12 | " |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 31467cb9..2f10e131 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -9,6 +9,7 @@ SRC_URI += " \ | |||
9 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ | 9 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ |
10 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ | 10 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ |
11 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ | 11 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ |
12 | file://0001-chromium-base.gypi-include-atomicops_internals_x86_gcc.cc-whe.patch \ | ||
12 | " | 13 | " |
13 | SRCREV_qtwebengine = "8eefc3a0658d1b10de12f43534cfd63af825ebc8" | 14 | SRCREV_qtwebengine = "8eefc3a0658d1b10de12f43534cfd63af825ebc8" |
14 | SRCREV_chromium = "be4ec3fa64a4c6c2b641830a9811ab7847c7dd39" | 15 | SRCREV_chromium = "be4ec3fa64a4c6c2b641830a9811ab7847c7dd39" |