diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-04-12 11:40:46 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-04-12 11:42:38 +0300 |
commit | 8b905e5145b7919b4a0b61c68d3119846c4925a8 (patch) | |
tree | 3754ef46ca35d18c49f8991c65cbbb435c76c1ff | |
parent | 912db845e563f4df34f3cf761df8c563193c5044 (diff) | |
parent | 817fc2a19b63908f0628f29c2940a1dc44563ef9 (diff) | |
download | meta-qt5-8b905e5145b7919b4a0b61c68d3119846c4925a8.tar.gz |
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.9
* upstream/master:
qtchooser: respect LDFLAGS
qtbase-native: create empty oe-device-extra.pri
qtwayland: update build without xkbcommon-evdev
Change-Id: Icafabee07696be98fd6e4fa145f42df6f53863d2
-rw-r--r-- | recipes-qt/qt5/qtbase-native_git.bb | 3 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch | 39 | ||||
-rw-r--r-- | recipes-qt/qtchooser/qtchooser_git.bb | 2 |
3 files changed, 37 insertions, 7 deletions
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb index 7675eb04..ef217488 100644 --- a/recipes-qt/qt5/qtbase-native_git.bb +++ b/recipes-qt/qt5/qtbase-native_git.bb | |||
@@ -82,6 +82,9 @@ PACKAGECONFIG_CONFARGS = " \ | |||
82 | export OE_QMAKE_QTCONF_PATH = "foodummy" | 82 | export OE_QMAKE_QTCONF_PATH = "foodummy" |
83 | 83 | ||
84 | do_configure_prepend() { | 84 | do_configure_prepend() { |
85 | # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory" | ||
86 | touch ${S}/mkspecs/oe-device-extra.pri | ||
87 | |||
85 | MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -opensource -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}" | 88 | MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -opensource -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}" |
86 | } | 89 | } |
87 | 90 | ||
diff --git a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch index e1e978e8..555bb28f 100644 --- a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch +++ b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch | |||
@@ -1,13 +1,40 @@ | |||
1 | From c93dbe53e8a1b2203c750a66c7efe6fc9a326903 Mon Sep 17 00:00:00 2001 | 1 | From 2b72ad7955fe19abb4a0b4ebb6bc7aa498e454bc Mon Sep 17 00:00:00 2001 |
2 | From: Raphael Freudiger <raphael.freudiger@siemens.com> | 2 | From: Raphael Freudiger <laser_b@gmx.ch> |
3 | Date: Thu, 22 Dec 2016 13:54:31 +0100 | 3 | Date: Tue, 10 Jan 2017 15:49:55 +0100 |
4 | Subject: [PATCH] fix build without xkbcommon-evdev | 4 | Subject: [PATCH] fix build without xkbcommon-evdev |
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
5 | 8 | ||
6 | Signed-off-by: Raphael Freudiger <raphael.freudiger@siemens.com> | 9 | Change-Id: I4f52c4ad741fdd7063a18b67f5777b52f03726fe |
10 | Signed-off-by: Raphael Freudiger <laser_b@gmx.ch> | ||
11 | Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com> | ||
7 | --- | 12 | --- |
13 | src/client/client.pro | 2 ++ | ||
14 | src/compositor/compositor.pro | 2 ++ | ||
8 | src/compositor/compositor_api/qwaylandkeyboard.cpp | 13 +++++++------ | 15 | src/compositor/compositor_api/qwaylandkeyboard.cpp | 13 +++++++------ |
9 | 1 file changed, 7 insertions(+), 6 deletions(-) | 16 | 3 files changed, 11 insertions(+), 6 deletions(-) |
10 | 17 | ||
18 | diff --git a/src/client/client.pro b/src/client/client.pro | ||
19 | index 7482cfd..cb3578c 100644 | ||
20 | --- a/src/client/client.pro | ||
21 | +++ b/src/client/client.pro | ||
22 | @@ -120,3 +120,5 @@ MODULE_PLUGIN_TYPES = \ | ||
23 | wayland-decoration-client \ | ||
24 | wayland-shell-integration | ||
25 | load(qt_module) | ||
26 | + | ||
27 | +LIBS += -lxkbcommon | ||
28 | diff --git a/src/compositor/compositor.pro b/src/compositor/compositor.pro | ||
29 | index dc9000d..4eebfd6 100644 | ||
30 | --- a/src/compositor/compositor.pro | ||
31 | +++ b/src/compositor/compositor.pro | ||
32 | @@ -32,3 +32,5 @@ include ($$PWD/extensions/extensions.pri) | ||
33 | MODULE_PLUGIN_TYPES = \ | ||
34 | wayland-graphics-integration-server | ||
35 | load(qt_module) | ||
36 | + | ||
37 | +LIBS += -lxkbcommon | ||
11 | diff --git a/src/compositor/compositor_api/qwaylandkeyboard.cpp b/src/compositor/compositor_api/qwaylandkeyboard.cpp | 38 | diff --git a/src/compositor/compositor_api/qwaylandkeyboard.cpp b/src/compositor/compositor_api/qwaylandkeyboard.cpp |
12 | index 55381b4..5c054c6 100644 | 39 | index 55381b4..5c054c6 100644 |
13 | --- a/src/compositor/compositor_api/qwaylandkeyboard.cpp | 40 | --- a/src/compositor/compositor_api/qwaylandkeyboard.cpp |
@@ -40,5 +67,5 @@ index 55381b4..5c054c6 100644 | |||
40 | { | 67 | { |
41 | Q_FOREACH (Resource *resource, resourceMap()) { | 68 | Q_FOREACH (Resource *resource, resourceMap()) { |
42 | -- | 69 | -- |
43 | 2.1.4 | 70 | 2.9.3 |
44 | 71 | ||
diff --git a/recipes-qt/qtchooser/qtchooser_git.bb b/recipes-qt/qtchooser/qtchooser_git.bb index 68b1c808..f7656450 100644 --- a/recipes-qt/qtchooser/qtchooser_git.bb +++ b/recipes-qt/qtchooser/qtchooser_git.bb | |||
@@ -16,7 +16,7 @@ PV = "39+git${SRCREV}" | |||
16 | inherit pkgconfig | 16 | inherit pkgconfig |
17 | 17 | ||
18 | do_compile() { | 18 | do_compile() { |
19 | oe_runmake | 19 | oe_runmake LFLAGS='${LDFLAGS}' |
20 | } | 20 | } |
21 | 21 | ||
22 | do_install() { | 22 | do_install() { |