summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-12-22 16:45:50 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-23 19:40:35 +0000
commit77edae59c3fae1e0f23fced2e7c0ce206ff64065 (patch)
tree02a3b89cb9f5a2597861792b502933a85e9c37e3
parentd45b966b4612fe59ac3c53e0f7a3c480d29b2fbe (diff)
downloadmeta-qt5-77edae59c3fae1e0f23fced2e7c0ce206ff64065.tar.gz
qtconnectivity: drop patch resolved upstream
* resolved in upstream commit: commit 2a52a400d6692b4f42d955302dee651646664385 Author: Alex Blasche <alexander.blasche@qt.io> Date: Wed Aug 29 10:02:58 2018 +0200 Fix bluez config test failure on clang Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtconnectivity/0001-Ignore-clang-warning-about-address-of-temp-in-config.patch40
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
2 files changed, 0 insertions, 42 deletions
diff --git a/recipes-qt/qt5/qtconnectivity/0001-Ignore-clang-warning-about-address-of-temp-in-config.patch b/recipes-qt/qt5/qtconnectivity/0001-Ignore-clang-warning-about-address-of-temp-in-config.patch
deleted file mode 100644
index a0c2ee72..00000000
--- a/recipes-qt/qt5/qtconnectivity/0001-Ignore-clang-warning-about-address-of-temp-in-config.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 162749d36f4bdea62d456516ae2bbcdc84b9ba87 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 6 Dec 2018 13:21:23 -0800
4Subject: [PATCH] Ignore clang warning about address of temp in
5 config.tests/bluez
6
7There is a similar error with gcc which is suppressed by using
8-fpermissive, clang however is more concerned and has specific flag for
9it, this flag is not implemented in gcc so we can not use it via general
10cmdline options to compiler, so resort to using diagnostic pragma
11
12Upstream-Status: Pending
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 config.tests/bluez/main.cpp | 3 +++
17 1 file changed, 3 insertions(+)
18
19diff --git a/config.tests/bluez/main.cpp b/config.tests/bluez/main.cpp
20index 3fe5ee09..8d1c968a 100644
21--- a/config.tests/bluez/main.cpp
22+++ b/config.tests/bluez/main.cpp
23@@ -30,11 +30,14 @@
24
25 int main()
26 {
27+#pragma clang diagnostic push
28+#pragma clang diagnostic ignored "-Waddress-of-temporary"
29 #ifdef BDADDR_NONE
30 bacmp(BDADDR_ANY, BDADDR_NONE);
31 #else
32 bacmp(BDADDR_ANY, BDADDR_LOCAL);
33 #endif
34+#pragma clang diagnostic pop
35
36 return 0;
37 }
38--
392.19.2
40
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index edf93a9f..f2e00751 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -20,5 +20,3 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
20EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" 20EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
21 21
22SRCREV = "e9967647ffe20df0473a1fa9eb10957b4e32fbf3" 22SRCREV = "e9967647ffe20df0473a1fa9eb10957b4e32fbf3"
23
24SRC_URI += "file://0001-Ignore-clang-warning-about-address-of-temp-in-config.patch"