summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-07-04 10:20:19 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-21 21:01:45 +0000
commit725fc1f98e0140dad5d03725c80fa096f2886c0b (patch)
tree6bd32e5768b8d065f67c3237b34a37124a27f7ca
parentb7b0a78d8e5aef81f3cc1089318293d1f238e7df (diff)
downloadmeta-qt5-725fc1f98e0140dad5d03725c80fa096f2886c0b.tar.gz
qtxmlpatterns: add qtdeclarative PACKAGECONFIG
Signed-off-by: Mikko Gronoff <mikko.gronoff@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 1957fafd..d9a1a9a9 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -14,6 +14,17 @@ LIC_FILES_CHKSUM = " \
14 14
15DEPENDS += "qtbase" 15DEPENDS += "qtbase"
16 16
17PACKAGECONFIG ?= ""
18PACKAGECONFIG_class-target ?= "qtdeclarative"
19PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
20
21do_configure_prepend() {
22 # disable qtdeclarative test if it isn't enabled by PACKAGECONFIG
23 sed -e 's/qtHaveModule(qml)/OE_QTDECLARATIVE_ENABLED/' -i ${S}/src/src.pro
24}
25
26EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
27
17SRCREV = "274f162fd41c4de88df7efda9e6ec16a1ca968bc" 28SRCREV = "274f162fd41c4de88df7efda9e6ec16a1ca968bc"
18 29
19BBCLASSEXTEND =+ "native nativesdk" 30BBCLASSEXTEND =+ "native nativesdk"