diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-11-15 13:12:39 +0200 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-11-15 13:29:36 +0000 |
commit | 7132e0eeaa39c86fc1845a4c402bea2b00eb1332 (patch) | |
tree | 4269ba0e069aa4cf599d5f8133f7c66620329519 | |
parent | c43892aa24fd3c1ac1e734209f7e0748646eed7d (diff) | |
download | meta-qt5-7132e0eeaa39c86fc1845a4c402bea2b00eb1332.tar.gz |
qt5: update submodules to 5.9.3 RC
Task-number: QTBUG-64216
Change-Id: Id6370798c5f62ce963ccec4190e7fef151b79f6d
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r-- | recipes-qt/qt5/nativesdk-qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qt3d_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtdeclarative_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtgraphicaleffects_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtlocation_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquickcontrols2_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtscxml_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebchannel_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 4 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebview_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtx11extras_git.bb | 2 |
13 files changed, 14 insertions, 14 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb index 7bd0f9da..5b943595 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bb +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb | |||
@@ -197,4 +197,4 @@ fakeroot do_generate_qt_environment_file() { | |||
197 | 197 | ||
198 | addtask generate_qt_environment_file after do_install before do_package | 198 | addtask generate_qt_environment_file after do_install before do_package |
199 | 199 | ||
200 | SRCREV = "39355daa40438eef386ce55f02e7ba9ff824993f" | 200 | SRCREV = "4870282117b43242d9c2cd6fbde8175b2a907b08" |
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb index 4a969e07..8a6d2714 100644 --- a/recipes-qt/qt5/qt3d_git.bb +++ b/recipes-qt/qt5/qt3d_git.bb | |||
@@ -37,6 +37,6 @@ do_configure_prepend() { | |||
37 | ${S}/src/quick3d/imports/input/importsinput.pro | 37 | ${S}/src/quick3d/imports/input/importsinput.pro |
38 | } | 38 | } |
39 | 39 | ||
40 | SRCREV = "252d2e5f2a237862cc50f926f66184d499298239" | 40 | SRCREV = "6399bcf7a9564f3566e160803f6f2837ce8727af" |
41 | 41 | ||
42 | BBCLASSEXTEND += "native nativesdk" | 42 | BBCLASSEXTEND += "native nativesdk" |
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb index e566709d..df4caccf 100644 --- a/recipes-qt/qt5/qtbase-native_git.bb +++ b/recipes-qt/qt5/qtbase-native_git.bb | |||
@@ -125,4 +125,4 @@ do_install() { | |||
125 | echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake | 125 | echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake |
126 | } | 126 | } |
127 | 127 | ||
128 | SRCREV = "39355daa40438eef386ce55f02e7ba9ff824993f" | 128 | SRCREV = "4870282117b43242d9c2cd6fbde8175b2a907b08" |
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index 97cfc13d..3c57275e 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -228,4 +228,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps" | |||
228 | 228 | ||
229 | RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" | 229 | RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" |
230 | 230 | ||
231 | SRCREV = "39355daa40438eef386ce55f02e7ba9ff824993f" | 231 | SRCREV = "4870282117b43242d9c2cd6fbde8175b2a907b08" |
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb index 91916673..63154711 100644 --- a/recipes-qt/qt5/qtdeclarative_git.bb +++ b/recipes-qt/qt5/qtdeclarative_git.bb | |||
@@ -30,6 +30,6 @@ do_install_append_class-nativesdk() { | |||
30 | 30 | ||
31 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" | 31 | EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" |
32 | 32 | ||
33 | SRCREV = "54f15f5df5cf545bf4d675ccbafecd482b4a2b0b" | 33 | SRCREV = "d188cdd7378e0e8b384fa812b5907638075d1206" |
34 | 34 | ||
35 | BBCLASSEXTEND =+ "native nativesdk" | 35 | BBCLASSEXTEND =+ "native nativesdk" |
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb index ac06fe7b..ad5a36f5 100644 --- a/recipes-qt/qt5/qtgraphicaleffects_git.bb +++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb | |||
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = "" | |||
18 | # http://errors.yoctoproject.org/Errors/Build/44912/ | 18 | # http://errors.yoctoproject.org/Errors/Build/44912/ |
19 | LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" | 19 | LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
20 | 20 | ||
21 | SRCREV = "7ab12ad1483607cf3f007c591e998f40f2ec9513" | 21 | SRCREV = "cb007fee657f8bc2e48c3c1969834114e06a4307" |
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb index ce028087..5f11b319 100644 --- a/recipes-qt/qt5/qtlocation_git.bb +++ b/recipes-qt/qt5/qtlocation_git.bb | |||
@@ -29,7 +29,7 @@ SRC_URI += " \ | |||
29 | ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \ | 29 | ${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \ |
30 | " | 30 | " |
31 | 31 | ||
32 | SRCREV_qtlocation = "714145e7017afb74a23548ee9df2eff30536cfde" | 32 | SRCREV_qtlocation = "64e8ed5fa20d343904a27ad86411223504367e89" |
33 | SRCREV_qtlocation-mapboxgl = "a2120304a881507ed60c3199925946c1df06b44c" | 33 | SRCREV_qtlocation-mapboxgl = "a2120304a881507ed60c3199925946c1df06b44c" |
34 | 34 | ||
35 | SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl" | 35 | SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl" |
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb index e0d187a8..522f1d7d 100644 --- a/recipes-qt/qt5/qtquickcontrols2_git.bb +++ b/recipes-qt/qt5/qtquickcontrols2_git.bb | |||
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \ | |||
10 | 10 | ||
11 | DEPENDS += "qtdeclarative" | 11 | DEPENDS += "qtdeclarative" |
12 | 12 | ||
13 | SRCREV = "d92fdd989fb0355f866356625cf7f68f06cf8280" | 13 | SRCREV = "2eb1d259c6441faa62dc1834664e71995dca9165" |
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb index e4ddbce1..43906608 100644 --- a/recipes-qt/qt5/qtscxml_git.bb +++ b/recipes-qt/qt5/qtscxml_git.bb | |||
@@ -10,7 +10,7 @@ require qt5-git.inc | |||
10 | 10 | ||
11 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native" | 11 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native" |
12 | 12 | ||
13 | SRCREV = "113b502b194d6d7573b9f86f400bdf481e98cf74" | 13 | SRCREV = "04a0d00d41087c431626cc82f6f01297b6d31e1d" |
14 | 14 | ||
15 | # Patches from https://github.com/meta-qt5/qtscxml/commits/b5.9 | 15 | # Patches from https://github.com/meta-qt5/qtscxml/commits/b5.9 |
16 | # 5.9.meta-qt5.2 | 16 | # 5.9.meta-qt5.2 |
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb index 0349d984..e47ef9fd 100644 --- a/recipes-qt/qt5/qtwebchannel_git.bb +++ b/recipes-qt/qt5/qtwebchannel_git.bb | |||
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \ | |||
12 | 12 | ||
13 | DEPENDS += "qtdeclarative qtwebsockets" | 13 | DEPENDS += "qtdeclarative qtwebsockets" |
14 | 14 | ||
15 | SRCREV = "87044174033f141d8d333e2a442d826d87db0415" | 15 | SRCREV = "10a2704788f0bdf8dad3f7872db11f76ca2f4a18" |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index b5f0a098..0f40202b 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -162,8 +162,8 @@ SRC_URI_append_libc-musl = "\ | |||
162 | file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \ | 162 | file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \ |
163 | " | 163 | " |
164 | 164 | ||
165 | SRCREV_qtwebengine = "a87049cd7e188ea2185cf467765b60cb9de1210e" | 165 | SRCREV_qtwebengine = "bc6915f0ae19a5bd5223b2b722c4c7f684972e4f" |
166 | SRCREV_chromium = "c394f9bd67128f67bb26bbb47254549ea23a099f" | 166 | SRCREV_chromium = "a83d8cdb8d8361eadb86ac48d020486f56543114" |
167 | SRCREV = "${SRCREV_qtwebengine}" | 167 | SRCREV = "${SRCREV_qtwebengine}" |
168 | 168 | ||
169 | SRCREV_FORMAT = "qtwebengine_chromium" | 169 | SRCREV_FORMAT = "qtwebengine_chromium" |
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb index 4377b78b..e419ab67 100644 --- a/recipes-qt/qt5/qtwebview_git.bb +++ b/recipes-qt/qt5/qtwebview_git.bb | |||
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)" | |||
19 | COMPATIBLE_MACHINE_armv7ve = "(.*)" | 19 | COMPATIBLE_MACHINE_armv7ve = "(.*)" |
20 | COMPATIBLE_MACHINE_aarch64 = "(.*)" | 20 | COMPATIBLE_MACHINE_aarch64 = "(.*)" |
21 | 21 | ||
22 | SRCREV = "71932e381ee12528f6516f61c5467f322d8ee903" | 22 | SRCREV = "abc6a559f2369e82018568ece2b2dcce268e3777" |
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb index 7276a7e9..ed504dc9 100644 --- a/recipes-qt/qt5/qtx11extras_git.bb +++ b/recipes-qt/qt5/qtx11extras_git.bb | |||
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \ | |||
13 | 13 | ||
14 | DEPENDS += "qtbase" | 14 | DEPENDS += "qtbase" |
15 | 15 | ||
16 | SRCREV = "f21ef0cd01ccf1ccdbb2211eb935aff402741969" | 16 | SRCREV = "2ee45df917c1c3b93a4584d5bb3e887dba55fed8" |