diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-02-10 09:22:31 +0200 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-02-10 14:03:32 +0200 |
commit | 251beba0ca5f7fae85b8fd9c20851c53347c9722 (patch) | |
tree | 6e2a334753d8bfb04e17a4b9ca56f89773a337e1 | |
parent | 1c88e9b361b9df92edf27b7d23f1bc3f07e784a3 (diff) | |
parent | 8ba28144d5571504112fd4f32c7bfcbac531e2cb (diff) | |
download | meta-qt5-251beba0ca5f7fae85b8fd9c20851c53347c9722.tar.gz |
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.85.8
* qtyocto/upstream/master:
qtwebengine: disable generate_character_data
qtwayland: fix build without xkbcommon-evdev
qtwayland: Add libxkbcommon in the dependencies
qtbase: create empty oe-device-extra.pri
cmake_qt5.bbclass: add qtbase-native to DEPENDS
Upgrade to Qt 5.8
qtbase: Remove comments about ICU and QtWebKit
qtwebkit: Always enable icu in QT_CONFIG
qtwebengine: use QT_GIT_PROTOCOL variable
Conflicts:
recipes-qt/qt5/qtbase_git.bb
recipes-qt/qt5/qtwayland_git.bb
Change-Id: I8929585c07f462b7ff28c0342386d4114c0c0ee2
-rw-r--r-- | classes/cmake_qt5.bbclass | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 8 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch | 44 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwayland_git.bb | 4 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 4 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit_git.bb | 3 |
6 files changed, 57 insertions, 8 deletions
diff --git a/classes/cmake_qt5.bbclass b/classes/cmake_qt5.bbclass index 3180fd6d..5d605a68 100644 --- a/classes/cmake_qt5.bbclass +++ b/classes/cmake_qt5.bbclass | |||
@@ -1,7 +1,7 @@ | |||
1 | inherit cmake | 1 | inherit cmake |
2 | inherit qmake5_paths | 2 | inherit qmake5_paths |
3 | 3 | ||
4 | DEPENDS_prepend = "qtbase " | 4 | DEPENDS_prepend = "qtbase qtbase-native " |
5 | 5 | ||
6 | EXTRA_OECMAKE_prepend = " \ | 6 | EXTRA_OECMAKE_prepend = " \ |
7 | -DOE_QMAKE_PATH_PREFIX=${OE_QMAKE_PATH_PREFIX} \ | 7 | -DOE_QMAKE_PATH_PREFIX=${OE_QMAKE_PATH_PREFIX} \ |
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index c9005a85..5db9aad1 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -33,10 +33,6 @@ DEPENDS += "qtbase-native" | |||
33 | RDEPENDS_${PN}-tools += "perl" | 33 | RDEPENDS_${PN}-tools += "perl" |
34 | 34 | ||
35 | # separate some parts of PACKAGECONFIG which are often changed | 35 | # separate some parts of PACKAGECONFIG which are often changed |
36 | # be aware that you need to add icu to build qtwebkit, default | ||
37 | # PACKAGECONFIG is kept rather minimal for people who don't need | ||
38 | # stuff like webkit (and it's easier to add options than remove) | ||
39 | |||
40 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}" | 36 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}" |
41 | PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}" | 37 | PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}" |
42 | PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xrender xinput2 glib xkb xkbcommon-evdev', '', d)}" | 38 | PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xrender xinput2 glib xkb xkbcommon-evdev', '', d)}" |
@@ -116,7 +112,6 @@ PACKAGECONFIG[directfb] = "-directfb,-no-directfb,directfb" | |||
116 | PACKAGECONFIG[linuxfb] = "-linuxfb,-no-linuxfb" | 112 | PACKAGECONFIG[linuxfb] = "-linuxfb,-no-linuxfb" |
117 | PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl" | 113 | PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl" |
118 | PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/mesa" | 114 | PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/mesa" |
119 | # needed for qtwebkit | ||
120 | PACKAGECONFIG[icu] = "-icu,-no-icu,icu" | 115 | PACKAGECONFIG[icu] = "-icu,-no-icu,icu" |
121 | PACKAGECONFIG[udev] = "-libudev,-no-libudev,udev" | 116 | PACKAGECONFIG[udev] = "-libudev,-no-libudev,udev" |
122 | PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl" | 117 | PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl" |
@@ -135,6 +130,9 @@ QT_CONFIG_FLAGS += " \ | |||
135 | " | 130 | " |
136 | 131 | ||
137 | do_configure() { | 132 | do_configure() { |
133 | # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory" during configuration | ||
134 | touch ${S}/mkspecs/oe-device-extra.pri | ||
135 | |||
138 | ${S}/configure -v \ | 136 | ${S}/configure -v \ |
139 | -opensource -confirm-license \ | 137 | -opensource -confirm-license \ |
140 | -sysroot ${STAGING_DIR_TARGET} \ | 138 | -sysroot ${STAGING_DIR_TARGET} \ |
diff --git a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch new file mode 100644 index 00000000..e1e978e8 --- /dev/null +++ b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From c93dbe53e8a1b2203c750a66c7efe6fc9a326903 Mon Sep 17 00:00:00 2001 | ||
2 | From: Raphael Freudiger <raphael.freudiger@siemens.com> | ||
3 | Date: Thu, 22 Dec 2016 13:54:31 +0100 | ||
4 | Subject: [PATCH] fix build without xkbcommon-evdev | ||
5 | |||
6 | Signed-off-by: Raphael Freudiger <raphael.freudiger@siemens.com> | ||
7 | --- | ||
8 | src/compositor/compositor_api/qwaylandkeyboard.cpp | 13 +++++++------ | ||
9 | 1 file changed, 7 insertions(+), 6 deletions(-) | ||
10 | |||
11 | diff --git a/src/compositor/compositor_api/qwaylandkeyboard.cpp b/src/compositor/compositor_api/qwaylandkeyboard.cpp | ||
12 | index 55381b4..5c054c6 100644 | ||
13 | --- a/src/compositor/compositor_api/qwaylandkeyboard.cpp | ||
14 | +++ b/src/compositor/compositor_api/qwaylandkeyboard.cpp | ||
15 | @@ -338,12 +338,6 @@ void QWaylandKeyboardPrivate::createXKBState(xkb_keymap *keymap) | ||
16 | xkb_state = xkb_state_new(keymap); | ||
17 | } | ||
18 | |||
19 | -uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode) | ||
20 | -{ | ||
21 | - const uint offset = 8; | ||
22 | - Q_ASSERT(nativeScanCode >= offset); | ||
23 | - return nativeScanCode - offset; | ||
24 | -} | ||
25 | |||
26 | void QWaylandKeyboardPrivate::createXKBKeymap() | ||
27 | { | ||
28 | @@ -373,6 +367,13 @@ void QWaylandKeyboardPrivate::createXKBKeymap() | ||
29 | } | ||
30 | #endif | ||
31 | |||
32 | +uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode) | ||
33 | +{ | ||
34 | + const uint offset = 8; | ||
35 | + Q_ASSERT(nativeScanCode >= offset); | ||
36 | + return nativeScanCode - offset; | ||
37 | +} | ||
38 | + | ||
39 | void QWaylandKeyboardPrivate::sendRepeatInfo() | ||
40 | { | ||
41 | Q_FOREACH (Resource *resource, resourceMap()) { | ||
42 | -- | ||
43 | 2.1.4 | ||
44 | |||
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb index ec41922a..d42d80a0 100644 --- a/recipes-qt/qt5/qtwayland_git.bb +++ b/recipes-qt/qt5/qtwayland_git.bb | |||
@@ -2,6 +2,7 @@ require qt5.inc | |||
2 | require qt5-git.inc | 2 | require qt5-git.inc |
3 | 3 | ||
4 | DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native" | 4 | DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native" |
5 | DEPENDS_append_class-target = " libxkbcommon" | ||
5 | 6 | ||
6 | LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )" | 7 | LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )" |
7 | LIC_FILES_CHKSUM = " \ | 8 | LIC_FILES_CHKSUM = " \ |
@@ -42,4 +43,7 @@ EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" | |||
42 | 43 | ||
43 | SRCREV = "0e2a950895805457a45abe860bc91a7cc4ba405e" | 44 | SRCREV = "0e2a950895805457a45abe860bc91a7cc4ba405e" |
44 | 45 | ||
46 | # From https://bugreports.qt.io/browse/QTBUG-57767 | ||
47 | SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch" | ||
48 | |||
45 | BBCLASSEXTEND =+ "native nativesdk" | 49 | BBCLASSEXTEND =+ "native nativesdk" |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 5efc35d5..3d139d0b 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -24,7 +24,7 @@ DEPENDS += " \ | |||
24 | " | 24 | " |
25 | 25 | ||
26 | DEPENDS += "yasm-native" | 26 | DEPENDS += "yasm-native" |
27 | EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm" | 27 | EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm GYP_CONFIG+=generate_character_data=0" |
28 | 28 | ||
29 | # To use system ffmpeg you need to enable also libwebp, opus, vpx | 29 | # To use system ffmpeg you need to enable also libwebp, opus, vpx |
30 | # Only depenedencies available in oe-core are enabled by default | 30 | # Only depenedencies available in oe-core are enabled by default |
@@ -105,7 +105,7 @@ RDEPENDS_${PN}-examples += " \ | |||
105 | QT_MODULE_BRANCH_CHROMIUM = "53-based" | 105 | QT_MODULE_BRANCH_CHROMIUM = "53-based" |
106 | 106 | ||
107 | SRC_URI += " \ | 107 | SRC_URI += " \ |
108 | ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};destsuffix=git/src/3rdparty \ | 108 | ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ |
109 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ | 109 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ |
110 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ | 110 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ |
111 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ | 111 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ |
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb index bf5c00ae..4845d0fd 100644 --- a/recipes-qt/qt5/qtwebkit_git.bb +++ b/recipes-qt/qt5/qtwebkit_git.bb | |||
@@ -64,6 +64,9 @@ do_configure_prepend() { | |||
64 | sed -e 's/\s\(config_fontconfig: \)/ OE_FONTCONFIG_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf | 64 | sed -e 's/\s\(config_fontconfig: \)/ OE_FONTCONFIG_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf |
65 | } | 65 | } |
66 | 66 | ||
67 | # Forcibly enable ICU, so qtbase doesn't need it. | ||
68 | EXTRA_QMAKEVARS_PRE += "QT_CONFIG+=icu" | ||
69 | |||
67 | # qtwebkit gets terribly big when linking with all debug info, disable by default | 70 | # qtwebkit gets terribly big when linking with all debug info, disable by default |
68 | QTWEBKIT_DEBUG = "QMAKE_CFLAGS+=-g0 QMAKE_CXXFLAGS+=-g0" | 71 | QTWEBKIT_DEBUG = "QMAKE_CFLAGS+=-g0 QMAKE_CXXFLAGS+=-g0" |
69 | EXTRA_QMAKEVARS_PRE += "${QTWEBKIT_DEBUG}" | 72 | EXTRA_QMAKEVARS_PRE += "${QTWEBKIT_DEBUG}" |