summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-01-26 00:03:30 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2019-02-14 17:40:27 +0000
commit080cc294b7e28eb4c77ccd2a3ea4d07b34c61738 (patch)
tree7882f07665a90d6b5606bd42e17999b8211816f1
parentf6f61b07a4eae4c0d6540c7909cf009431cca80b (diff)
downloadmeta-qt5-080cc294b7e28eb4c77ccd2a3ea4d07b34c61738.tar.gz
qtwayland: workaround upstream bug: install missing headers manually
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index a1b38de2..8f901ad7 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -46,3 +46,20 @@ BBCLASSEXTEND =+ "native nativesdk"
46LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" 46LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
47 47
48SRC_URI += "file://0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch" 48SRC_URI += "file://0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch"
49
50# Since version 5.11.2 some private headers are not installed. Work around
51# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for
52# further details
53do_install_append() {
54 if [ -d "${B}/src/client" ]; then
55 upstream_pv=`echo "${PV}" | sed 's:+git.*::g'`
56 for header in `find ${B}/src/client -name '*wayland-*.h'`; do
57 header_base=`basename $header`
58 dest="${D}${includedir}/QtWaylandClient/$upstream_pv/QtWaylandClient/private/$header_base"
59 if [ ! -e "$dest" ]; then
60 echo "Manual install: $header_base to $dest"
61 install -m 644 "$header" "$dest"
62 fi
63 done
64 fi
65}