summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeokha Ko <sukdo399@daum.net>2018-12-02 16:20:53 +0900
committerOtavio Salvador <otavio@ossystems.com.br>2018-12-07 06:37:33 -0200
commit010a29e0ab5eb2a7efde98ee0a4f78884281bc09 (patch)
tree8a2e98773eacc9edb24edd65baa3d59a0e664efb
parentf22750291b224a3ee68456f0319ba18d428e197a (diff)
downloadmeta-qt5-010a29e0ab5eb2a7efde98ee0a4f78884281bc09.tar.gz
qmllive: add new recipe
qmlLive is a live reloader environment for rapid UI development Change-Id: Icc29a45ed488a95257625122107b83cbe746c755 Signed-off-by: Seokha Ko <sukdo399@daum.net>
-rw-r--r--recipes-qt/qmllive/qmllive_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-qt/qmllive/qmllive_git.bb b/recipes-qt/qmllive/qmllive_git.bb
new file mode 100644
index 00000000..bc9a3784
--- /dev/null
+++ b/recipes-qt/qmllive/qmllive_git.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "QmlLive is a live reloader environment for rapid UI development"
2HOMEPAGE = "https://github.com/qtproject/qt-apps-qmllive"
3LICENSE = "GPL-3.0"
4LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
5DEPENDS = "qtbase qtdeclarative"
6
7PV = "5.12+git${SRCPV}"
8
9QT_GIT_PROJECT = "qt-apps"
10SRC_URI = "${QT_GIT}/qmllive.git;branch=dev"
11SRCREV = "0c7bf141b08aa9e757e91a4a05769257d043eab2"
12S = "${WORKDIR}/git"
13
14inherit pkgconfig qmake5
15
16EXTRA_QMAKEVARS_POST = "QMAKE_RPATHDIR="
17
18FILES_${PN}-dev += "${datadir}"