summaryrefslogtreecommitdiffstats
path: root/recipes-qt3
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-05-09 15:55:14 -0700
committerSaul Wold <sgw@linux.intel.com>2011-05-09 15:55:14 -0700
commit422a054589a05844c9eced03abf3664ec6cd33a0 (patch)
tree6d74b031fbe1e2e11edfb400784c48bbef84a6c2 /recipes-qt3
parent302576f9b9a87a86eb156b842aa28009446102da (diff)
downloadmeta-qt3-422a054589a05844c9eced03abf3664ec6cd33a0.tar.gz
meta-qt3: move files to top level for layer
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-qt3')
-rw-r--r--recipes-qt3/images/core-image-lsb-qt3.bb10
-rw-r--r--recipes-qt3/qt3/qt-x11-free-common.inc92
-rw-r--r--recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb72
-rw-r--r--recipes-qt3/qt3/qt-x11-free/configure.patch51
-rw-r--r--recipes-qt3/qt3/qt-x11-free/gcc4_1-HACK.patch28
-rw-r--r--recipes-qt3/qt3/qt-x11-free/no-examples.patch16
-rw-r--r--recipes-qt3/qt3/qt-x11-free_3.3.6.bb13
-rw-r--r--recipes-qt3/qt3/qt-x11-free_3.3.7.bb17
-rw-r--r--recipes-qt3/tasks/task-core-qt3.bb23
9 files changed, 322 insertions, 0 deletions
diff --git a/recipes-qt3/images/core-image-lsb-qt3.bb b/recipes-qt3/images/core-image-lsb-qt3.bb
new file mode 100644
index 0000000..b7dc92e
--- /dev/null
+++ b/recipes-qt3/images/core-image-lsb-qt3.bb
@@ -0,0 +1,10 @@
1IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
2
3IMAGE_INSTALL = "\
4 ${POKY_BASE_INSTALL} \
5 task-core-basic \
6 task-core-lsb \
7 task-core-qt-mt3 \
8 "
9
10inherit core-image
diff --git a/recipes-qt3/qt3/qt-x11-free-common.inc b/recipes-qt3/qt3/qt-x11-free-common.inc
new file mode 100644
index 0000000..e486c52
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free-common.inc
@@ -0,0 +1,92 @@
1DESCRIPTION = "Qt/X11 Version ${PV} is a full fledged cross-platform application framework"
2SECTION = "x11/libs"
3PRIORITY = "optional"
4LICENSE = "GPL | QPL"
5HOMEPAGE = "http://www.trolltech.com"
6PR = "r0"
7
8S = "${WORKDIR}/qt-x11-free-${PV}"
9
10
11inherit qmake_base ${COREBASE}/meta-qt3/classes/qt3x11.bbclass
12
13export QTDIR = "${S}"
14STAGING_QT_DIR = "${STAGING_DIR_HOST}/qt3"
15ARCH_i686 = "x86"
16EXTRA_OEMAKE = "-e"
17
18QT_CONFIG_FLAGS = "-release -shared -qt-zlib -no-nas-sound -no-sm -qt-libpng -no-gif -no-xinerama \
19 -no-tablet -no-xkb -no-dlopen-opengl -no-nis -no-cups -thread -verbose"
20
21EXTRA_ENV = 'QMAKE="${STAGING_BINDIR_NATIVE}/qmake -after INCPATH+=${STAGING_INCDIR} \
22 INCPATH+=${STAGING_INCDIR}/freetype2 LIBS+=-L${STAGING_LIBDIR}" \
23 QMAKESPEC="${QMAKESPEC}" LINK="${CXX} -Wl,-rpath-link,${STAGING_LIBDIR}" \
24 AR="${TARGET_PREFIX}ar cqs" \
25 MOC="${STAGING_BINDIR_NATIVE}/moc3" UIC="${STAGING_BINDIR_NATIVE}/uic3" MAKE="make -e"'
26
27do_configure() {
28 echo "yes" | ./configure -prefix ${prefix} ${QT_CONFIG_FLAGS} -no-fast \
29 -L${STAGING_LIBDIR} -I${STAGING_INCDIR} -I${STAGING_INCDIR}/freetype2 -I${STAGING_INCDIR}/mysql
30
31 # force regenerate
32 rm -f src/qtmain.pro
33 cat Makefile >makefile
34 find . -name "Makefile"|xargs rm -f
35 (cd src && qmake -spec ${QMAKESPEC} )
36 (cd plugins/src && qmake -spec ${QMAKESPEC} )
37 (cd tools && qmake -spec ${QMAKESPEC} )
38 (cd tools/qvfb && qmake -spec ${QMAKESPEC} )
39}
40
41do_compile() {
42 unset CFLAGS
43 unset CXXFLAGS
44
45 install -m 0755 ${STAGING_BINDIR_NATIVE}/moc3 ${S}/bin/moc
46 install -m 0755 ${STAGING_BINDIR_NATIVE}/uic3 ${S}/bin/uic
47
48 oe_runmake -C src ${EXTRA_ENV}
49 oe_runmake -C plugins/src ${EXTRA_ENV}
50 oe_runmake -C tools ${EXTRA_ENV}
51}
52
53do_install_prepend() {
54 install -d ${STAGING_QT_DIR}/bin
55 ln -sf ${STAGING_BINDIR_NATIVE}/moc3 ${STAGING_QT_DIR}/bin/moc
56 ln -sf ${STAGING_BINDIR_NATIVE}/uic3 ${STAGING_QT_DIR}/bin/uic
57 ln -sf ${STAGING_BINDIR_NATIVE}/qmake ${STAGING_QT_DIR}/bin/qmake
58 install -d ${STAGING_QT_DIR}/lib
59 oe_soinstall lib/libqt-mt.so.${PV} ${STAGING_QT_DIR}/lib
60 install -d ${STAGING_QT_DIR}/include/private
61 for f in include/*.h
62 do
63 install -m 0644 $f ${STAGING_QT_DIR}/include/
64 done
65 for f in include/private/*.h
66 do
67 install -m 0644 $f ${STAGING_QT_DIR}/include/private
68 done
69 for f in lib/*.prl
70 do
71 install -m 0644 $f ${STAGING_QT_DIR}/lib
72 done
73}
74
75do_install() {
76 install -d ${D}${libdir}/
77 oe_soinstall lib/libqt-mt.so.${PV} ${D}${libdir}/
78 install -d ${D}${bindir}/
79 install -d ${D}${prefix}/plugins/
80 cp -pPR plugins/imageformats plugins/sqldrivers plugins/designer ${D}${prefix}/plugins/
81}
82
83PACKAGES =+ " libqt-mt3 qt-x11-plugins-imageformats qt-x11-plugins-sqldrivers qt-x11-plugins-designer \
84 qt-x11-designer qt-x11-assistant qt-x11-qvfb qt-x11-qtconfig"
85FILES_libqt-mt3 = "${D}/{libdir}/libqt-mt*"
86FILES_qt-x11-plugins-imageformats = "${prefix}/plugins/imageformats/*.so"
87FILES_qt-x11-plugins-sqldrivers = "${prefix}/plugins/sqldrivers/*.so"
88FILES_qt-x11-plugins-designer = "${prefix}/plugins/designer/*.so"
89FILES_qt-x11-designer = "${bindir}/designer"
90FILES_qt-x11-assistant = "${bindir}/assistant"
91FILES_qt-x11-qtconfig = "${bindir}/qtconfig"
92FILES_qt-x11-dbg += "${prefix}/plugins/*/.debug ${D}/qt-x11-plugins-debug"
diff --git a/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb b/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
new file mode 100644
index 0000000..e068b27
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
@@ -0,0 +1,72 @@
1DESCRIPTION = "Qt/X11 Version ${PV}"
2SECTION = "libs"
3PRIORITY = "optional"
4LICENSE = "GPL | QPL"
5DEPENDS = "xmu-native"
6HOMEPAGE = "http://www.trolltech.com"
7PR = "r0"
8
9PROVIDES += "qt-x11-free-native"
10FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/qt-x11-free"
11
12LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=629178675a7d49c9fa19dfe9f43ea256 \
13 file://LICENSE.QPL;md5=fff372435cb41647bc0b3cb940ea5c51"
14
15SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2 \
16 file://no-examples.patch"
17S = "${WORKDIR}/qt-x11-free-${PV}"
18
19#
20# FIXME - This should be updated to use OE's qmake_base.oeclass
21# or the full qmake.oeclass.
22#
23
24PROVIDES = "qt-x11-free-native"
25export QTDIR = "${S}"
26export SYSCONF_CXX = "${CCACHE} g++"
27export SYSCONF_CC = "${CCACHE} gcc"
28export SYSCONF_LINK = "${CCACHE} g++"
29THIS_QMAKESPEC = "${STAGING_DATADIR}/qmake/${TARGET_OS}-oe-g++"
30export QMAKESPEC = ""
31ARCH_i686 = "x86"
32
33QT_CONFIG_FLAGS = "-release -shared -qt-zlib -no-nas-sound -no-sm -qt-libpng -qt-gif -no-xshape -no-xinerama -no-xcursor -no-xrandr \
34 -no-xrender -no-xft -no-tablet -no-xkb -no-dlopen-opengl -no-freetype -no-nis -no-cups -stl -thread -no-exceptions"
35
36
37inherit native
38
39do_configure() {
40 echo "yes" | ./configure -prefix ${prefix} ${QT_CONFIG_FLAGS} -fast -L ${STAGING_LIBDIR} \
41 -I ${STAGING_INCDIR_NATIVE}
42}
43
44do_compile() {
45 LD_LIBRARY_PATH=${S}/lib oe_runmake \
46 QMAKE="${STAGING_BINDIR_NATIVE}/qmake -after INCLUDEPATH+=${STAGING_INCDIR} LIBS+=-L${STAGING_LIBDIR}" \
47 QMAKESPEC="${THIS_QMAKESPEC}"
48}
49
50
51do_install() {
52 install -d ${D}${bindir}/
53 install -m 0755 bin/qmake ${D}${bindir}/qmake3
54 for i in moc uic lrelease lupdate; do
55 install -m 0755 bin/${i} ${D}${bindir}/${i}3
56 done
57
58 install -d ${D}${datadir}/qt3/
59 cp -PfR mkspecs ${D}${datadir}/qt3/
60 ln -sf linux-g++ ${D}${datadir}/qt3/mkspecs/${BUILD_OS}-oe-g++
61 ln -s ${D}${datadir}/qt3/mkspecs/ ${D}${datadir}/qmake
62 install -d ${D}${libdir}/
63 oe_soinstall lib/libqt-mt.so.${PV} ${D}${libdir}/
64 cd ${D}${bindir}
65 for i in qmake moc uic lrelease lupdate;do
66 ln -s ${i}3 ${i}
67 done
68}
69
70
71SRC_URI[md5sum] = "05d04688c0c0230ed54e89102d689ca4"
72SRC_URI[sha256sum] = "aac89e862c74b2f3ead768e50e9fa7ada1e4225fe9d1d9e05723a3279259eb96"
diff --git a/recipes-qt3/qt3/qt-x11-free/configure.patch b/recipes-qt3/qt3/qt-x11-free/configure.patch
new file mode 100644
index 0000000..9d6c1e8
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free/configure.patch
@@ -0,0 +1,51 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- qt-x11-free-3.3.2/configure~configure.patch
7+++ qt-x11-free-3.3.2/configure
8@@ -1754,21 +1754,14 @@
9 CFG_FREETYPE=yes
10 fi
11 fi
12- # add freetype2 include path
13- if [ "$CFG_FREETYPE" = "yes" ] && [ -f $outpath/config.tests/x11/xft.inc ];then
14- QMAKE_VARS="$QMAKE_VARS \"INCLUDEPATH+=`cat $outpath/config.tests/x11/xft.inc`\""
15- fi
16- rm -f $outpath/config.tests/x11/xft.inc
17 # add Xft specific libraries
18 if [ "$CFG_FREETYPE" = "yes" ] && [ -f $outpath/config.tests/x11/xft.lib ]; then
19 QMAKE_VARS="$QMAKE_VARS \"QMAKE_LIBS_X11=`cat $outpath/config.tests/x11/xft.lib` \$\$QMAKE_LIBS_X11\""
20 fi
21- rm -f $outpath/config.tests/x11/xft.lib
22 # add Xft specific config options
23 if [ "$CFG_FREETYPE" = "yes" ] && [ -f $outpath/config.tests/x11/xft.cfg ]; then
24 QMAKE_CONFIG="$QMAKE_CONFIG `cat $outpath/config.tests/x11/xft.cfg`"
25 fi
26- rm -f $outpath/config.tests/x11/xft.cfg
27 # auto-detect Session Management support
28 if [ "$CFG_SM" = "auto" ]; then
29 if $x11tests/sm.test $XQMAKESPEC $OPT_VERBOSE $L_FLAGS $I_FLAGS; then
30@@ -2553,12 +2546,6 @@
31 (cd $outpath/qmake; $MAKE || (echo "qmake failed to build. Aborting." && exit 2)) || exit 2
32 fi
33
34-# clean up temporary qconfig.h and qmodules.h
35-rm -f $outpath/include/qmake/qconfig.h
36-rm -f $outpath/include/qmake/qmodules.h
37-rmdir $outpath/include/qmake
38-
39-
40 #-------------------------------------------------------------------------------
41 # tests that need qmake
42 #-------------------------------------------------------------------------------
43@@ -3605,7 +3592,7 @@
44
45 EOF
46 else
47- EXEC="$outpath/bin/qmake $QMAKE_SWITCHES $QMAKE_SPEC_ARGS -o $OUTDIR $a"
48+ EXEC="$outpath/bin/qmake $QMAKE_SWITCHES $QMAKE_SPEC_ARGS -o $OUTDIR $a $OE_EXTRA_QMAKE"
49 if [ "$OPT_VERBOSE" = "yes" ]; then
50 echo " (`basename $SPEC`)"
51 if echo '\c' | grep '\c' >/dev/null; then
diff --git a/recipes-qt3/qt3/qt-x11-free/gcc4_1-HACK.patch b/recipes-qt3/qt3/qt-x11-free/gcc4_1-HACK.patch
new file mode 100644
index 0000000..818bced
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free/gcc4_1-HACK.patch
@@ -0,0 +1,28 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- qt-x11-free-3.3.6/src/tools/qstring.h~gcc4_1.patch
7+++ qt-x11-free-3.3.6/src/tools/qstring.h
8@@ -60,7 +60,7 @@
9 #endif
10 #endif
11
12-
13+#define Q_NO_PACKED_REFERENCE
14 /*****************************************************************************
15 QString class
16 *****************************************************************************/
17@@ -194,9 +194,9 @@
18 char latin1() const { return ucs > 0xff ? 0 : (char) ucs; }
19 ushort unicode() const { return ucs; }
20 #ifdef Q_NO_PACKED_REFERENCE
21- ushort &unicode() { return *(&ucs); }
22+ ushort &unicode() { return *((ushort*)&ucs); }
23 #else
24- ushort &unicode() { return ucs; }
25+ ushort &unicode() { return (ushort)ucs; }
26 #endif
27 #ifndef QT_NO_CAST_ASCII
28 // like all ifdef'd code this is undocumented
diff --git a/recipes-qt3/qt3/qt-x11-free/no-examples.patch b/recipes-qt3/qt3/qt-x11-free/no-examples.patch
new file mode 100644
index 0000000..b0ee637
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free/no-examples.patch
@@ -0,0 +1,16 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- qt-embedded-free-3.3.2/Makefile~no-examples 2003-08-11 16:37:25.000000000 +0200
7+++ qt-embedded-free-3.3.2/Makefile 2004-05-11 15:53:53.000000000 +0200
8@@ -11,7 +11,7 @@
9 install: FORCE
10 @$(MAKE) qt.install
11
12-all: symlinks src-qmake src-moc sub-src sub-tools sub-tutorial sub-examples
13+all: symlinks src-qmake src-moc sub-src sub-tools
14 @echo
15 @echo "The Qt library is now built in ./lib"
16 @echo "The Qt examples are built in the directories in ./examples"
diff --git a/recipes-qt3/qt3/qt-x11-free_3.3.6.bb b/recipes-qt3/qt3/qt-x11-free_3.3.6.bb
new file mode 100644
index 0000000..789e6fb
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free_3.3.6.bb
@@ -0,0 +1,13 @@
1DEPENDS = "uicmoc3-native freetype virtual/libx11 libxft libxext libxrender libxrandr libxcursor mysql virtual/libgl"
2PROVIDES = "qt3x11"
3PR = "r3"
4
5SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2 \
6 file://configure.patch \
7 file://no-examples.patch \
8 file://gcc4_1-HACK.patch"
9
10require qt-x11-free-common.inc
11
12SRC_URI[md5sum] = "dc1384c03ac08af21f6fefab32d982cf"
13SRC_URI[sha256sum] = "04f12083f6a6f7a8fd4d34a6c1efd37db76a67580c424f4fb7b7c43c0565e6ae"
diff --git a/recipes-qt3/qt3/qt-x11-free_3.3.7.bb b/recipes-qt3/qt3/qt-x11-free_3.3.7.bb
new file mode 100644
index 0000000..9a3bcf9
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free_3.3.7.bb
@@ -0,0 +1,17 @@
1DEPENDS = "qt-x11-free-native freetype virtual/libx11 libxmu libxft libxext libxrender libxrandr libxcursor virtual/libgl"
2PROVIDES = "qt3x11"
3PR = "r0"
4
5PREFERRED_VERSION_qt-x11-free = 3.3.7
6LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=b07b0d5ac6b1822effe47173a1744433 \
7 file://LICENSE.QPL;md5=b81b6b6fc04ed873adde5aa901c0613b"
8
9SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2 \
10 file://configure.patch \
11 file://no-examples.patch \
12 file://gcc4_1-HACK.patch"
13
14require qt-x11-free-common.inc
15
16SRC_URI[md5sum] = "655e21cf6a7e66daf8ec6ceda81aae1e"
17SRC_URI[sha256sum] = "48c05b501029f0640db665fbc7f981a0efbf69ad3cf87a43c5eea4872f4f7ba1"
diff --git a/recipes-qt3/tasks/task-core-qt3.bb b/recipes-qt3/tasks/task-core-qt3.bb
new file mode 100644
index 0000000..81479d9
--- /dev/null
+++ b/recipes-qt3/tasks/task-core-qt3.bb
@@ -0,0 +1,23 @@
1#
2# Copyright (C) 2011 Wind River
3#
4
5DESCRIPTION = "Create qt3 Tasks"
6PR = "r0"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
9 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11PACKAGES = "\
12 task-core-qt-mt3 \
13"
14
15
16ALLOW_EMPTY = "1"
17
18
19RDEPENDS_task-core-qt-mt3 = "\
20 qt-x11-free \
21 libqt-mt3 \
22"
23