summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-10 14:09:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-10 14:10:49 +0000
commit4772424ab69908d4e3b9d6d4717ca889468e6acd (patch)
tree8448268883d0b8bc98379fc320a34e83088dc4f1
parentb73552fb998fd30a01dbee5a172e432a16078222 (diff)
downloadmeta-qt3-4772424ab69908d4e3b9d6d4717ca889468e6acd.tar.gz
Ensure the variable reaches the compilation enviroment in all cases to avoid errors like: | make[4]: Entering directory `/home/pokybuild/yocto-autobuilder/yocto-slave/nightly-ppc-lsb/build/build/tmp/work/x86_64-linux/qt-x11-free-native/3.3.5-r4/qt-x11-free-3.3.5/tools/designer/designer' | /home/pokybuild/yocto-autobuilder/yocto-slave/nightly-ppc-lsb/build/build/tmp/work/x86_64-linux/qt-x11-free-native/3.3.5-r4/qt-x11-free-3.3.5/bin/uic -L /home/pokybuild/yocto-autobuilder/yocto-slave/nightly-ppc-lsb/build/build/tmp/work/x86_64-linux/qt-x11-free-native/3.3.5-r4/qt-x11-free-3.3.5/plugins listboxeditor.ui -o listboxeditor.h | /home/pokybuild/yocto-autobuilder/yocto-slave/nightly-ppc-lsb/build/build/tmp/work/x86_64-linux/qt-x11-free-native/3.3.5-r4/qt-x11-free-3.3.5/bin/uic: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory| make[4]: *** [listboxeditor.h] Error 127 Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb b/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
index b18ea0d..e4388c4 100644
--- a/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
+++ b/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
@@ -44,7 +44,8 @@ do_configure() {
44} 44}
45 45
46do_compile() { 46do_compile() {
47 LD_LIBRARY_PATH=${S}/lib oe_runmake \ 47 export LD_LIBRARY_PATH=${S}/lib
48 oe_runmake \
48 QMAKE="${STAGING_BINDIR_NATIVE}/qmake -after INCLUDEPATH+=${STAGING_INCDIR} LIBS+=-L${STAGING_LIBDIR}" \ 49 QMAKE="${STAGING_BINDIR_NATIVE}/qmake -after INCLUDEPATH+=${STAGING_INCDIR} LIBS+=-L${STAGING_LIBDIR}" \
49 QMAKESPEC="${THIS_QMAKESPEC}" 50 QMAKESPEC="${THIS_QMAKESPEC}"
50} 51}