summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-21 17:03:21 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-21 17:07:22 +0000
commit3016129d90b7ac8517a5227d819f10ad417b5b45 (patch)
treeb8639fe6129a9a3f28c3d4361ccf91f2e35a17af
parent0fd2469d05181520e0a0c1603968f8201bca2f29 (diff)
downloadmeta-qt3-3016129d90b7ac8517a5227d819f10ad417b5b45.tar.gz
Without this we were picking up the host version (if present) and possibly failing later on due to "unsafe for cross-compilation" errors. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--recipes-qt3/qt3/qt-x11-free/qt-x11-free-3.3.8b-freetype251.patch53
-rw-r--r--recipes-qt3/qt3/qt-x11-free_3.3.7.bb3
2 files changed, 55 insertions, 1 deletions
diff --git a/recipes-qt3/qt3/qt-x11-free/qt-x11-free-3.3.8b-freetype251.patch b/recipes-qt3/qt3/qt-x11-free/qt-x11-free-3.3.8b-freetype251.patch
new file mode 100644
index 0000000..99b1fff
--- /dev/null
+++ b/recipes-qt3/qt3/qt-x11-free/qt-x11-free-3.3.8b-freetype251.patch
@@ -0,0 +1,53 @@
1Fix for FreeType 2.5.1
2
3Patch originally from Fedora.
4
5Upstream-Status: Inappropriate [unmaintained]
6
7Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
8
9diff -ur qt-x11-free-3.3.8b/config.tests/x11/xfreetype.test qt-x11-free-3.3.8b-freetype251/config.tests/x11/xfreetype.test
10--- qt-x11-free-3.3.8b/config.tests/x11/xfreetype.test 2008-01-15 20:09:15.000000000 +0100
11+++ qt-x11-free-3.3.8b-freetype251/config.tests/x11/xfreetype.test 2014-02-23 19:22:02.000000000 +0100
12@@ -116,33 +116,14 @@
13 # check for freetype2 headers
14 FREETYPE2_INCDIR=
15 if [ "$XFT" = "yes" ]; then
16- INC="freetype2/freetype/freetype.h"
17- XDIRS=`sed -n -e '/^QMAKE_INCDIR_X11[ ]*=/ { s/[^=]*=[ ]*//; s/-I/ /g; p; }' $XCONFIG`
18- LDIRS=`sed -n -e '/^QMAKE_INCDIR[ ]*=/ { s/[^=]*=[ ]*//; s/-I/ /g; p; }' $XCONFIG`
19- INCDIRS="$IN_INCDIRS $XDIRS $LDIRS /usr/include /include"
20- F=
21- for INCDIR in $INCDIRS; do
22- if [ -f $INCDIR/$INC ]; then
23- # detect major version of freetype2
24- FREETYPE_MAJOR=`grep "#define FREETYPE_MAJOR" $INCDIR/$INC | head -n 1 | awk '{ print \$3 }'`
25- FREETYPE_MINOR=`grep "#define FREETYPE_MINOR" $INCDIR/$INC | head -n 1 | awk '{ print \$3 }'`
26- FREETYPE_PATCH=`grep "#define FREETYPE_PATCH" $INCDIR/$INC | head -n 1 | awk '{ print \$3 }'`
27- test -z "$FREETYPE_PATCH" && FREETYPE_PATCH="0"
28- [ "$VERBOSE" = "yes" ] && \
29- echo " Found Freetype version $FREETYPE_MAJOR.$FREETYPE_MINOR.$FREETYPE_PATCH"
30- if [ "$FREETYPE_MAJOR" -eq "2" ] \
31- && [ "$FREETYPE_MINOR" -ge "0" -a "$FREETYPE_PATCH" -ge "9" ] \
32- || [ "$FREETYPE_MINOR" -ge "1" ]; then
33- F=yes
34- FREETYPE2_INCDIR=$INCDIR/freetype2
35- [ "$VERBOSE" = "yes" ] && echo " Found $INC in $INCDIR"
36- break
37- fi
38- fi
39- done
40- if [ -z "$F" ]; then
41- XFT=no
42- [ "$VERBOSE" = "yes" ] && echo " Could not find $INC anywhere in $INCDIRS"
43+ # minimum is freetype 2.0.9, which had libtool version 6.3.0
44+ if pkg-config --atleast-version=6.3.0 freetype2; then
45+ [ "$VERBOSE" = "yes" ] && echo " Found Freetype >= 2.0.9 using pkg-config"
46+ FREETYPE2_INCDIR=`pkg-config --cflags-only-I freetype2 | sed -e 's/^-I//g' -e 's/ -I/ /g'`
47+ [ "$VERBOSE" = "yes" ] && echo " Freetype headers in $FREETYPE2_INCDIR"
48+ else
49+ XFT=no
50+ [ "$VERBOSE" = "yes" ] && echo " Could not find Freetype >= 2.0.9 using pkg-config"
51 fi
52 fi
53
diff --git a/recipes-qt3/qt3/qt-x11-free_3.3.7.bb b/recipes-qt3/qt3/qt-x11-free_3.3.7.bb
index af4fc01..89f976d 100644
--- a/recipes-qt3/qt3/qt-x11-free_3.3.7.bb
+++ b/recipes-qt3/qt3/qt-x11-free_3.3.7.bb
@@ -9,7 +9,8 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2 \
9 file://configure.patch \ 9 file://configure.patch \
10 file://no-examples.patch \ 10 file://no-examples.patch \
11 file://gcc4_1-HACK.patch \ 11 file://gcc4_1-HACK.patch \
12 file://qt3-cstddef.patch" 12 file://qt3-cstddef.patch \
13 file://qt-x11-free-3.3.8b-freetype251.patch"
13 14
14require qt-x11-free-common.inc 15require qt-x11-free-common.inc
15 16